aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/php5-pgsql/files/patch-pgsql.c70
-rw-r--r--graphics/php5-gd/Makefile1
-rw-r--r--graphics/php5-gd/files/patch-CVE-2009-354612
-rw-r--r--lang/php5/Makefile7
-rw-r--r--lang/php5/distinfo6
-rw-r--r--lang/php5/files/patch-main_streams_xp_socket.c11
-rw-r--r--lang/php53/Makefile7
-rw-r--r--lang/php53/distinfo6
-rw-r--r--lang/php53/files/patch-main_streams_xp_socket.c11
9 files changed, 14 insertions, 117 deletions
diff --git a/databases/php5-pgsql/files/patch-pgsql.c b/databases/php5-pgsql/files/patch-pgsql.c
index ecc1fdd2f193..6ca128cb2095 100644
--- a/databases/php5-pgsql/files/patch-pgsql.c
+++ b/databases/php5-pgsql/files/patch-pgsql.c
@@ -28,73 +28,3 @@
{
register int i = strlen(message)-1;
-@@ -363,7 +366,7 @@
- if (PGG(log_notices)) {
- php_error_docref(NULL TSRMLS_CC, E_NOTICE, "%s", notice->message);
- }
-- zend_hash_index_update(&PGG(notices), (int)resource_id, (void **)&notice, sizeof(php_pgsql_notice *), NULL);
-+ zend_hash_index_update(&PGG(notices), (ulong)resource_id, (void **)&notice, sizeof(php_pgsql_notice *), NULL);
- }
- }
- /* }}} */
-@@ -761,13 +764,14 @@
- */
- if (!(connect_type & PGSQL_CONNECT_FORCE_NEW)
- && zend_hash_find(&EG(regular_list),str.c,str.len+1,(void **) &index_ptr)==SUCCESS) {
-- int type,link;
-+ int type;
-+ ulong link;
- void *ptr;
-
- if (Z_TYPE_P(index_ptr) != le_index_ptr) {
- RETURN_FALSE;
- }
-- link = (int) index_ptr->ptr;
-+ link = (uintptr_t /* ulong is as wide or wider than pointer */) index_ptr->ptr;
- ptr = zend_list_find(link,&type); /* check if the link is still there */
- if (ptr && (type==le_link || type==le_plink)) {
- Z_LVAL_P(return_value) = link;
-@@ -1748,12 +1752,15 @@
-
-
- if (return_oid) {
-+#if UINT_MAX > LONG_MAX /* Oid is unsigned int, we don't need this code, where LONG is wider */
- if (oid > LONG_MAX) {
- smart_str oidstr = {0};
- smart_str_append_unsigned(&oidstr, oid);
- smart_str_0(&oidstr);
- RETURN_STRINGL(oidstr.c, oidstr.len, 0);
-- } else {
-+ } else
-+#endif
-+ {
- RETURN_LONG((long)oid);
- }
- }
-@@ -1854,6 +1861,7 @@
-
- oid = PQftype(pgsql_result, Z_LVAL_PP(field));
-
-+#if UINT_MAX > LONG_MAX
- if (oid > LONG_MAX) {
- smart_str s = {0};
- smart_str_append_unsigned(&s, oid);
-@@ -1863,6 +1871,7 @@
- Z_TYPE_P(return_value) = IS_STRING;
- }
- else
-+#endif
- {
- Z_LVAL_P(return_value) = (long)oid;
- Z_TYPE_P(return_value) = IS_LONG;
-@@ -5741,8 +5750,8 @@
- {
- zval *row;
- char *field_name, *element, *data;
-- size_t num_fields, element_len, data_len;
-- int pg_numrows, pg_row;
-+ size_t num_fields, element_len;
-+ int pg_numrows, pg_row, data_len;
- uint i;
- assert(Z_TYPE_P(ret_array) == IS_ARRAY);
-
diff --git a/graphics/php5-gd/Makefile b/graphics/php5-gd/Makefile
index 2a8bcdd5e908..6ed41946bb21 100644
--- a/graphics/php5-gd/Makefile
+++ b/graphics/php5-gd/Makefile
@@ -6,7 +6,6 @@
#
CATEGORIES= graphics
-PORTREVISION= 2
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/graphics/php5-gd/files/patch-CVE-2009-3546 b/graphics/php5-gd/files/patch-CVE-2009-3546
deleted file mode 100644
index 2010c6829504..000000000000
--- a/graphics/php5-gd/files/patch-CVE-2009-3546
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./libgd/gd_gd.c.orig 2007-08-09 07:21:38.000000000 -0700
-+++ ./libgd/gd_gd.c 2009-11-08 23:13:19.144908056 -0800
-@@ -39,6 +39,9 @@
- if (!gdGetWord(&im->colorsTotal, in)) {
- goto fail1;
- }
-+ if (im->colorsTotal > gdMaxColors) {
-+ goto fail1;
-+ }
- }
- /* Int to accommodate truecolor single-color transparency */
- if (!gdGetInt(&im->transparent, in)) {
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index a028f827010f..69b29fd9bf5e 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.11
-PORTREVISION?= 1
+PORTVERSION= 5.2.12
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -56,7 +56,8 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
+#PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-5.2.11-0.9.7.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index a95c17a66fc1..0f0bbaba1d64 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,6 +1,6 @@
-MD5 (php-5.2.11.tar.bz2) = 286bf34630f5643c25ebcedfec5e0a09
-SHA256 (php-5.2.11.tar.bz2) = 9bcd14ceda2b4bd7abcc7eb59bd74bae490d9335e4207580de783b48aa7e8f23
-SIZE (php-5.2.11.tar.bz2) = 9030787
+MD5 (php-5.2.12.tar.bz2) = 5b7077e366c7eeab34da31dd860a1923
+SHA256 (php-5.2.12.tar.bz2) = e65756a8412726a491ca48da1e0693eaeb3f38f19fb6cbc8f53005cab1f2491a
+SIZE (php-5.2.12.tar.bz2) = 9075161
MD5 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 8f9de4d97fae6eba163cf3699509a260
SHA256 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 392f10c9b7d9c47f30e989fb7775cc46d36153b933bf7ac9ccd8826b2954584b
SIZE (suhosin-patch-5.2.11-0.9.7.patch.gz) = 23050
diff --git a/lang/php5/files/patch-main_streams_xp_socket.c b/lang/php5/files/patch-main_streams_xp_socket.c
deleted file mode 100644
index 7b4c5e15d448..000000000000
--- a/lang/php5/files/patch-main_streams_xp_socket.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/streams/xp_socket.c 2009/09/04 07:59:48 288034
-+++ main/streams/xp_socket.c 2009/09/23 10:25:54 288604
-@@ -289,7 +289,7 @@
- if (sock->socket == -1) {
- alive = 0;
- } else if (php_pollfd_for(sock->socket, PHP_POLLREADABLE|POLLPRI, &tv) > 0) {
-- if (recv(sock->socket, &buf, sizeof(buf), MSG_PEEK) != SOCK_CONN_ERR && php_socket_errno() != EWOULDBLOCK) {
-+ if (0 >= recv(sock->socket, &buf, sizeof(buf), MSG_PEEK) && php_socket_errno() != EWOULDBLOCK) {
- alive = 0;
- }
- }
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index a028f827010f..69b29fd9bf5e 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.11
-PORTREVISION?= 1
+PORTVERSION= 5.2.12
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -56,7 +56,8 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
+#PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.7.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-5.2.11-0.9.7.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index a95c17a66fc1..0f0bbaba1d64 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,6 +1,6 @@
-MD5 (php-5.2.11.tar.bz2) = 286bf34630f5643c25ebcedfec5e0a09
-SHA256 (php-5.2.11.tar.bz2) = 9bcd14ceda2b4bd7abcc7eb59bd74bae490d9335e4207580de783b48aa7e8f23
-SIZE (php-5.2.11.tar.bz2) = 9030787
+MD5 (php-5.2.12.tar.bz2) = 5b7077e366c7eeab34da31dd860a1923
+SHA256 (php-5.2.12.tar.bz2) = e65756a8412726a491ca48da1e0693eaeb3f38f19fb6cbc8f53005cab1f2491a
+SIZE (php-5.2.12.tar.bz2) = 9075161
MD5 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 8f9de4d97fae6eba163cf3699509a260
SHA256 (suhosin-patch-5.2.11-0.9.7.patch.gz) = 392f10c9b7d9c47f30e989fb7775cc46d36153b933bf7ac9ccd8826b2954584b
SIZE (suhosin-patch-5.2.11-0.9.7.patch.gz) = 23050
diff --git a/lang/php53/files/patch-main_streams_xp_socket.c b/lang/php53/files/patch-main_streams_xp_socket.c
deleted file mode 100644
index 7b4c5e15d448..000000000000
--- a/lang/php53/files/patch-main_streams_xp_socket.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- main/streams/xp_socket.c 2009/09/04 07:59:48 288034
-+++ main/streams/xp_socket.c 2009/09/23 10:25:54 288604
-@@ -289,7 +289,7 @@
- if (sock->socket == -1) {
- alive = 0;
- } else if (php_pollfd_for(sock->socket, PHP_POLLREADABLE|POLLPRI, &tv) > 0) {
-- if (recv(sock->socket, &buf, sizeof(buf), MSG_PEEK) != SOCK_CONN_ERR && php_socket_errno() != EWOULDBLOCK) {
-+ if (0 >= recv(sock->socket, &buf, sizeof(buf), MSG_PEEK) && php_socket_errno() != EWOULDBLOCK) {
- alive = 0;
- }
- }