aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/boehm-gc/Makefile35
-rw-r--r--devel/boehm-gc/distinfo6
-rw-r--r--devel/boehm-gc/pkg-plist6
-rw-r--r--devel/dparser/Makefile2
-rw-r--r--devel/shards/Makefile2
-rw-r--r--devel/shedskin/Makefile2
-rw-r--r--editors/zile/Makefile2
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--games/aisleriot/Makefile2
-rw-r--r--games/trackballs/Makefile2
-rw-r--r--graphics/graphviz/Makefile2
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--lang/crystal/Makefile1
-rw-r--r--lang/ecl/Makefile2
-rw-r--r--lang/guile2/Makefile2
-rw-r--r--lang/mdk/Makefile2
-rw-r--r--lang/neko/Makefile2
-rw-r--r--lang/oo2c/Makefile2
-rw-r--r--lang/sagittarius-scheme/Makefile2
-rw-r--r--lang/see/Makefile2
-rw-r--r--math/asymptote/Makefile2
-rw-r--r--net-im/freetalk/Makefile2
-rw-r--r--net-im/gale/Makefile2
-rw-r--r--science/meep/Makefile2
-rw-r--r--textproc/chpp/Makefile2
-rw-r--r--www/w3m/Makefile1
26 files changed, 42 insertions, 49 deletions
diff --git a/devel/boehm-gc/Makefile b/devel/boehm-gc/Makefile
index c2cfcc79ba85..7ed8f7cd7002 100644
--- a/devel/boehm-gc/Makefile
+++ b/devel/boehm-gc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gc
-PORTVERSION= 7.6.6
+PORTVERSION= 7.6.8
CATEGORIES= devel
MASTER_SITES= http://www.hboehm.info/gc/gc_source/ \
https://github.com/ivmai/bdwgc/releases/download/v${PORTVERSION}/
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= boehm-
PKGNAMESUFFIX= -${GC_VARIANT}
.endif
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yasu@utahime.org
COMMENT= Garbage collection and memory leak detection for C and C++
LICENSE= BDWGC
@@ -36,46 +36,40 @@ WRKSRC= ${WRKDIR}/${DISTNAME:C/[a-z]$//}
OPTIONS_DEFINE= DEBUG
.ifdef GC_VARIANT
+INSTALL_TARGET= install-exec install-pkgconfigDATA
CORDLIBS= cord
GCLIBS= gc
GCCPPLIBS= gccpp
PLIST= ${NONEXISTENT}
PLIST_FILES= ${CORDLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so,} \
${CORDLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1,} \
- ${CORDLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.0,} \
+ ${CORDLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.1,} \
${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so,} \
${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1,} \
- ${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.3,} \
+ ${GCLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.4,} \
${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so,} \
${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1,} \
- ${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.1,} \
+ ${GCCPPLIBS:S,^,lib/lib,:S,$,-${GC_VARIANT}.so.1.3.2,} \
libdata/pkgconfig/bdw-gc-${GC_VARIANT}.pc
RUN_DEPENDS+= ${LOCALBASE}/include/gc/gc.h:devel/boehm-gc
. if ${GC_VARIANT} == "redirect"
-CONFIGURE_ARGS+=--disable-threads --enable-redirect-malloc
+CONFIGURE_ARGS+= --disable-threads --enable-redirect-malloc
. endif
. if ${GC_VARIANT} == "threaded"
-CONFIGURE_ARGS+=--enable-threads=posix --disable-redirect-malloc
-OPTIONS_DEFINE+=PARALLEL_MARK
+CONFIGURE_ARGS+= --enable-threads=posix --disable-redirect-malloc
+OPTIONS_DEFINE+= PARALLEL_MARK
PARALLEL_MARK_DESC= Parallel-thread marking (faster for SMP)
. endif
.else
-CONFIGURE_ARGS+=--disable-threads --disable-redirect-malloc
-OPTIONS_DEFINE+=DOCS
+CONFIGURE_ARGS+= --disable-threads --disable-redirect-malloc
+OPTIONS_DEFINE+= DOCS
PORTDOCS= *
.endif
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+=--enable-gc-debug
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+fulldebug
-.endif
+DEBUG_CONFIGURE_WITH= --enable-gc-debug
.if defined(GC_VARIANT) && ${GC_VARIANT} == "threaded"
-. if ${PORT_OPTIONS:MPARALLEL_MARK}
-CONFIGURE_ARGS+=--enable-parallel-mark
-. endif
+PARALLEL_MARK_CONFIGURE_WITH= --enable-parallel-mark
.endif
.ifdef GC_VARIANT
@@ -88,8 +82,6 @@ post-patch:
's,-lgc,-lgc-${GC_VARIANT},' ${WRKSRC}/bdw-gc.pc.in
post-install:
- ${RM} -r ${STAGEDIR}${PREFIX}/include
- ${RM} -r ${STAGEDIR}${PREFIX}/share
${MV} ${STAGEDIR}${PREFIX}/libdata/pkgconfig/bdw-gc.pc \
${STAGEDIR}${PREFIX}/libdata/pkgconfig/bdw-gc-${GC_VARIANT}.pc
@@ -101,7 +93,6 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/gc.man ${STAGEDIR}${MAN3PREFIX}/man/man3/gc.3
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
diff --git a/devel/boehm-gc/distinfo b/devel/boehm-gc/distinfo
index b4e7cb987fdc..934aeab2064e 100644
--- a/devel/boehm-gc/distinfo
+++ b/devel/boehm-gc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1527622888
-SHA256 (gc-7.6.6.tar.gz) = e968edf8f80d83284dd473e00a5e3377addc2df261ffb7e6dc77c9a34a0039dc
-SIZE (gc-7.6.6.tar.gz) = 1122848
+TIMESTAMP = 1534086510
+SHA256 (gc-7.6.8.tar.gz) = 040ac5cdbf1bebc7c8cd4928996bbae0c54497c151ea5639838fa0128102e258
+SIZE (gc-7.6.8.tar.gz) = 1128462
diff --git a/devel/boehm-gc/pkg-plist b/devel/boehm-gc/pkg-plist
index 4d91a3c5d20e..707b5127489d 100644
--- a/devel/boehm-gc/pkg-plist
+++ b/devel/boehm-gc/pkg-plist
@@ -21,12 +21,12 @@ include/gc/weakpointer.h
include/gc_cpp.h
lib/libcord.so
lib/libcord.so.1
-lib/libcord.so.1.3.0
+lib/libcord.so.1.3.1
lib/libgc.so
lib/libgc.so.1
-lib/libgc.so.1.3.3
+lib/libgc.so.1.3.4
lib/libgccpp.so
lib/libgccpp.so.1
-lib/libgccpp.so.1.3.1
+lib/libgccpp.so.1.3.2
libdata/pkgconfig/bdw-gc.pc
man/man3/gc.3.gz
diff --git a/devel/dparser/Makefile b/devel/dparser/Makefile
index dedafde0e518..607f9b3ac8f5 100644
--- a/devel/dparser/Makefile
+++ b/devel/dparser/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dparser
PORTVERSION= 1.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/
DISTNAME= d-${PORTVERSION}-src
diff --git a/devel/shards/Makefile b/devel/shards/Makefile
index fe1b7bd1d7ec..5d789273df29 100644
--- a/devel/shards/Makefile
+++ b/devel/shards/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shards
DISTVERSIONPREFIX= v
DISTVERSION= 0.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MAINTAINER= greg@unrelenting.technology
diff --git a/devel/shedskin/Makefile b/devel/shedskin/Makefile
index 1375a2c4b32d..f3f99e1dfe5f 100644
--- a/devel/shedskin/Makefile
+++ b/devel/shedskin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shedskin
PORTVERSION= 0.9.4
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
CATEGORIES= devel python
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index 31469a07c1d7..1bea322ae379 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zile
PORTVERSION= 2.4.14
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= editors
MASTER_SITES= GNU
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index a2076760cff6..ca396b49fe36 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnucash
PORTVERSION= 3.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
diff --git a/games/aisleriot/Makefile b/games/aisleriot/Makefile
index 37d6fcedf752..404573d531ce 100644
--- a/games/aisleriot/Makefile
+++ b/games/aisleriot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aisleriot
PORTVERSION= 3.22.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
diff --git a/games/trackballs/Makefile b/games/trackballs/Makefile
index 53b0a69fc2a5..5ad31276746e 100644
--- a/games/trackballs/Makefile
+++ b/games/trackballs/Makefile
@@ -4,7 +4,7 @@
PORTNAME= trackballs
PORTVERSION= 1.3.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MAINTAINER= martymac@FreeBSD.org
diff --git a/graphics/graphviz/Makefile b/graphics/graphviz/Makefile
index 48d8278f5045..bbff16db1a88 100644
--- a/graphics/graphviz/Makefile
+++ b/graphics/graphviz/Makefile
@@ -3,7 +3,7 @@
PORTNAME= graphviz
PORTVERSION= 2.40.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics tk
MASTER_SITES= http://www.graphviz.org/pub/graphviz/ARCHIVE/
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index d891ef83b55a..4a7f2bc7fc7f 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inkscape
PORTVERSION= 0.92.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics gnome
MASTER_SITES= https://inkscape.org/en/gallery/item/12187/
diff --git a/lang/crystal/Makefile b/lang/crystal/Makefile
index 3de791045aa7..942873985113 100644
--- a/lang/crystal/Makefile
+++ b/lang/crystal/Makefile
@@ -2,6 +2,7 @@
PORTNAME= crystal
DISTVERSION= 0.25.1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= https://unrelentingtech.s3.dualstack.eu-west-1.amazonaws.com/crystal/:bootstrap
DISTFILES= ${BOOTSTRAP_PATH}:bootstrap
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index 6a9aa6e54671..272156c53bd2 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ecl
PORTVERSION= 15.3.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang lisp
MASTER_SITES= SF/${PORTNAME}s/${PORTNAME}s/15.3/
diff --git a/lang/guile2/Makefile b/lang/guile2/Makefile
index 390106aa9f48..90e22657c151 100644
--- a/lang/guile2/Makefile
+++ b/lang/guile2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= guile
PORTVERSION= 2.0.14
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang scheme
MASTER_SITES= GNU
PKGNAMESUFFIX= 2
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index 57b06f66386b..a623513236f1 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mdk
PORTVERSION= 1.2.9
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang gnome
MASTER_SITES= GNU/${PORTNAME}/v${PORTVERSION}
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index 7dfab628f87c..ab88f34fef3e 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -3,7 +3,7 @@
PORTNAME= neko
DISTVERSIONPREFIX= v
DISTVERSION= 2-2-0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= lang
MAINTAINER= penzin.dev@gmail.com
diff --git a/lang/oo2c/Makefile b/lang/oo2c/Makefile
index 1ede9c645c2b..9f33eabcdb8e 100644
--- a/lang/oo2c/Makefile
+++ b/lang/oo2c/Makefile
@@ -3,7 +3,7 @@
PORTNAME= oo2c
PORTVERSION= 2.1.11
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= lang
MASTER_SITES= SF/ooc/ooc2/${PORTVERSION}
DISTNAME= ${PORTNAME}_${BITS}-${PORTVERSION}
diff --git a/lang/sagittarius-scheme/Makefile b/lang/sagittarius-scheme/Makefile
index d842f6ce815d..95b5d6c4f8d5 100644
--- a/lang/sagittarius-scheme/Makefile
+++ b/lang/sagittarius-scheme/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sagittarius
PORTVERSION= 0.9.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= https://bitbucket.org/ktakashi/sagittarius-scheme/downloads/ \
LOCAL/ashish
diff --git a/lang/see/Makefile b/lang/see/Makefile
index ae9074682c53..4b6cf1e28edf 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -3,7 +3,7 @@
PORTNAME= see
PORTVERSION= 3.1.1424
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel
MASTER_SITES= http://download.openpkg.org/components/cache/see/ \
http://lil.fr.distfiles.macports.org/see/ \
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index ada59b506838..1fd04f5c97bd 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -3,7 +3,7 @@
PORTNAME= asymptote
PORTVERSION= 2.44
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
index 66bc79b19cd7..f4dde89007cb 100644
--- a/net-im/freetalk/Makefile
+++ b/net-im/freetalk/Makefile
@@ -4,7 +4,7 @@
PORTNAME= freetalk
PORTVERSION= 4.1
DISTVERSIONPREFIX= v
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im
MAINTAINER= ports@FreeBSD.org
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index 0b501bc8bc52..c46c53a373b4 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gale
PORTVERSION= 0.99f
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= net-im
MASTER_SITES= http://download.ofb.net/${PORTNAME}/
DISTNAME= ${PORTNAME}-${PORTVERSION}ruit
diff --git a/science/meep/Makefile b/science/meep/Makefile
index adfccb3111da..51159e07c54d 100644
--- a/science/meep/Makefile
+++ b/science/meep/Makefile
@@ -3,7 +3,7 @@
PORTNAME= meep
PORTVERSION= 1.2.1
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= science
MASTER_SITES= http://ab-initio.mit.edu/meep/
diff --git a/textproc/chpp/Makefile b/textproc/chpp/Makefile
index eb93eb191493..3f7ac4a3faec 100644
--- a/textproc/chpp/Makefile
+++ b/textproc/chpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= chpp
PORTVERSION= 0.3.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= http://www.complang.tuwien.ac.at/schani/chpp/files/ \
http://freebsd.nsu.ru/distfiles/
diff --git a/www/w3m/Makefile b/www/w3m/Makefile
index 5ac111005e13..8be7452db31c 100644
--- a/www/w3m/Makefile
+++ b/www/w3m/Makefile
@@ -3,6 +3,7 @@
PORTNAME= w3m
PORTVERSION= 0.5.3.20180520
+PORTREVISION= 1
CATEGORIES+= www ipv6
MAINTAINER?= nobutaka@FreeBSD.org