aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-amqp067/Makefile21
-rw-r--r--net/rubygem-amqp067/distinfo2
-rw-r--r--net/rubygem-amqp067/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5054b2aa34ac..b3a0f3a7e616 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -961,6 +961,7 @@
SUBDIR += rubygem-amq-protocol
SUBDIR += rubygem-amqp
SUBDIR += rubygem-amqp-utils
+ SUBDIR += rubygem-amqp067
SUBDIR += rubygem-bunny
SUBDIR += rubygem-geoip
SUBDIR += rubygem-http_parser.rb
diff --git a/net/rubygem-amqp067/Makefile b/net/rubygem-amqp067/Makefile
new file mode 100644
index 000000000000..680b3e2ab79a
--- /dev/null
+++ b/net/rubygem-amqp067/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-amqp
+# Date created: Dec 16, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= amqp
+PORTVERSION= 0.6.7
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= An implementation of the AMQP protocol for RabbitMQ clients
+
+RUN_DEPENDS= rubygem-eventmachine>=0.12.4:${PORTSDIR}/devel/rubygem-eventmachine
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-amqp067/distinfo b/net/rubygem-amqp067/distinfo
new file mode 100644
index 000000000000..aa3408c43c52
--- /dev/null
+++ b/net/rubygem-amqp067/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amqp-0.6.7.gem) = 7d7faf3e394d0a9c5c3574fbd87f9877b85dbd1fa419f5e1dfe84266f56cdfe3
+SIZE (rubygem/amqp-0.6.7.gem) = 83456
diff --git a/net/rubygem-amqp067/pkg-descr b/net/rubygem-amqp067/pkg-descr
new file mode 100644
index 000000000000..0eb35dab9e27
--- /dev/null
+++ b/net/rubygem-amqp067/pkg-descr
@@ -0,0 +1,7 @@
+Simple asynchronous AMQP driver for Ruby/EventMachine.
+This library works with Ruby 1.8, Ruby 1.9, JRuby and Rubinius.
+
+This library was tested primarily with RabbitMQ, although it
+should be compatible with any server implementing the AMQP 0-8 spec.
+
+WWW: https://github.com/ruby-amqp/amqp