aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.autotools.mk8
-rw-r--r--Mk/bsd.database.mk36
-rw-r--r--Mk/bsd.gcc.mk4
-rw-r--r--Mk/bsd.gnome.mk12
-rw-r--r--Mk/bsd.gstreamer.mk4
-rw-r--r--Mk/bsd.kde.mk4
-rw-r--r--Mk/bsd.kde4.mk4
-rw-r--r--Mk/bsd.php.mk10
-rw-r--r--Mk/bsd.port.mk98
-rw-r--r--Mk/bsd.ruby.mk6
-rw-r--r--Mk/bsd.sdl.mk2
11 files changed, 121 insertions, 67 deletions
diff --git a/Mk/bsd.autotools.mk b/Mk/bsd.autotools.mk
index 3e9bd01d5a55..bf11a6938957 100644
--- a/Mk/bsd.autotools.mk
+++ b/Mk/bsd.autotools.mk
@@ -77,7 +77,7 @@ AUTOTOOL_${item:C/^([^:]+).*/\1/}${item:M*\:*\:*:C/^[^:]+:[^:]+:([^:]+)/_\1/}= $
# XXX: temporary to highlight any missed ports in the conversion
#
.if defined(AUTOTOOL_libtool_inc)
-BROKEN+=libtool:${AUTOTOOL_libtool_inc}:inc construct no longer available
+IGNORE+= error: libtool:${AUTOTOOL_libtool_inc}:inc construct no longer available
.endif
#---------------------------------------------------------------------------
@@ -100,7 +100,7 @@ AUTOMAKE_VERSION= ${AUTOTOOL_automake_env}
# Make sure we specified a legal version of automake
#
. if !exists(${PORTSDIR}/devel/automake${AUTOMAKE_VERSION}/Makefile)
-BROKEN+= Unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
+IGNORE+= cannot install: unknown AUTOMAKE version: ${AUTOMAKE_VERSION}
. endif
# Set up the automake environment
@@ -146,7 +146,7 @@ AUTOCONF_VERSION= ${AUTOTOOL_autoconf_env}
# Make sure we specified a legal version of autoconf
#
. if !exists(${PORTSDIR}/devel/autoconf${AUTOCONF_VERSION}/Makefile)
-BROKEN+= Unknown AUTOCONF version: ${AUTOCONF_VERSION}
+IGNORE+= cannot install: unknown AUTOCONF version: ${AUTOCONF_VERSION}
. endif
# Set up the autoconf/autoheader environment
@@ -189,7 +189,7 @@ LIBTOOL_VERSION= ${AUTOTOOL_libtool_env}
# Make sure we specified a legal version of libtool
#
. if !exists(${PORTSDIR}/devel/libtool${LIBTOOL_VERSION}/Makefile)
-BROKEN+= Unknown LIBTOOL version: ${LIBTOOL_VERSION}
+IGNORE+= cannot install: unknown LIBTOOL version: ${LIBTOOL_VERSION}
. endif
# Set up the libtool environment
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 7286894b3516..4af9d90033e3 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -25,7 +25,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# Default: 50.
# WANT_MYSQL_VER
# - Maintainer can set an arbitrary version of MySQL by using it.
-# BROKEN_WITH_MYSQL
+# IGNORE_WITH_MYSQL
# - This variable can be defined if the ports doesn't support
# one or more version of MySQL.
# WITH_MYSQL_VER
@@ -44,7 +44,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# WANT_PGSQL_VER
# - Maintainer can set an arbitrary version of PostgreSQL by
# using it.
-# BROKEN_WITH_PGSQL
+# IGNORE_WITH_PGSQL
# - This variable can be defined if the ports doesn't support
# one or more versions of PostgreSQL.
# PGSQL_VER
@@ -116,13 +116,17 @@ IGNORE= cannot install: MySQL versions mismatch: mysql${_MYSQL_VER}-client is in
# And now we are checking if we can use it
.if defined(MYSQL${MYSQL_VER}_LIBVER)
+# compatability shim
.if defined(BROKEN_WITH_MYSQL)
-. for VER in ${BROKEN_WITH_MYSQL}
+IGNORE_WITH_MYSQL=${BROKEN_WITH_MYSQL}
+.endif
+.if defined(IGNORE_WITH_MYSQL)
+. for VER in ${IGNORE_WITH_MYSQL}
. if (${MYSQL_VER} == "${VER}")
-IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${BROKEN_WITH_MYSQL})
+IGNORE= cannot install: doesn't work with MySQL version : ${MYSQL_VER} (Doesn't support MySQL ${IGNORE_WITH_MYSQL})
. endif
. endfor
-.endif # BROKEN_WITH_MYSQL
+.endif # IGNORE_WITH_MYSQL
LIB_DEPENDS+= mysqlclient.${MYSQL${MYSQL_VER}_LIBVER}:${PORTSDIR}/databases/mysql${MYSQL_VER}-client
.else
IGNORE= cannot install: unknown MySQL version: ${MYSQL_VER}
@@ -155,13 +159,17 @@ PGSQL_VER= ${DEFAULT_PGSQL_VER}
# And now we are checking if we can use it
.if defined(PGSQL${PGSQL_VER}_LIBVER)
+# compatability shim
.if defined(BROKEN_WITH_PGSQL)
-. for VER in ${BROKEN_WITH_PGSQL}
+IGNORE_WITH_PGSQL=${BROKEN_WITH_PGSQL}
+.endif
+.if defined(IGNORE_WITH_PGSQL)
+. for VER in ${IGNORE_WITH_PGSQL}
. if (${PGSQL_VER} == "${VER}")
-IGNORE= cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${BROKEN_WITH_PGSQL} not supported)
+IGNORE= cannot install: does not work with postgresql${PGSQL_VER}-client PostgresSQL (${IGNORE_WITH_PGSQL} not supported)
. endif
. endfor
-.endif # BROKEN_WITH_PGSQL
+.endif # IGNORE_WITH_PGSQL
LIB_DEPENDS+= pq.${PGSQL${PGSQL_VER}_LIBVER}:${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.else
IGNORE= cannot install: unknown PostgreSQL version: ${PGSQL_VER}
@@ -220,7 +228,7 @@ _WANT_BDB_VER= 41+
# Detect bdb version
_BDB_VER= no
-_BDB_BROKEN= no
+_BDB_IGNORE= no
# Override the user defined WITH_BDB_VER with the WANT_BDB_VER
.if defined(WANT_BDB_VER)
@@ -242,7 +250,7 @@ _BDB_VER= ${bdb}
. for dbx in ${_DB_${_MATCHED_DB_VER}P}
. if exists(${db${dbx}_FIND})
_BRKDB= no
-# Skip versions we are broken with
+# Skip versions we are incompatible with
. if defined(INVALID_BDB_VER)
_CHK_BDB:= ${dbx}
. for BRKDB in ${INVALID_BDB_VER}
@@ -282,20 +290,20 @@ _CHK_PLUS:= ${VER:S/+//}
# INVALID_BDB_VER is specified as VER+
. if ${_CHK_PLUS} != "${VER}"
. if ${_BDB_VER} == "${_CHK_PLUS}
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. else
. for VER_P in ${_DB_${_CHK_PLUS}P}
. if ${_BDB_VER} == "${VER_P}"
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. endif
. endfor
. endif
. elif ${_BDB_VER} == "${VER}"
-_BDB_BROKEN= yes
+_BDB_IGNORE= yes
. endif
. endfor
. endif
-. if ${_BDB_BROKEN} == "yes"
+. if ${_BDB_IGNORE} == "yes"
IGNORE= cannot install: does not work with bdb version: ${_BDB_VER} (${INVALID_BDB_VER} not supported)
. else
# Now add the dependancy on Berkeley DB ${_BDB_VER) version
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 585a6e2799bc..0242a5bc9cea 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -78,7 +78,7 @@ _GCCVERSION_OKAY= true;
.endfor
.if !defined(_GCCVERSION_OKAY)
-BROKEN= Unknown version of GCC specified (USE_GCC=${USE_GCC})
+IGNORE= Unknown version of GCC specified (USE_GCC=${USE_GCC})
.endif
#
@@ -94,7 +94,7 @@ _GCC_FOUND${v}:= base
. endif
.endfor
.if !defined(_GCCVERSION)
-BROKEN= Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
+IGNORE= Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})
.endif
#
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 2bacd1536e8b..107656e57e9d 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -613,18 +613,18 @@ ${component}_USE_GNOME_IMPL+=${${subcomponent}_USE_GNOME_IMPL}
# Then use already expanded USE_GNOME_IMPL to expand USE_GNOME.
# Also, check to see if each component has a desktop requirement. If it does,
# and if the user's chosen desktop is not of the same version, mark the
-# port as broken.
+# port as IGNORE.
. for component in ${USE_GNOME}
. if defined(GNOME_DESKTOP_VERSION) && \
defined(${component}_GNOME_DESKTOP_VERSION)
. if ${GNOME_DESKTOP_VERSION}!=${${component}_GNOME_DESKTOP_VERSION}
-BROKEN= ${PORTNAME} wants to use the GNOME
-BROKEN+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
-BROKEN+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
+IGNORE= cannot install: ${PORTNAME} wants to use the GNOME
+IGNORE+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
+IGNORE+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
. endif
. endif
. if ${_USE_GNOME_ALL:M${component}}==""
-BROKEN= Unknown component ${component}
+IGNORE= cannot install: unknown component ${component}
. endif
_USE_GNOME+= ${${component}_USE_GNOME_IMPL} ${component}
. endfor
@@ -647,7 +647,7 @@ ltverhack_PRE_PATCH= ${CP} -pf ${LTMAIN} ${WRKDIR}/gnome-ltmain.sh && \
done;
.else
. if ${USE_GNOME:Mltverhack}!=""
-BROKEN= ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
+IGNORE= cannot install: ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
. endif
.endif
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index b57b786990d8..cb9c02e73a49 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -246,7 +246,7 @@ ${ext}_NAME?= ${ext}
BUILD_DEPENDS+= ${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
RUN_DEPENDS+= ${${ext}_GST80_PREFIX}${${ext}_NAME}${${ext}_GST80_SUFX}>=${${ext}_GST80_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}${${ext}_GST80_SUFX}
. else
-BROKEN= Unknown gstreamer-plugin -- ${ext}
+IGNORE= cannot install: unknown gstreamer-plugin -- ${ext}
. endif
.endfor
.endif
@@ -256,7 +256,7 @@ BROKEN= Unknown gstreamer-plugin -- ${ext}
BUILD_DEPENDS+= ${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
RUN_DEPENDS+= ${${ext}_GST_PREFIX}${${ext}_NAME}>=${${ext}_GST_VERSION}:${PORTSDIR}/${${ext}_DEPENDS}
. else
-BROKEN= Unknown gstreamer-plugin -- ${ext}
+IGNORE= cannot install: unknown gstreamer-plugin -- ${ext}
. endif
.endfor
.endif
diff --git a/Mk/bsd.kde.mk b/Mk/bsd.kde.mk
index f2f19e71bc11..43aa064f6347 100644
--- a/Mk/bsd.kde.mk
+++ b/Mk/bsd.kde.mk
@@ -68,7 +68,7 @@ LIB_DEPENDS+= kimproxy:${PORTSDIR}/x11/kdelibs3
USE_QT_VER= 3
PREFIX= ${KDE_PREFIX}
.else
-IGNORE= Unsupported value in USE_KDELIBS_VER
+IGNORE= cannot install: unsupported value in USE_KDELIBS_VER
.endif # ${USE_KDELIBS_VER} == 3
.endif # defined(USE_KDELIBS_VER)
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.else
-IGNORE= Unsupported value of USE_QT_VER
+IGNORE= cannot install: unsupported value of USE_QT_VER
.endif # defined(USE_QT_VER)
# End of USE_QT_VER section
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index f2f19e71bc11..43aa064f6347 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -68,7 +68,7 @@ LIB_DEPENDS+= kimproxy:${PORTSDIR}/x11/kdelibs3
USE_QT_VER= 3
PREFIX= ${KDE_PREFIX}
.else
-IGNORE= Unsupported value in USE_KDELIBS_VER
+IGNORE= cannot install: unsupported value in USE_KDELIBS_VER
.endif # ${USE_KDELIBS_VER} == 3
.endif # defined(USE_KDELIBS_VER)
@@ -128,7 +128,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.else
-IGNORE= Unsupported value of USE_QT_VER
+IGNORE= cannot install: unsupported value of USE_QT_VER
.endif # defined(USE_QT_VER)
# End of USE_QT_VER section
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 5104f0a51e6b..58c409fd410f 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -18,7 +18,7 @@
# The port can set these options in its Makefile before bsd.ports.pre.mk:
#
# DEFAULT_PHP_VER=N - Use PHP version N if PHP is not yet installed.
-# BROKEN_WITH_PHP=N - The port doesn't work with PHP version N.
+# IGNORE_WITH_PHP=N - The port doesn't work with PHP version N.
# USE_PHPIZE=yes - Use to build a PHP extension.
# USE_PHPEXT=yes - Use to build, install and register a PHP extension.
# USE_PHP_BUILD=yes - Set PHP also as a build dependency.
@@ -70,10 +70,14 @@ PHP_SAPI?= ""
.endif
PHP_EXT_INC?= ""
+# compatability shim
.if defined(BROKEN_WITH_PHP)
-. for VER in ${BROKEN_WITH_PHP}
+IGNORE_WITH_PHP=${BROKEN_WITH_PHP}
+.endif
+.if defined(IGNORE_WITH_PHP)
+. for VER in ${IGNORE_WITH_PHP}
. if ${PHP_VER} == "${VER}"
-BROKEN= Doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${BROKEN_WITH_PHP})
+IGNORE= cannot install: doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${IGNORE_WITH_PHP})
. endif
. endfor
.endif
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 0740d37de2c9..64a9b21fa88c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -291,7 +291,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# compression.
# USE_ZIP - If set, this port distfile uses zip, not tar w/[bg]zip
# for compression.
-# USE_DOS2UNIX - If set to "YES", remove the ^M from all files
+# USE_DOS2UNIX - If set to "YES", remove the ^M from all files
# under ${WRKSRC}. If set to a string, remove in all
# files under ${WRKSRC} with one of these names the ^Ms.
# USE_GCC - If set, this port requires this version of gcc, either in
@@ -393,13 +393,16 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_FAM - If set, this port uses the File Alteration Monitor.
#
# WANT_FAM_SYSTEM
-# - Legal values are: gamin (default),fam
-# If set to an unknown value, the port is marked BROKEN.
+# - Legal values are: gamin (default),fam
+# If set to an unknown value, the port is marked IGNORE.
##
# USE_AUTOTOOLS - If set, this port uses various GNU autotools
# (libtool, autoconf, autoheader, automake et al.)
# See bsd.autotools.mk for more details.
##
+# USE_SCONS - If set, this port uses the Python-based SCons build system
+# See bsd.scons.mk for more details.
+##
# USE_JAVA - If set, this port relies on the Java language.
# Implies inclusion of bsd.java.mk. (Also see
# that file for more information on USE_JAVA_*).
@@ -462,15 +465,15 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# usable in *_DEPENDS (e.g. BUILD_DEPENDS=${LINUX_BASE_PORT}).
# It honors USE_LINUX=foo and OVERRIDE_LINUX_BASE_PORT.
# USE_RC_SUBR - If set, the ports startup/shutdown script uses the common
-# routines found in etc/rc.subr and may need to
-# depend on the sysutils/rc_subr port.
-# If this is set to a list of files, these files will be
-# automatically added to ${SUB_FILES}, some %%VAR%%'s will
-# automatically be expanded, they will be installed in
-# ${PREFIX}/etc/rc.d and added to the packing list.
+# routines found in etc/rc.subr and may need to
+# depend on the sysutils/rc_subr port.
+# If this is set to a list of files, these files will be
+# automatically added to ${SUB_FILES}, some %%VAR%%'s will
+# automatically be expanded, they will be installed in
+# ${PREFIX}/etc/rc.d and added to the packing list.
# USE_RCORDER - List of rc.d startup scripts to be called early in the boot
-# process. This acts exactly like USE_RC_SUBR except that
-# scripts are installed in /etc/rc.d.
+# process. This acts exactly like USE_RC_SUBR except that
+# scripts are installed in /etc/rc.d.
# RC_SUBR - Set to path of rc.subr.
# Default: ${LOCALBASE}/etc/rc.subr.
##
@@ -952,7 +955,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# - Different checksum algorithms to check for verifying the
# integrity of the distfiles. The absence of the algorithm
# in distinfo doesn't make it fail.
-# Default: md5
+# Default: md5 sha256
# NO_CHECKSUM - Don't verify the checksum. Typically used when
# when you noticed the distfile you just fetched has
# a different checksum and you intend to verify if
@@ -1150,6 +1153,9 @@ USE_SUBMAKE= yes
# where 'make config' records user configuration options
PORT_DBDIR?= /var/db/ports
+LDCONFIG_DIR= libdata/ldconfig
+LDCONFIG32_DIR= libdata/ldconfig32
+
.if defined(LATEST_LINK)
UNIQUENAME?= ${LATEST_LINK}
.else
@@ -1204,7 +1210,7 @@ check-makefile::
.if defined(PORTVERSION)
.if ${PORTVERSION:M*[-_,]*}x != x
-BROKEN= PORTVERSION ${PORTVERSION} may not contain '-' '_' or ','
+IGNORE= PORTVERSION ${PORTVERSION} may not contain '-' '_' or ','
.endif
DISTVERSION?= ${PORTVERSION:S/:/::/g}
.elif defined(DISTVERSION)
@@ -1404,18 +1410,22 @@ PERL= ${LOCALBASE}/bin/perl
.include "${PORTSDIR}/Mk/bsd.gnome.mk"
.endif
-.if defined(WANT_GSTREAMER) || defined(USE_GSTREAMER) || defined(USE_GSTREAMER80)
-.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
+.if defined(WANT_WX) || defined(USE_WX) || defined(USE_WX_NOT)
+.include "${PORTSDIR}/Mk/bsd.wx.mk"
.endif
-.if defined(USE_SDL) || defined(WANT_SDL)
-.include "${PORTSDIR}/Mk/bsd.sdl.mk"
+.if defined(WANT_GSTREAMER) || defined(USE_GSTREAMER) || defined(USE_GSTREAMER80)
+.include "${PORTSDIR}/Mk/bsd.gstreamer.mk"
.endif
.if defined(USE_QMAIL) || defined(USE_QMAIL_RUN) || defined(USE_QMAIL_BUILD) || defined(WANT_QMAIL)
.include "${PORTSDIR}/Mk/bsd.mail.mk"
.endif
+.if defined(USE_SDL) || defined(WANT_SDL)
+.include "${PORTSDIR}/Mk/bsd.sdl.mk"
+.endif
+
.if ${OSVERSION} >= 502123
X_WINDOW_SYSTEM ?= xorg
.elif (${OSVERSION} >= 450005 && !defined(XFREE86_VERSION)) || \
@@ -1540,7 +1550,7 @@ LIB_DEPENDS+= ldap-2.3.2:${PORTSDIR}/net/openldap23${_OPENLDAP_FLAVOUR}-client
.elif ${WANT_OPENLDAP_VER} == 24
LIB_DEPENDS+= ldap-2.4.1:${PORTSDIR}/net/openldap24${_OPENLDAP_FLAVOUR}-client
.else
-BROKEN= unknown OpenLDAP version: ${WANT_OPENLDAP_VER}
+IGNORE= unknown OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
.endif
@@ -1558,7 +1568,7 @@ _HAVE_FAM_SYSTEM= fam
.if defined(WANT_FAM_SYSTEM)
.if defined(WITH_FAM_SYSTEM) && ${WITH_FAM_SYSTEM}!=${WANT_FAM_SYSTEM}
-BROKEN= The port wants to use ${WANT_FAM_SYSTEM} as its FAM system and you wish to use ${WITH_FAM_SYSTEM}
+IGNORE= The port wants to use ${WANT_FAM_SYSTEM} as its FAM system and you wish to use ${WITH_FAM_SYSTEM}
.endif
FAM_SYSTEM= ${WANT_FAM_SYSTEM}
.elif defined(WITH_FAM_SYSTEM)
@@ -1580,7 +1590,7 @@ BROKEN= FAM system mismatch: ${_HAVE_FAM_SYSTEM} is installed and desired FAM sy
.if defined(FAM_SYSTEM_${FAM_SYSTEM:U})
LIB_DEPENDS+= ${FAM_SYSTEM_${FAM_SYSTEM:U}}
.else
-BROKEN= unknown FAM system: ${FAM_SYSTEM}
+IGNORE= unknown FAM system: ${FAM_SYSTEM}
.endif
.endif # USE_FAM
@@ -1609,14 +1619,12 @@ SUB_FILES+= ${USE_RCORDER}
.endif
.endif
-LDCONFIG_DIR= libdata/ldconfig
-LDCONFIG32_DIR= libdata/ldconfig32
-
.if defined(USE_LDCONFIG) || defined(USE_LDCONFIG32)
-.if ${OSVERSION} < 504105 || \
- (${OSVERSION} >= 700000 && ${OSVERSION} < 700012) || \
- (${OSVERSION} >= 600000 && ${OSVERSION} < 600104)
+.if ( ${OSVERSION} < 504105 ) || \
+ ( ${OSVERSION} >= 700000 && ${OSVERSION} < 700012 ) || \
+ ( ${OSVERSION} >= 600000 && ${OSVERSION} < 600104 )
RUN_DEPENDS+= ${LOCALBASE}/${LDCONFIG_DIR}:${PORTSDIR}/misc/ldconfig_compat
+NO_LDCONFIG_MTREE= yes
.endif
.if defined(USE_LDCONFIG) && ${USE_LDCONFIG:L} == "yes"
USE_LDCONFIG= ${PREFIX}/lib
@@ -1662,6 +1670,9 @@ USE_LINUX= ${OVERRIDE_LINUX_BASE_PORT}
. endif
. endif
+# NOTE: when you update the default linux_base version (case "yes"),
+# don't forget to update the Handbook!
+
. if exists(${PORTSDIR}/emulators/linux_base-${USE_LINUX})
LINUX_BASE_PORT= ${LINUXBASE}/bin/sh:${PORTSDIR}/emulators/linux_base-${USE_LINUX}
. else
@@ -1851,6 +1862,10 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.include "${PORTSDIR}/Mk/bsd.linux-rpm.mk"
.endif
+.if defined(USE_SCONS)
+.include "${PORTSDIR}/Mk/bsd.scons.mk"
+.endif
+
.if defined(USE_SDL) || defined(WANT_SDL)
.include "${PORTSDIR}/Mk/bsd.sdl.mk"
.endif
@@ -1863,6 +1878,10 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
.endif
+.if defined(USE_WX) || defined(USE_WX_NOT)
+.include "${PORTSDIR}/Mk/bsd.wx.mk"
+.endif
+
.if defined(USE_APACHE) || defined(APACHE_COMPAT)
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.endif
@@ -1875,6 +1894,7 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
.include "${PORTSDIR}/Mk/bsd.gnome.mk"
.endif
+
.if exists(${PORTSDIR}/../Makefile.inc)
.include "${PORTSDIR}/../Makefile.inc"
USE_SUBMAKE= yes
@@ -3669,9 +3689,15 @@ install-ldconfig-file:
.endif
.if ${USE_LDCONFIG:L} != "${PREFIX}/lib"
@${ECHO_MSG} "===> Installing ldconfig configuration file"
+.if defined(NO_LDCONFIG_MTREE)
+ @${MKDIR} ${LDCONFIG_DIR}
+.endif
@${ECHO_CMD} ${USE_LDCONFIG} | ${TR} ' ' '\n' \
> ${PREFIX}/${LDCONFIG_DIR}/${UNIQUENAME}
@${ECHO_CMD} ${LDCONFIG_DIR}/${UNIQUENAME} >> ${TMPPLIST}
+.if defined(NO_LDCONFIG_MTREE)
+ @${ECHO_CMD} "@unexec rmdir ${LDCONFIG_DIR} >/dev/null 2>&1" >> ${TMPPLIST}
+.endif
.endif
.endif
.if defined(USE_LDCONFIG32)
@@ -3683,9 +3709,15 @@ install-ldconfig-file:
-${LDCONFIG} -32 -m ${USE_LDCONFIG32}
.endif
@${ECHO_MSG} "===> Installing 32-bit ldconfig configuration file"
+.if defined(NO_LDCONFIG_MTREE)
+ @${MKDIR} ${LDCONFIG_32DIR}
+.endif
@${ECHO_CMD} ${USE_LDCONFIG32} | ${TR} ' ' '\n' \
> ${PREFIX}/${LDCONFIG32_DIR}/${UNIQUENAME}
@${ECHO_CMD} ${LDCONFIG32_DIR}/${UNIQUENAME} >> ${TMPPLIST}
+.if defined(NO_LDCONFIG_MTREE)
+ @${ECHO_CMD} "@unexec rmdir ${LDCONFIG32_DIR} >/dev/null 2>&1" >> ${TMPPLIST}
+.endif
.endif
# This can be removed once, all ports have been converted to USE_LDCONFIG.
.if defined(INSTALLS_SHLIB)
@@ -4864,6 +4896,16 @@ package-recursive: package
(cd $$dir; ${MAKE} package-noinstall); \
done
+# Show missing dependiencies
+missing:
+ @for dir in $$(${ALL-DEPENDS-LIST}); do \
+ THISORIGIN=$$(${ECHO_CMD} $$dir | ${SED} 's,${PORTSDIR}/,,'); \
+ installed=$$(${PKG_INFO} -qO $${THISORIGIN}); \
+ if [ -z $$installed ]; then \
+ ${ECHO_CMD} $$THISORIGIN; \
+ fi \
+ done
+
################################################################
# Everything after here are internal targets and really
# shouldn't be touched by anybody but the release engineers.
@@ -5560,7 +5602,7 @@ VALID_DESKTOP_CATEGORIES+= Application Core Development Building Debugger IDE \
check-desktop-entries:
.if defined(DESKTOP_ENTRIES)
@set ${DESKTOP_ENTRIES} XXX; \
- if [ $$((($$# - 1) % 6)) -ne 0 ]; then \
+ if [ `${EXPR} \( $$# - 1 \) % 6` -ne 0 ]; then \
${ECHO_CMD} "${PKGNAME}: Makefile error: the DESKTOP_ENTRIES list must contain one or more groups of 6 elements"; \
exit 1; \
fi; \
@@ -5606,7 +5648,7 @@ check-desktop-entries:
exit 1; \
fi; \
shift 6; \
- num=$$((num + 1)); \
+ num=`${EXPR} $$num + 1`; \
done
.else
@${DO_NADA}
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index 58ff3f0c833d..b0b7a8addc8d 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -114,12 +114,12 @@ RUBY_VER?= ${RUBY_DEFAULT_VER}
.if defined(RUBY)
.if !exists(${RUBY})
-BROKEN= You set the variable RUBY to "${RUBY}", but it does not seem to exist. Please specify an already installed ruby executable.
+IGNORE= cannot install: you set the variable RUBY to "${RUBY}", but it does not seem to exist. Please specify an already installed ruby executable.
.endif
_RUBY_TEST!= ${RUBY} -e 'begin; require "rbconfig"; rescue LoadError; puts "error"; end'
.if !empty(_RUBY_TEST)
-BROKEN= You set the variable RUBY to "${RUBY}", but it failed to include rbconfig. Please specify a properly installed ruby executable.
+IGNORE= cannot install: you set the variable RUBY to "${RUBY}", but it failed to include rbconfig. Please specify a properly installed ruby executable.
.endif
_RUBY_CONFIG= ${RUBY} -r rbconfig -e 'C = Config::CONFIG' -e
@@ -147,7 +147,7 @@ RUBY_PATCHFILES?= ${RUBY_VERSION}-patch1.gz
RUBY_WRKSRC= ${WRKDIR}/ruby-${RUBY_VERSION}
#MASTER_SITE_SUBDIR_RUBY= snapshots
.elif defined(RUBY_VER) && ${RUBY_VER} == 1.7
-BROKEN= Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead.
+IGNORE= Ruby 1.7 is obsolete; set RUBY_VER to 1.8 instead.
.else
RUBY_VERSION?= 1.6.8
RUBY_DISTVERSION?= ${RUBY_VERSION}-2004.07.28
diff --git a/Mk/bsd.sdl.mk b/Mk/bsd.sdl.mk
index 53cfa12b8f72..ae1dc5bf5802 100644
--- a/Mk/bsd.sdl.mk
+++ b/Mk/bsd.sdl.mk
@@ -145,7 +145,7 @@ USE_SDL= sdl
_USE_SDL=
.for component in ${USE_SDL}
. if ${_USE_SDL_ALL:M${component}}==""
-BROKEN= Unknown SDL component ${component}
+IGNORE= cannot install: unknown SDL component ${component}
. endif
_USE_SDL+= ${_REQUIRES_${component}} ${component}
.endfor