aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/vorbis-tools/Makefile2
-rw-r--r--audio/vorbis-tools/files/patch-oggenc::audio.c13
-rw-r--r--audio/vorbis-tools/files/patch-share::iconvert.c29
3 files changed, 14 insertions, 30 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 37bd122d8b3a..5abdb96c68bd 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.0.r3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 2
CATEGORIES= audio
MASTER_SITES= http://www.xiph.org/ogg/vorbis/download/ \
diff --git a/audio/vorbis-tools/files/patch-oggenc::audio.c b/audio/vorbis-tools/files/patch-oggenc::audio.c
new file mode 100644
index 000000000000..997207d3b7fd
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-oggenc::audio.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- oggenc/audio.c.orig Sat Dec 8 03:23:01 2001
++++ oggenc/audio.c Tue Mar 26 03:32:57 2002
+@@ -570,6 +570,7 @@
+ wav->bigendian = 0;
+ wav->channels = format.channels;
+ wav->samplesize = opt->samplesize;
++ wav->totalsamples = 0;
+
+ opt->read_samples = wav_read;
+ opt->readdata = (void *)wav;
diff --git a/audio/vorbis-tools/files/patch-share::iconvert.c b/audio/vorbis-tools/files/patch-share::iconvert.c
deleted file mode 100644
index 407ea9d47a91..000000000000
--- a/audio/vorbis-tools/files/patch-share::iconvert.c
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- share/iconvert.c.orig Wed Dec 19 03:57:31 2001
-+++ share/iconvert.c Thu Feb 14 16:52:41 2002
-@@ -105,10 +105,12 @@
- obl = utflen;
- for (;;) {
- k = iconv(cd1, &ib, &ibl, &ob, &obl);
-+#if 0 /* mistaken assumptions */
- assert((!k && !ibl) ||
- (k == (size_t)(-1) && errno == E2BIG && ibl && obl < 6) ||
- (k == (size_t)(-1) &&
- (errno == EILSEQ || errno == EINVAL) && ibl));
-+#endif
- if (!ibl)
- break;
- if (obl < 6) {
-@@ -216,8 +218,10 @@
- }
- }
- k = iconv(cd2, 0, 0, &ob, &obl);
-+#if 0
- assert(!k);
- assert(!obl);
-+#endif
- *ob = '\0';
-
- free(utfbuf);