aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/tclsasl/Makefile38
-rw-r--r--security/tclsasl/distinfo3
-rw-r--r--security/tclsasl/files/patch-Makefile.in28
-rw-r--r--security/tclsasl/files/patch-configure11
-rw-r--r--security/tclsasl/pkg-descr3
-rw-r--r--security/tclsasl/pkg-plist6
7 files changed, 90 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index eb1abffa6d63..c656c3a3868f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -603,6 +603,7 @@
SUBDIR += super
SUBDIR += swatch
SUBDIR += symbion-sslproxy
+ SUBDIR += tclsasl
SUBDIR += tea-total
SUBDIR += termlog
SUBDIR += tinc
diff --git a/security/tclsasl/Makefile b/security/tclsasl/Makefile
new file mode 100644
index 000000000000..5f5880079457
--- /dev/null
+++ b/security/tclsasl/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tclsasl
+# Date created: Wed Apr 26 12:42:16 MSD 2006
+# Whom: Denis Shaposhnikov <dsh@vlink.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tclsasl
+PORTVERSION= 1.0
+CATEGORIES= security tcl84
+MASTER_SITES= http://beepcore-tcl.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dsh@vlink.ru
+COMMENT= A Tcl interface to the Cyrus SASLv2 library
+
+LIB_DEPENDS= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+# USE_TCL hack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+GNU_CONFIGURE= yes
+USE_TCL= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR} \
+ --with-cyrus-sasl=${LOCALBASE}
+CONFIGURE_ENV= INSTALL="${INSTALL_DATA}"
+
+PORTDOCS= tclsasl.html
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/tclsasl.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/tclsasl/distinfo b/security/tclsasl/distinfo
new file mode 100644
index 000000000000..1043f1062ec9
--- /dev/null
+++ b/security/tclsasl/distinfo
@@ -0,0 +1,3 @@
+MD5 (tclsasl-1.0.tgz) = 6d8cc2bd31d9d41a999a72817308d165
+SHA256 (tclsasl-1.0.tgz) = 4a07365339b4ec9bbc3d0d3a726d6f06608b49b0a1524e2ce5b22d2be14a2e25
+SIZE (tclsasl-1.0.tgz) = 229245
diff --git a/security/tclsasl/files/patch-Makefile.in b/security/tclsasl/files/patch-Makefile.in
new file mode 100644
index 000000000000..fc524ece1962
--- /dev/null
+++ b/security/tclsasl/files/patch-Makefile.in
@@ -0,0 +1,28 @@
+--- Makefile.in.orig Sat Jun 8 11:10:07 2002
++++ Makefile.in Wed Apr 26 13:14:22 2006
+@@ -137,7 +137,7 @@
+ WISH_PROG = @WISH_PROG@
+ tclsasl_LIB_FILE = @tclsasl_LIB_FILE@
+
+-LIB_TCL = -ltcl83
++LIB_TCL = $(TCL_STUB_LIB_SPEC)
+ LIB_SASL = @CYRUS_LIBS@
+
+ tclsasl_version = 1:0:0
+@@ -367,7 +367,7 @@
+ install: install-am
+ uninstall-am: uninstall-libLTLIBRARIES
+ uninstall: uninstall-am
+-all-am: Makefile $(LTLIBRARIES)
++all-am: $(LTLIBRARIES)
+ all-redirect: all-am
+ install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
+@@ -437,7 +437,6 @@
+ sed -e 's%load .libs/libtclsasl.so%package require sasl%' \
+ < test.tcl \
+ > @PKG_TCL@/test.tcl
+- cp doc/tclsasl.html @PKG_TCL@/
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/security/tclsasl/files/patch-configure b/security/tclsasl/files/patch-configure
new file mode 100644
index 000000000000..70359dd0d6f0
--- /dev/null
+++ b/security/tclsasl/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sat Jun 8 11:10:07 2002
++++ configure Wed Apr 26 13:13:38 2006
+@@ -2917,7 +2917,7 @@
+
+
+
+-PKG_TCL=${TCL_PACKAGE_PATH}/sasl-${VERSION}
++PKG_TCL=${TCL_PACKAGE_PATH}/tclsasl
+
+
+ # Check whether --with-cyrus-sasl or --without-cyrus-sasl was given.
diff --git a/security/tclsasl/pkg-descr b/security/tclsasl/pkg-descr
new file mode 100644
index 000000000000..deb881dc77bc
--- /dev/null
+++ b/security/tclsasl/pkg-descr
@@ -0,0 +1,3 @@
+Tcl SASL provides a Tcl interface to the Cyrus SASLv2 library.
+
+WWW: http://beepcore-tcl.sourceforge.net/tclsasl.html
diff --git a/security/tclsasl/pkg-plist b/security/tclsasl/pkg-plist
new file mode 100644
index 000000000000..3b77d409d6e4
--- /dev/null
+++ b/security/tclsasl/pkg-plist
@@ -0,0 +1,6 @@
+lib/libtclsasl.so.1
+lib/libtclsasl.so
+lib/libtclsasl.la
+lib/tclsasl/pkgIndex.tcl
+lib/tclsasl/test.tcl
+@dirrm lib/tclsasl