aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/p5-Class-DBI-AbstractSearch/Makefile6
-rw-r--r--databases/p5-Class-DBI-FromCGI/Makefile4
-rw-r--r--databases/p5-Class-DBI-Oracle/Makefile2
-rw-r--r--databases/p5-Class-DBI-Pager/Makefile8
-rw-r--r--databases/p5-Class-Inflate/Makefile6
-rw-r--r--databases/p5-DBD-InterBase/Makefile2
-rw-r--r--databases/p5-DBD-SQLite2/Makefile4
-rw-r--r--databases/p5-DBIx-Browse/Makefile4
-rw-r--r--databases/p5-DBIx-Tree/Makefile4
-rw-r--r--databases/p5-DBIx-XHTML_Table/Makefile4
-rw-r--r--databases/p5-Ima-DBI/Makefile6
-rw-r--r--databases/p5-POE-Component-EasyDBI/Makefile8
-rw-r--r--databases/p5-POE-Component-LaDBI/Makefile4
-rw-r--r--databases/p5-Search-InvertedIndex/Makefile8
14 files changed, 35 insertions, 35 deletions
diff --git a/databases/p5-Class-DBI-AbstractSearch/Makefile b/databases/p5-Class-DBI-AbstractSearch/Makefile
index afdcf680ad14..6b6e374f1fe9 100644
--- a/databases/p5-Class-DBI-AbstractSearch/Makefile
+++ b/databases/p5-Class-DBI-AbstractSearch/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Abstract Class::DBI SQL with SQL::Abstract
-RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/SQL/Abstract.pm:${PORTSDIR}/databases/p5-SQL-Abstract \
- ${SITE_PERL}/SQL/Abstract/Limit.pm:${PORTSDIR}/databases/p5-SQL-Abstract-Limit
+RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract \
+ p5-SQL-Abstract-Limit>=0:${PORTSDIR}/databases/p5-SQL-Abstract-Limit
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-FromCGI/Makefile b/databases/p5-Class-DBI-FromCGI/Makefile
index 07128e068125..746667020f1b 100644
--- a/databases/p5-Class-DBI-FromCGI/Makefile
+++ b/databases/p5-Class-DBI-FromCGI/Makefile
@@ -16,8 +16,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Update Class::DBI data using CGI::Untaint
BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint
+RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-CGI-Untaint>=0:${PORTSDIR}/www/p5-CGI-Untaint
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-Oracle/Makefile b/databases/p5-Class-DBI-Oracle/Makefile
index d6551dabc7de..188f47ac0591 100644
--- a/databases/p5-Class-DBI-Oracle/Makefile
+++ b/databases/p5-Class-DBI-Oracle/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Extensions to Class::DBI for Oracle
-BUILD_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI
+BUILD_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-DBI-Pager/Makefile b/databases/p5-Class-DBI-Pager/Makefile
index 31d7fe58ac64..24ce4b695396 100644
--- a/databases/p5-Class-DBI-Pager/Makefile
+++ b/databases/p5-Class-DBI-Pager/Makefile
@@ -15,10 +15,10 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Pager utility for Class::DBI
BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/Class/DBI.pm:${PORTSDIR}/databases/p5-Class-DBI \
- ${SITE_PERL}/Exporter/Lite.pm:${PORTSDIR}/devel/p5-Exporter-Lite \
- ${SITE_PERL}/Data/Page.pm:${PORTSDIR}/databases/p5-Data-Page \
- ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-Exporter-Lite>=0:${PORTSDIR}/devel/p5-Exporter-Lite \
+ p5-Data-Page>=0:${PORTSDIR}/databases/p5-Data-Page \
+ p5-Clone>=0:${PORTSDIR}/devel/p5-Clone
PERL_CONFIGURE= yes
diff --git a/databases/p5-Class-Inflate/Makefile b/databases/p5-Class-Inflate/Makefile
index cb332c1bbd49..c2eb3253011a 100644
--- a/databases/p5-Class-Inflate/Makefile
+++ b/databases/p5-Class-Inflate/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Inflate HASH Object from Values in Database
-RUN_DEPENDS= ${SITE_PERL}/Devel/Messenger.pm:${PORTSDIR}/devel/p5-Devel-Messenger
+RUN_DEPENDS= p5-Devel-Messenger>=0:${PORTSDIR}/devel/p5-Devel-Messenger
BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
- ${SITE_PERL}/Test/Debugger.pm:${PORTSDIR}/devel/p5-Test-Debugger
+BUILD_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Test-Debugger>=0:${PORTSDIR}/devel/p5-Test-Debugger
PERL_MODBUILD= yes
diff --git a/databases/p5-DBD-InterBase/Makefile b/databases/p5-DBD-InterBase/Makefile
index 82f120070095..6db200460088 100644
--- a/databases/p5-DBD-InterBase/Makefile
+++ b/databases/p5-DBD-InterBase/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DBI driver for InterBase RDBMS server
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS+= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS+= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBD-SQLite2/Makefile b/databases/p5-DBD-SQLite2/Makefile
index e6c817f90b8f..12a9f6319785 100644
--- a/databases/p5-DBD-SQLite2/Makefile
+++ b/databases/p5-DBD-SQLite2/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides access to SQLite2 databases through the DBI
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
PERL_CONFIGURE= yes
diff --git a/databases/p5-DBIx-Browse/Makefile b/databases/p5-DBIx-Browse/Makefile
index f54b7ca2344a..97b7f2263ddb 100644
--- a/databases/p5-DBIx-Browse/Makefile
+++ b/databases/p5-DBIx-Browse/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= DBIx::Browse - Perl extension to browse tables
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
MAKE_JOBS_SAFE= yes
diff --git a/databases/p5-DBIx-Tree/Makefile b/databases/p5-DBIx-Tree/Makefile
index e715d95baf4c..eff9db669f39 100644
--- a/databases/p5-DBIx-Tree/Makefile
+++ b/databases/p5-DBIx-Tree/Makefile
@@ -15,8 +15,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for generating a tree from a self-referential table
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
TEST_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
MAKE_JOBS_SAFE= yes
diff --git a/databases/p5-DBIx-XHTML_Table/Makefile b/databases/p5-DBIx-XHTML_Table/Makefile
index 6f6a5b1aaea9..80490218f05d 100644
--- a/databases/p5-DBIx-XHTML_Table/Makefile
+++ b/databases/p5-DBIx-XHTML_Table/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Create XHTML tables from SQL queries
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
PERL_CONFIGURE= yes
diff --git a/databases/p5-Ima-DBI/Makefile b/databases/p5-Ima-DBI/Makefile
index 3a36b4bb6c4b..6691f8733dba 100644
--- a/databases/p5-Ima-DBI/Makefile
+++ b/databases/p5-Ima-DBI/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Database connection caching and organization
-BUILD_DEPENDS= ${SITE_PERL}/DBIx/ContextualFetch.pm:${PORTSDIR}/databases/p5-DBIx-ContextualFetch \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+BUILD_DEPENDS= p5-DBIx-ContextualFetch>=0:${PORTSDIR}/databases/p5-DBIx-ContextualFetch \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-POE-Component-EasyDBI/Makefile b/databases/p5-POE-Component-EasyDBI/Makefile
index 16c9124f4fea..b09d899b88a7 100644
--- a/databases/p5-POE-Component-EasyDBI/Makefile
+++ b/databases/p5-POE-Component-EasyDBI/Makefile
@@ -15,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE Component for simplified DBI usage
-RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-POE-Component-LaDBI/Makefile b/databases/p5-POE-Component-LaDBI/Makefile
index 6f41a569444a..a01a5d60add1 100644
--- a/databases/p5-POE-Component-LaDBI/Makefile
+++ b/databases/p5-POE-Component-LaDBI/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for asynchronous non-blocking DBI calls in POE
-BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/databases/p5-Search-InvertedIndex/Makefile b/databases/p5-Search-InvertedIndex/Makefile
index e05f924a70f5..9ebeca60d216 100644
--- a/databases/p5-Search-InvertedIndex/Makefile
+++ b/databases/p5-Search-InvertedIndex/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A manager for inverted index maps
-BUILD_DEPENDS= ${SITE_PERL}/Class/NamedParms.pm:${PORTSDIR}/devel/p5-Class-NamedParms \
- ${SITE_PERL}/Class/ParmList.pm:${PORTSDIR}/devel/p5-Class-ParmList \
- ${SITE_PERL}/Tie/DB_File/SplitHash.pm:${PORTSDIR}/devel/p5-Tie-DB_File-SplitHash \
- ${SITE_PERL}/Tie/FileLRUCache.pm:${PORTSDIR}/devel/p5-Tie-FileLRUCache
+BUILD_DEPENDS= p5-Class-NamedParms>=0:${PORTSDIR}/devel/p5-Class-NamedParms \
+ p5-Class-ParmList>=0:${PORTSDIR}/devel/p5-Class-ParmList \
+ p5-Tie-DB_File-SplitHash>=0:${PORTSDIR}/devel/p5-Tie-DB_File-SplitHash \
+ p5-Tie-FileLRUCache>=0:${PORTSDIR}/devel/p5-Tie-FileLRUCache
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes