aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING14
-rw-r--r--sysutils/ansible/Makefile29
-rw-r--r--sysutils/ansible/distinfo6
-rw-r--r--sysutils/ansible/files/pkg-message.in15
-rw-r--r--sysutils/ansible1/Makefile9
5 files changed, 42 insertions, 31 deletions
diff --git a/UPDATING b/UPDATING
index ebe15fa7db4e..bbacebf94716 100644
--- a/UPDATING
+++ b/UPDATING
@@ -26,6 +26,20 @@ you update your ports collection, before attempting any port upgrades.
Qt5 was fixed to ignore gold. If you see these errors, you
need to rebuild qt5-qmake, then all qt5-* ports.
+20170412:
+ AFFECTS: users of sysutils/ansible
+ AUTHOR: lifanov@FreeBSD.org
+
+ The default value for ansible_python_interpreter has been changed
+ to match the upstream /usr/bin/python. If managing FreeBSD systems,
+ adjust the hosts database to explicitly set a valid python interpreter:
+
+ [freebsd]
+ host1
+
+ [freebsd_vars]
+ ansible_python_interpreter=/usr/local/bin/python2.7
+
20170411:
AFFECTS: www/firefox
AUTHOR: gecko@FreeBSD.org
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index 36271307f0b9..5a9a050009a9 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION?= 2.2.2.0
+PORTVERSION?= 2.3.1.0
PORTREVISION?= 0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -13,24 +13,25 @@ COMMENT= Radically simple IT automation
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}jmespath>0:devel/py-jmespath \
+ ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr \
${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko \
- ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml
+
+EXTRA_PATCHES?= #
NO_ARCH= yes
-USES?= cpe python shebangfix
+USES?= cpe python
USE_PYTHON= autoplist distutils
-python_CMD= ${LOCALBASE}/bin/python
-SHEBANG_FILES+= lib/ansible/modules/core/*/*.py \
- lib/ansible/modules/core/*/*/*.py \
- lib/ansible/modules/extras/*/*.py \
- lib/ansible/modules/extras/*/*/*.py
CPE_VENDOR= ansibleworks
SUB_FILES= pkg-message
+SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
-PLIST_FILES+= man/man1/ansible-doc.1.gz \
+PLIST_FILES?= man/man1/ansible-console.1.gz \
+ man/man1/ansible-doc.1.gz \
man/man1/ansible-galaxy.1.gz \
man/man1/ansible-playbook.1.gz \
man/man1/ansible-pull.1.gz \
@@ -39,11 +40,7 @@ PLIST_FILES+= man/man1/ansible-doc.1.gz \
PORTEXAMPLES= ansible.cfg hosts
-OPTIONS_DEFINE= DOCS EXAMPLES NETADDR
-OPTIONS_DEFAULT=NETADDR
-
-NETADDR_DESC= Dependency on py-netaddr for ipaddr() filter
-NETADDR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
.for f in bin/ansible docs/man/man1/* examples/* lib/ansible/*.py \
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index 9d667baab5e8..c162d5d6ec44 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490707549
-SHA256 (ansible-2.2.2.0.tar.gz) = efd9c574168ac1916dd57f7c88d4dd2e13ef816af0ee49a8d34c77567886e4c2
-SIZE (ansible-2.2.2.0.tar.gz) = 2510182
+TIMESTAMP = 1496432079
+SHA256 (ansible-2.3.1.0.tar.gz) = cd4b8f53720fcd0c351156b840fdd15ecfbec22c951b5406ec503de49d40b9f5
+SIZE (ansible-2.3.1.0.tar.gz) = 4263357
diff --git a/sysutils/ansible/files/pkg-message.in b/sysutils/ansible/files/pkg-message.in
index ef541fdaa198..c94524d97dbc 100644
--- a/sysutils/ansible/files/pkg-message.in
+++ b/sysutils/ansible/files/pkg-message.in
@@ -8,22 +8,15 @@ host database and a sample configuration file:
%%EXAMPLESDIR%%/ansible.cfg
To use Ansible to control FreeBSD hosts, you need to
-install the lang/python package on remote machines.
-
-To use Ansible to control systems other than FreeBSD,
-set the Python interpreter in the host database for
-that system. Example:
+install the lang/python package on remote machines
+and set up a path to the python interpreter. Example:
[freebsd]
host1
host2
- [centos]
- host3
- host4
-
- [centos:vars]
- ansible_python_interpreter=/usr/bin/python
+ [freebsd:vars]
+ ansible_python_interpreter=%%PYTHON_CMD%%
Python notes:
diff --git a/sysutils/ansible1/Makefile b/sysutils/ansible1/Makefile
index b9d84753ef80..2c77943d836b 100644
--- a/sysutils/ansible1/Makefile
+++ b/sysutils/ansible1/Makefile
@@ -17,11 +17,18 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml \
USES= cpe python:2 shebangfix
+PLIST_FILES= man/man1/ansible-doc.1.gz \
+ man/man1/ansible-galaxy.1.gz \
+ man/man1/ansible-playbook.1.gz \
+ man/man1/ansible-pull.1.gz \
+ man/man1/ansible-vault.1.gz \
+ man/man1/ansible.1.gz
+
SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py
EXTRA_PATCHES=
DEPRECATED= please upgrade to sysutils/ansible
-EXPIRATION_DATE= 2016-10-01
+EXPIRATION_DATE= 2017-10-01
.include "${MASTERDIR}/Makefile"