aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/gale/Makefile5
-rw-r--r--net/echoping/Makefile3
-rw-r--r--polish/ekg2/Makefile11
-rw-r--r--textproc/libpathan/Makefile2
-rw-r--r--textproc/libpathan/pkg-plist2
-rw-r--r--x11/libX11/Makefile4
6 files changed, 14 insertions, 13 deletions
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index f2932628cc50..8ab16e928b46 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -21,9 +21,10 @@ LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww \
USE_ICONV= yes
USE_GNOME= glib12
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+LIBTOOLFILES= configure liboop/configure
USE_OPENSSL= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index d1aa8775812c..465e936c1708 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -53,4 +53,7 @@ PLIST_SUB+= WITH_PGSQL="@comment "
CONFIGURE_ARGS+=--enable-plugin="${PING_PLUGINS}"
+post-patch:
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
+
.include <bsd.port.post.mk>
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index 505f4548ee63..93951de3ee5d 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -44,12 +44,9 @@ MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/libpathan/Makefile b/textproc/libpathan/Makefile
index 16ea058fa431..38142d49f262 100644
--- a/textproc/libpathan/Makefile
+++ b/textproc/libpathan/Makefile
@@ -35,7 +35,7 @@ PLIST_SUB+= PATHAN_LIB_VERSION=${PATHAN_LIB_VERSION}
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's|LIBS="-lpthread|LIBS="${PTHREAD_LIBS}|g' \
+ @${REINPLACE_CMD} -e 's|LIBS="-lpthread|LIBS="${PTHREAD_LIBS}|g ; s|echo aout|echo elf|' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|targetoptions="-O2"|targetoptions="${CFLAGS}"|g' \
${WRKSRC}/runConfigure
diff --git a/textproc/libpathan/pkg-plist b/textproc/libpathan/pkg-plist
index fcd3705eb416..a056bc599553 100644
--- a/textproc/libpathan/pkg-plist
+++ b/textproc/libpathan/pkg-plist
@@ -274,6 +274,6 @@ include/pathan/simpleVariables/VariableTypeStore.hpp
@dirrm include/pathan
lib/libpathan.la
lib/libpathan.so.%%PATHAN_LIB_VERSION%%
-@exec ln -sf libpathen.so.%%PATHAN_LIB_VERSION%% %D/lib/libpathan.so
+@exec ln -sf libpathan.so.%%PATHAN_LIB_VERSION%% %D/lib/libpathan.so
@unexec if test ! -r %D/lib/libpathan.so; then rm -f %D/lib/libpathan.so; fi
@unexec if test ! -r %D/lib/libpathan.so.%%PATHAN_LIB_VERSION%%; then rm -f %D/lib/libpathan.so.%%PATHAN_LIB_VERSION%%; fi
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
index e1bf1841430a..5b29ff81d12f 100644
--- a/x11/libX11/Makefile
+++ b/x11/libX11/Makefile
@@ -25,12 +25,12 @@ CONFLICTS= XFree86-libraries-* xorg-libraries-*
USE_BZIP2= yes
PREFIX?= ${X11BASE}
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
CONFIGURE_ARGS+= --enable-xdmauth
CFLAGS+= -DMALLOC_0_RETURNS_NULL
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
USE_GNOME= gnomehack pkgconfig
.include <bsd.port.mk>