aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/openspc/Makefile4
-rw-r--r--cad/repsnapper/Makefile6
-rw-r--r--databases/gigabase/Makefile12
-rw-r--r--databases/gigabase/files/patch-Makefile.in36
-rw-r--r--databases/gigabase/files/patch-configure.in19
-rw-r--r--databases/mdbtools/Makefile4
-rw-r--r--databases/mysql-workbench51/Makefile38
-rw-r--r--databases/mysql-workbench51/files/patch-configure.in10
-rw-r--r--databases/mysql-workbench52/Makefile8
-rw-r--r--databases/tora/Makefile12
-rw-r--r--deskutils/growl-for-linux/Makefile5
-rw-r--r--deskutils/multisync/Makefile6
-rw-r--r--devel/apr2/Makefile19
-rw-r--r--devel/fstrm/Makefile6
-rw-r--r--devel/libr3/Makefile6
-rw-r--r--devel/ois/Makefile4
-rw-r--r--devel/pinba_engine/Makefile4
-rw-r--r--devel/sdts++/Makefile6
-rw-r--r--emulators/pcsxr/Makefile7
-rw-r--r--graphics/agg/Makefile6
-rw-r--r--graphics/cal3d-devel/Makefile5
-rw-r--r--graphics/cinepaint/Makefile7
-rw-r--r--graphics/gtimelapse/Makefile5
-rw-r--r--graphics/viewnior/Makefile20
-rw-r--r--irc/irssi-otr/Makefile8
-rw-r--r--japanese/FreeWnn-lib/Makefile.common3
26 files changed, 69 insertions, 197 deletions
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 152d1e3b6431..c6d6e030e007 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -15,9 +15,7 @@ COMMENT= Command-line player for .spc and .zst files
ONLY_FOR_ARCHS= i386 # contains x86 asm code
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= libtool
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
+USES= autoreconf libtool
USE_GCC= any
USE_LDCONFIG= yes
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 36ef0d87cb56..28f8dc557b0c 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -19,8 +19,7 @@ LICENSE_COMB= multi
LIB_DEPENDS= libgtkglextmm-x11-1.2.so:${PORTSDIR}/x11-toolkits/gtkglextmm \
libzip.so:${PORTSDIR}/archivers/libzip \
-USES= gmake libtool perl5 pkgconfig
-USE_AUTOTOOLS= libtoolize:env autoconf:env automake:env
+USES= autoreconf gmake libtool perl5 pkgconfig
USE_GNOME= gtkmm24 libxml++26
USE_GL= gl
USE_PERL5= build
@@ -36,9 +35,6 @@ NLS_USES= gettext
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALL_TARGET= install-strip
-pre-configure:
- cd ${WRKSRC} && ${SETENV} NOCONFIGURE=yes ./autogen.sh
-
post-install:
${MV} ${STAGEDIR}${PREFIX}/etc/xdg/repsnapper/repsnapper.conf \
${STAGEDIR}${PREFIX}/etc/xdg/repsnapper/repsnapper.conf.sample
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index bf5d402ad34a..a85606900a50 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -14,16 +14,10 @@ LICENSE= MIT
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= dos2unix gmake libtool
-DOS2UNIX_FILES= Makefile.in *.cpp *.h
+GNU_CONFIGURE= yes
+USES= autoreconf dos2unix gmake libtool
+DOS2UNIX_FILES= Makefile.in configure.in *.cpp *.h
USE_GCC= any
-USE_AUTOTOOLS= libtoolize aclocal autoconf
USE_LDCONFIG= yes
-LDFLAGS+= -pthread
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-lpthread|-pthread|' ${WRKSRC}/GiST/Makefile
-
.include <bsd.port.mk>
diff --git a/databases/gigabase/files/patch-Makefile.in b/databases/gigabase/files/patch-Makefile.in
index aaf5e0d7a13f..c00995326e14 100644
--- a/databases/gigabase/files/patch-Makefile.in
+++ b/databases/gigabase/files/patch-Makefile.in
@@ -1,15 +1,5 @@
--- Makefile.in.orig 2012-05-14 15:11:18.000000000 +0600
+++ Makefile.in 2012-05-14 15:14:15.000000000 +0600
-@@ -6,7 +6,8 @@
- exec_prefix = @exec_prefix@
- VPATH = @srcdir@
- LIBTOOL = ./libtool
--INSTALL = @INSTALL@
-+INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+INSTALL_DATA = @INSTALL_DATA@
-
- # Coment this for AIX/xlC 5.0
- LIBEXT=la
@@ -41,7 +42,7 @@
SUFF=@SUFF@
@@ -28,24 +18,6 @@
CXXFLAGS = @CXXFLAGS@ $(DEFS)
CFLAGS = @CFLAGS@ $(DEFS)
LD = $(CXX)
-@@ -70,7 +71,7 @@
-
- $(GB_LIB): $(OBJS)
- # Coment this for AIX/xlC 5.0
-- $(LIBTOOL) --mode=link $(CXX) -o $@ $(OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
-+ $(LIBTOOL) --mode=link $(CXX) -o $@ $(OBJS) $(LDFLAGS) -rpath $(libdir) -version-info $(VERSION)
- # Uncoment this for AIX/xlC 5.0
- # mkdir .libs
- # xlC_r -qmkshrobj=-10 -o .libs/gigabase.so $(OBJS)
-@@ -80,7 +81,7 @@
-
- $(CLI_LIB): $(CLI_OBJS)
- # Coment this for AIX/xlC 5.0
-- $(LIBTOOL) --mode=link $(CXX) -o $@ $(CLI_OBJS) $(LDFLAGS) @LTHREADSLIB@ -rpath $(libdir) -version-info $(VERSION)
-+ $(LIBTOOL) --mode=link $(CXX) -o $@ $(CLI_OBJS) $(LDFLAGS) -rpath $(libdir) -version-info $(VERSION)
- # Uncoment this for AIX/xlC 5.0
- # xlC_r -qmkshrobj=-10 -o .libs/cli.so $(CLI_OBJS)
- # ar rv .libs/libcli_r.a .libs/cli.so
@@ -154,15 +155,15 @@
$(LIBTOOL) --mode=link $(LD) $(LDFLAGS) -o testleak testleak.o $(GB_LIB) $(SLHACK)
@@ -56,16 +28,16 @@
- $(LIBTOOL) --mode=install $(INSTALL) $(GB_LIB) $(CLI_LIB) $(libdir)
- mkdir -p $(bindir)
+ mkdir -p $(DESTDIR)$(includedir)
-+ $(INSTALL_DATA) $(INCS) $(CLI_INCS) $(DESTDIR)$(includedir)
++ $(BSD_INSTALL_DATA) $(INCS) $(CLI_INCS) $(DESTDIR)$(includedir)
+ mkdir -p $(DESTDIR)$(libdir)
-+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $(GB_LIB) $(CLI_LIB) $(DESTDIR)$(libdir)
++ $(LIBTOOL) --mode=install $(BSD_INSTALL_PROGRAM) $(GB_LIB) $(CLI_LIB) $(DESTDIR)$(libdir)
+ mkdir -p $(DESTDIR)$(bindir)
if test -x .libs/subsql ; then \
- cp .libs/subsql $(bindir); \
-+ $(INSTALL_PROGRAM) .libs/subsql $(DESTDIR)$(bindir)/subsql_gb; \
++ $(BSD_INSTALL_PROGRAM) .libs/subsql $(DESTDIR)$(bindir)/subsql_gb; \
else \
- cp subsql $(bindir); \
-+ $(INSTALL_PROGRAM) subsql $(DESTDIR)$(bindir)/subsql_gb; \
++ $(BSD_INSTALL_PROGRAM) subsql $(DESTDIR)$(bindir)/subsql_gb; \
fi
# strip $(bindir)/subsql
diff --git a/databases/gigabase/files/patch-configure.in b/databases/gigabase/files/patch-configure.in
new file mode 100644
index 000000000000..427c8fccb8ca
--- /dev/null
+++ b/databases/gigabase/files/patch-configure.in
@@ -0,0 +1,19 @@
+--- configure.in.orig 2015-04-18 16:58:56 UTC
++++ configure.in
+@@ -4,7 +4,6 @@ AC_INIT(gigabase.h)
+ AC_CANONICAL_SYSTEM
+ AC_AIX
+ GB_VERSION=`$srcdir/mkversion`
+-AM_INIT_AUTOMAKE(gigabase, $GB_VERSION)
+
+ AC_ARG_ENABLE(pthreads, [
+ --disable-pthreads use this for single-threaded libs],
+@@ -84,7 +83,7 @@ AC_FUNC_STRFTIME
+ AC_CACHE_CHECK(for compiler option for pthreads, ac_cv_pthreads,
+ [SAVE_CXXFLAGS="$CXXFLAGS"
+ SAVE_CFLAGS="$CFLAGS"
+-for i in "" -pthread -pthreads -mthreads -mt; do
++for i in -lpthread -pthreads -mthreads -mt; do
+ CXXFLAGS="$SAVE_CXXFLAGS $i"
+ CFLAGS="$SAVE_CFLAGS $i"
+ AC_LANG_CPLUSPLUS
diff --git a/databases/mdbtools/Makefile b/databases/mdbtools/Makefile
index 79e541ed5892..11befc968deb 100644
--- a/databases/mdbtools/Makefile
+++ b/databases/mdbtools/Makefile
@@ -18,10 +18,8 @@ BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk \
txt2man:${PORTSDIR}/textproc/txt2man
LIB_DEPENDS= libodbc.so:${PORTSDIR}/databases/unixODBC
-USES= bison iconv libtool pathfix pkgconfig
+USES= autoreconf bison iconv libtool pathfix pkgconfig
PATHFIX_MAKEFILEIN= Makefile.am
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= -a -c -f
USE_LDCONFIG= yes
USE_GNOME= glib20
WANT_GNOME= yes
diff --git a/databases/mysql-workbench51/Makefile b/databases/mysql-workbench51/Makefile
index dccf4d4ab0f2..f1a0eb542a30 100644
--- a/databases/mysql-workbench51/Makefile
+++ b/databases/mysql-workbench51/Makefile
@@ -21,13 +21,9 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= PYTHON
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-ACLOCAL_ARGS= -I m4
-AUTOMAKE_ARGS= -a -c -f --foreign
USE_LDCONFIG= ${PREFIX}/lib/mysql-workbench
-SUBDIRS= ext/yassl/taocrypt ext/yassl ext/ctemplate/ctemplate-src .
-USES= dos2unix libtool lua:51
+USES= autoreconf dos2unix libtool lua:51
DOS2UNIX_REGEX= .*ext/yassl/.*(Makefile.am|configure.in)
USE_GL= gl
USE_GNOME= cairo gtkmm24 libglade2 libgnome libsigc++20 libxml2
@@ -63,34 +59,8 @@ post-patch:
${WRKSRC}/plugins/wb.printing/backend/stdafx.h \
${WRKSRC}/plugins/db.mysql/backend/db_plugin_be.cpp
-run-autotools-libtoolize:
-.for dir in ${SUBDIRS}
- @(cd ${WRKSRC}/${dir} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} ${LIBTOOLIZE_ARGS})
-.endfor
-
-run-autotools-aclocal:
-.for dir in ${SUBDIRS}
- @(cd ${WRKSRC}/${dir} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} ${ACLOCAL_ARGS})
-.endfor
-
-run-autotools-autoheader:
-.for dir in ${SUBDIRS}
- @(cd ${WRKSRC}/${dir} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER} ${AUTOHEADER_ARGS})
-.endfor
-
-run-autotools-automake:
-.for dir in ${SUBDIRS}
- @(cd ${WRKSRC}/${dir} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTOMAKE} ${AUTOMAKE_ARGS})
-.endfor
-
-run-autotools-autoconf:
-.for dir in ${SUBDIRS}
- @(cd ${WRKSRC}/${dir} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTOCONF} ${AUTOCONF_ARGS})
-.endfor
+pre-configure:
+ (cd ${WRKSRC}/ext/yassl && ${LOCALBASE}/bin/autoreconf -f -i)
+ (cd ${WRKSRC}/ext/yassl/taocrypt && ${LOCALBASE}/bin/autoreconf -f -i)
.include <bsd.port.mk>
diff --git a/databases/mysql-workbench51/files/patch-configure.in b/databases/mysql-workbench51/files/patch-configure.in
deleted file mode 100644
index 7453b98e36a5..000000000000
--- a/databases/mysql-workbench51/files/patch-configure.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.in.orig 2009-06-26 03:33:18.000000000 +0300
-+++ configure.in 2009-06-26 20:42:05.000000000 +0300
-@@ -422,7 +422,6 @@
-
- (
- cd ./ext/ctemplate/ctemplate-src &&
-- autoreconf -i -s;
- ./configure --prefix=$prefix --libdir=$libdir/mysql-workbench --disable-dependency-tracking
- )
-
diff --git a/databases/mysql-workbench52/Makefile b/databases/mysql-workbench52/Makefile
index 5eeccfd88c9e..b594379347cd 100644
--- a/databases/mysql-workbench52/Makefile
+++ b/databases/mysql-workbench52/Makefile
@@ -33,9 +33,9 @@ RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils \
OPTIONS_DEFINE= PYTHON_UTILS UNIXODBC
PYTHON_UTILS_DESC= Python scripts useful for administering MySQL
-USES= compiler:gcc-c++11-lib desktop-file-utils gettext gmake iconv \
- libtool lua:51 pathfix pkgconfig python:2 shared-mime-info \
- shebangfix
+USES= autoreconf compiler:gcc-c++11-lib desktop-file-utils gettext \
+ gmake iconv libtool lua:51 pathfix pkgconfig python:2 \
+ shared-mime-info shebangfix
SHEBANG_FILES= ext/ctemplate/ctemplate-src/src/htmlparser/*.py \
ext/mysql-utilities/*.py \
ext/mysql-utilities/scripts/*.py \
@@ -51,8 +51,6 @@ USE_GL= gl
USE_GNOME= gtk20 libxml2
USE_MYSQL= client
USE_SQLITE= 3
-USE_AUTOTOOLS= libtoolize aclocal automake autoheader autoconf
-AUTOMAKE_ARGS= --add-missing --copy --force-missing --foreign
GNU_CONFIGURE= yes
CONFIGURE_ENV= LUA_CFLAGS="$$(pkg-config --cflags lua-${LUA_VER})" \
LUA_LIBS="$$(pkg-config --libs lua-${LUA_VER})" \
diff --git a/databases/tora/Makefile b/databases/tora/Makefile
index f12ed15dc6ef..057ff5dcfe14 100644
--- a/databases/tora/Makefile
+++ b/databases/tora/Makefile
@@ -21,9 +21,8 @@ OPTIONS_DEFINE= PGSQL MYSQL DOCS
OPTIONS_DEFINE_i386= ORACLE
OPTIONS_DEFAULT= PGSQL MYSQL
-USE_AUTOTOOLS= aclocal automake autoconf autoheader libtoolize
USE_QT4= gui corelib sql xml network linguist moc_build uic_build rcc_build
-USES= gmake libtool makeinfo
+USES= autoreconf gmake libtool makeinfo
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pcre=${LOCALBASE}
LDFLAGS+= -L${LOCALBASE}/lib
@@ -55,15 +54,12 @@ ORACLE_VER= 8i # Client version
CONFIGURE_ARGS+= --with-oracle=${ORACLE_HOME} --with-oci-version=${ORACLE_VER:tu}
.endif
-run-autotools:
- (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./autogen.sh)
-
-pre-configure:
+post-patch:
.if ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e 's|/etc/torarc|${PREFIX}/etc/torarc|' \
+ @${REINPLACE_CMD} 's|/etc/torarc|${PREFIX}/etc/torarc|' \
${PREFIX2FIX:S|^|${WRKSRC}/|}
.else
- ${REINPLACE_CMD} -e 's|test doc|test|' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} 's|test doc|test|' ${WRKSRC}/Makefile.am
.endif
.include <bsd.port.mk>
diff --git a/deskutils/growl-for-linux/Makefile b/deskutils/growl-for-linux/Makefile
index 6c0fe58a749d..d9ca779f4fe2 100644
--- a/deskutils/growl-for-linux/Makefile
+++ b/deskutils/growl-for-linux/Makefile
@@ -15,8 +15,6 @@ BUILD_DEPENDS= desktop-file-install:${PORTSDIR}/devel/desktop-file-utils
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-AUTOMAKE_ARGS= -a -c -f
-
CONFIGURE_ARGS= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
GH_ACCOUNT= mattn
@@ -34,8 +32,7 @@ OPTIONS_DEFINE= LIBNOTIFY
PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
-USES= compiler:nestedfct libtool pkgconfig
-USE_AUTOTOOLS= aclocal autoconf automake libtoolize
+USES= autoreconf compiler:nestedfct libtool pkgconfig
USE_GITHUB= yes
USE_GNOME= gtk20
USE_OPENSSL= yes
diff --git a/deskutils/multisync/Makefile b/deskutils/multisync/Makefile
index 32650ea99e86..077596c12464 100644
--- a/deskutils/multisync/Makefile
+++ b/deskutils/multisync/Makefile
@@ -11,16 +11,14 @@ DISTNAME= multisync-${PORTVERSION}
MAINTAINER?= ports@FreeBSD.org
COMMENT?= Synchronize calendars, addressbooks, and other PIM data
+USES= autoreconf gmake libtool pathfix pkgconfig tar:bzip2
USE_GNOME= gnomeprefix libgnomeui
-USES= gmake libtool pathfix pkgconfig tar:bzip2
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
-pre-configure:
+post-patch:
@${FIND} ${WRKDIR} -type l -delete
.include <bsd.port.mk>
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index e00c8d2612b5..1a21fda2f9df 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -19,11 +19,11 @@ NO_PACKAGE= yes
SNAPDATE= 20140626144503
-USES= cpe tar:xz iconv perl5 pathfix libtool python:2,build
+USES= autoreconf:build cpe iconv libtool pathfix perl5 \
+ python:2,build tar:xz
CPE_PRODUCT= apr-util
CPE_VENDOR= apache
CPE_VERSION= ${PORTVERSION:S|.${SNAPDATE}||}
-USE_AUTOTOOLS= automake:env autoconf:env libtoolize:env
USE_PERL5= build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -113,7 +113,7 @@ post-patch:
-e 's|python -c|${PYTHON_VERSION} -c|' \
${WRKSRC}/build/buildcheck.sh
-run-autotools:
+pre-configure:
@(cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${SH} ./buildconf)
pre-install:
@@ -129,17 +129,4 @@ test: build
#regression-test: test
-debug_autoconf:
- @${ECHO} "LIBTOOL: ${LIBTOOL_VERSION}"
- @${ECHO} "AUTOCONF: dev ${dev_acver} cur ${cur_acver} use ${use_acver}"
- @${ECHO} "AUTOMAKE: dev ${dev_amver} cur ${cur_amver} use ${use_amver}"
- @${ECHO} "AUTOCONF_DIR: ${AUTOCONF_DIR}"
- @${ECHO} "BUILD_DEPENDS: ${BUILD_DEPENDS}"
- @${ECHO} "ACLOCAL_DIR: ${ACLOCAL_DIR}"
- @${ECHO} "LIBTOOL_SHAREDIR: ${LIBTOOL_SHAREDIR}"
- @${ECHO} "LIBTOOL_LIBEXECDIR: ${LIBTOOL_LIBEXECDIR}"
- @${ECHO} "LIBTOOL_M4: ${LIBTOOL_M4}"
- @${ECHO} "==================="
- @${ECHO} "${SETENV} ${CONFIGURE_ENV} ${SH} ./configure ${CONFIGURE_ARGS}" | ${TR} -s ' ' '\n'
-
.include <bsd.port.mk>
diff --git a/devel/fstrm/Makefile b/devel/fstrm/Makefile
index 9faa68430189..05f8f81789dc 100644
--- a/devel/fstrm/Makefile
+++ b/devel/fstrm/Makefile
@@ -18,9 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= farsightsec
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake autoconf:env libtoolize
+USES= autoreconf gmake libtool pkgconfig
USE_LDCONFIG= yes
-USES= libtool gmake pkgconfig
OPTIONS_DEFINE= DOXYGEN
DOXYGEN_DESC= Use doxygen for docs
@@ -29,7 +28,4 @@ DOXYGEN_ALL_TARGET= html-local
PORTDOCS= *
-run-autotools:
- cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ./autogen.sh
-
.include <bsd.port.mk>
diff --git a/devel/libr3/Makefile b/devel/libr3/Makefile
index 821149ad8ea9..53ef990a293e 100644
--- a/devel/libr3/Makefile
+++ b/devel/libr3/Makefile
@@ -16,9 +16,8 @@ LIB_DEPENDS= libcheck.so:${PORTSDIR}/devel/libcheck \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-graphviz
-USES= libtool pkgconfig
+USES= autoreconf libtool pkgconfig
INSTALL_TARGET= install-strip
-USE_AUTOTOOLS= aclocal:env autoconf:env autoheader:env automake:env libtoolize:env
USE_GITHUB= yes
GH_ACCOUNT= c9s
@@ -30,7 +29,4 @@ post-patch:
@${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' \
${WRKSRC}/Makefile.am
-pre-configure:
- (cd ${WRKSRC} && ./autogen.sh)
-
.include <bsd.port.mk>
diff --git a/devel/ois/Makefile b/devel/ois/Makefile
index 4bc80a815146..f89b7f21f4a9 100644
--- a/devel/ois/Makefile
+++ b/devel/ois/Makefile
@@ -13,10 +13,8 @@ COMMENT= Object Oriented Input System
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= pathfix gmake libtool
+USES= autoreconf gmake libtool pathfix
PATHFIX_MAKEFILEIN= Makefile.am
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= --add-missing --copy --foreign
USE_XORG= x11 xaw
USE_LDCONFIG= yes
diff --git a/devel/pinba_engine/Makefile b/devel/pinba_engine/Makefile
index ef3161c2037c..6dcea46bb004 100644
--- a/devel/pinba_engine/Makefile
+++ b/devel/pinba_engine/Makefile
@@ -30,11 +30,9 @@ MYSQL_WRKSRC= $$(cd ${PORTSDIR}/${_MYSQL_SERVER} && ${MAKE} -V WRKSRC)
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake libtool
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
+USES= autoreconf gmake libtool
USE_LDCONFIG= ${PREFIX}/lib/mysql/plugin
-AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ARGS= --disable-static \
--with-mysql=${MYSQL_WRKSRC} \
--libdir=${PREFIX}/lib/mysql/plugin
diff --git a/devel/sdts++/Makefile b/devel/sdts++/Makefile
index 63a4ff4bedbe..3a1f8a5d7685 100644
--- a/devel/sdts++/Makefile
+++ b/devel/sdts++/Makefile
@@ -14,10 +14,8 @@ COMMENT= C++ library for SDTS related development
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
DOS2UNIX_FILES= sdts++/io/sio_Utils.cpp
-USES= bison dos2unix gmake libtool makeinfo
-USE_AUTOTOOLS= libtoolize aclocal automake autoconf
-ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS= --add-missing --copy --foreign
+USES= autoreconf bison dos2unix gmake libtool makeinfo
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-boost=${LOCALBASE}/include
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 3057dc57d082..2c64c04cf6c4 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
ONLY_FOR_ARCHS= i386 amd64
-USE_AUTOTOOLS= autoconf:env aclocal:env automake:env libtoolize:env
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -33,7 +32,8 @@ USE_XORG= x11 xv xext xxf86vm xtst
USE_SDL= sdl
USE_GL= gl
-USES= tar:bzip2 dos2unix iconv gmake pkgconfig libtool desktop-file-utils
+USES= autoreconf desktop-file-utils dos2unix iconv gmake libtool \
+ pkgconfig tar:bzip2
DOS2UNIX_REGEX= .*\.(c|h|cpp|hpp|am)
PORTDOCS= ChangeLog README
@@ -60,9 +60,6 @@ post-patch:
@${REINPLACE_CMD} "s|%%DVD_DEVICE%%|${DEFAULT_DVD_DEVICE}|" \
${WRKSRC}/plugins/dfcdrom/cdr.h
-pre-configure:
- @(cd ${WRKSRC} && ${AUTORECONF} -fi)
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index 06da97e88998..e4543cad2e4e 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -16,12 +16,10 @@ LICENSE_FILE= ${WRKSRC}/copying
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+GNU_CONFIGURE= yes
+USES= autoreconf gmake libtool pathfix pkgconfig
USE_XORG= x11
-USES= gmake libtool pathfix pkgconfig
USE_SDL= sdl
-USE_AUTOTOOLS= aclocal autoheader autoconf libtoolize automake
-ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS= --foreign --add-missing --ignore-deps
MAKE_ENV= C="${CC}" AGGCXXFLAGS="${CXXFLAGS}"
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/graphics/cal3d-devel/Makefile b/graphics/cal3d-devel/Makefile
index b5b28c07092b..4439b13eebb9 100644
--- a/graphics/cal3d-devel/Makefile
+++ b/graphics/cal3d-devel/Makefile
@@ -15,11 +15,10 @@ COMMENT= Skeletal based 3D character animation library written in C++ (devel)
CONFLICTS= cal3d-[0-9]*
-USES= libtool pathfix pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
+USES= autoreconf libtool pathfix pkgconfig tar:bzip2
PATHFIX_MAKEFILEIN= Makefile.am
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= --add-missing
INSTALL_TARGET= install-strip
post-patch:
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index aeeb110d3a26..253c453fd15c 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -25,13 +25,12 @@ OPTIONS_DEFINE= OYRANOS PRINT
OYRANOS_DESC= ICC profile support via Oyranos
PRINT_DESC= Gutenprint (gimp-print) plugin
-USES= desktop-file-utils gettext gmake libtool pkgconfig python
+GNU_CONFIGURE= yes
+USES= autoreconf desktop-file-utils gettext gmake libtool \
+ pkgconfig python
USE_XORG= xmu
USE_GNOME= gtk20
USE_GHOSTSCRIPT_RUN=yes
-USE_AUTOTOOLS= libtoolize aclocal automake autoconf
-ACLOCAL_ARGS= -I aclocal
-AUTOMAKE_ARGS= --copy --force-missing --foreign --add-missing
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/graphics/gtimelapse/Makefile b/graphics/gtimelapse/Makefile
index 5a1512ca915d..c543ef709c63 100644
--- a/graphics/gtimelapse/Makefile
+++ b/graphics/gtimelapse/Makefile
@@ -16,13 +16,12 @@ LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= compiler:c++11-lib pkgconfig
+GNU_CONFIGURE= yes
+USES= autoreconf compiler:c++11-lib libtool pkgconfig
USE_WX= 3.0
USE_CXXSTD= c++11
WX_UNICODE= yes
WX_CONF_ARGS= absolute
-USE_AUTOTOOLS= libtoolize aclocal automake autoconf
-AUTOMAKE_ARGS= --add-missing --copy
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/viewnior/Makefile b/graphics/viewnior/Makefile
index 70516ad31d80..ddc3faf40784 100644
--- a/graphics/viewnior/Makefile
+++ b/graphics/viewnior/Makefile
@@ -11,8 +11,6 @@ COMMENT= Fast and simple image viewer
LICENSE= GPLv3
-BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common \
- p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
USE_GITHUB= yes
@@ -21,11 +19,11 @@ GH_PROJECT= Viewnior
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= fc0f5cb
-USES= desktop-file-utils gmake pkgconfig
+USES= autoreconf desktop-file-utils gmake libtool pkgconfig
USE_GNOME= glib20 gtk20
-USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
-AUTOMAKE_ARGS= --add-missing --force
GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS NEWS README
@@ -35,18 +33,6 @@ OPTIONS_SUB= yes
NLS_USES= gettext
-.include <bsd.port.options.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|$$(prefix)/$$(DATADIRNAME)/locale|$$(datarootdir)/locale|' \
- ${WRKSRC}/po/Makefile.in.in
-
-.if ! ${PORT_OPTIONS:MNLS}
- @${REINPLACE_CMD} -e 's|install: install-data|install:|' \
- ${WRKSRC}/po/Makefile.in.in
-.endif
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index 44cfcc464129..235fee134eac 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libotr.so:${PORTSDIR}/security/libotr \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
-USES= pkgconfig
+USES= autoreconf libtool pkgconfig
USE_LDCONFIG= yes
USE_GNOME= glib20
USE_GITHUB= yes
@@ -28,12 +28,8 @@ GH_PROJECT= ${PORTNAME}
GH_COMMIT= f4ecd19
GH_TAGNAME= v${PORTVERSION}
-USE_AUTOTOOLS= autoconf aclocal libtoolize automake
-ACLOCAL_ARGS= -I config
-AUTOMAKE_ARGS= --add-missing --no-force
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${LOCALBASE} --with-libotr-inc-prefix=${LOCALBASE}/include
+CONFIGURE_ARGS= --with-libotr-inc-prefix=${LOCALBASE}/include
INSTALL_TARGET= install-strip
PLIST_FILES= lib/irssi/modules/libotr.so \
diff --git a/japanese/FreeWnn-lib/Makefile.common b/japanese/FreeWnn-lib/Makefile.common
index 409f81917ade..e1a35982814a 100644
--- a/japanese/FreeWnn-lib/Makefile.common
+++ b/japanese/FreeWnn-lib/Makefile.common
@@ -1,8 +1,7 @@
# $FreeBSD$
GNU_CONFIGURE= yes
-USES= tar:bzip2 libtool:keepla
-USE_AUTOTOOLS= aclocal autoheader autoconf libtoolize
+USES= autoreconf libtool:keepla tar:bzip2
USE_LDCONFIG= yes
MAKE_ARGS= MANLANG="${MANLANG}" CDEBUGFLAGS="${CFLAGS}" \
LIBRARY_WNNMANDIR="3.libwnn" \