aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-RSA-Yandex/Makefile18
-rw-r--r--security/p5-Crypt-RSA-Yandex/distinfo2
-rw-r--r--security/p5-Crypt-RSA-Yandex/pkg-descr4
-rw-r--r--security/p5-Crypt-RSA-Yandex/pkg-plist10
5 files changed, 35 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c3780369fab6..e3d9ccc18a92 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -483,6 +483,7 @@
SUBDIR += p5-Crypt-RC6
SUBDIR += p5-Crypt-RIPEMD160
SUBDIR += p5-Crypt-RSA
+ SUBDIR += p5-Crypt-RSA-Yandex
SUBDIR += p5-Crypt-Rabbit
SUBDIR += p5-Crypt-RandPasswd
SUBDIR += p5-Crypt-Random
diff --git a/security/p5-Crypt-RSA-Yandex/Makefile b/security/p5-Crypt-RSA-Yandex/Makefile
new file mode 100644
index 000000000000..0f96e74914e6
--- /dev/null
+++ b/security/p5-Crypt-RSA-Yandex/Makefile
@@ -0,0 +1,18 @@
+# Created by: Anes Mukhametov <anes@anes.su>
+# $FreeBSD$
+
+PORTNAME= Crypt-RSA-Yandex
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anes@anes.su
+COMMENT= Perl binding to modified RSA (yamrsa)
+
+USES= perl5
+USE_PERL5= configure
+
+MAKE_ARGS= CC=${CXX}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-RSA-Yandex/distinfo b/security/p5-Crypt-RSA-Yandex/distinfo
new file mode 100644
index 000000000000..4825639c72c3
--- /dev/null
+++ b/security/p5-Crypt-RSA-Yandex/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-RSA-Yandex-0.06.tar.gz) = 012e3d2c5c0408dfbe8e7e3ca6beb2d3be9caa0f5991c8e43c4534a67cd1e596
+SIZE (Crypt-RSA-Yandex-0.06.tar.gz) = 53179
diff --git a/security/p5-Crypt-RSA-Yandex/pkg-descr b/security/p5-Crypt-RSA-Yandex/pkg-descr
new file mode 100644
index 000000000000..2ccd3309624d
--- /dev/null
+++ b/security/p5-Crypt-RSA-Yandex/pkg-descr
@@ -0,0 +1,4 @@
+Perl binding to modified RSA library (yamrsa) for encrypting Yandex auth token
+
+
+WWW: http://search.cpan.org/dist/Crypt-RSA-Yandex/
diff --git a/security/p5-Crypt-RSA-Yandex/pkg-plist b/security/p5-Crypt-RSA-Yandex/pkg-plist
new file mode 100644
index 000000000000..24e4ff5178f8
--- /dev/null
+++ b/security/p5-Crypt-RSA-Yandex/pkg-plist
@@ -0,0 +1,10 @@
+%%PERL5_MAN3%%/Crypt::RSA::Yandex.3.gz
+%%SITE_PERL%%/%%PERL_ARCH%%/Crypt/RSA/Yandex.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA/Yandex/Yandex.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA/Yandex/Yandex.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA/Yandex/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA/Yandex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/RSA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt/RSA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Crypt