aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-License/Makefile24
-rw-r--r--security/p5-Crypt-License/distinfo3
-rw-r--r--security/p5-Crypt-License/pkg-descr13
-rw-r--r--security/p5-Crypt-License/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e91b4ff5301d..623aab7876a6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -312,6 +312,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-Imail
SUBDIR += p5-Crypt-Khazad
+ SUBDIR += p5-Crypt-License
SUBDIR += p5-Crypt-Lite
SUBDIR += p5-Crypt-MySQL
SUBDIR += p5-Crypt-NULL
diff --git a/security/p5-Crypt-License/Makefile b/security/p5-Crypt-License/Makefile
new file mode 100644
index 000000000000..60a89a168750
--- /dev/null
+++ b/security/p5-Crypt-License/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-License
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-License
+PORTVERSION= 2.03
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension to examine a license
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::License.3 Crypt::License::Util.3 Crypt::License::Notice.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-License/distinfo b/security/p5-Crypt-License/distinfo
new file mode 100644
index 000000000000..a1348395a718
--- /dev/null
+++ b/security/p5-Crypt-License/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-License-2.03.tar.gz) = 0a9cb70700a3000470a5383b8aa5ec0a
+SHA256 (Crypt-License-2.03.tar.gz) = 64c2928141164ec1a6a8e0326a0bcb3210f6b6831cfcc1048cc49ab2b5f666ae
+SIZE (Crypt-License-2.03.tar.gz) = 38588
diff --git a/security/p5-Crypt-License/pkg-descr b/security/p5-Crypt-License/pkg-descr
new file mode 100644
index 000000000000..16808b74402d
--- /dev/null
+++ b/security/p5-Crypt-License/pkg-descr
@@ -0,0 +1,13 @@
+Crypt::License decodes an encrypted file and attempts to decrypt it by first,
+looking for a hash pointer in the caller program called $ptr2_License. The
+hash contains the path to the License file and an optional 'private' key list
+of modules which will decrypt only with the 'private' key. OR, a hash key of
+'next' with no particular value that indicates to look to the next caller on
+the stack for the License pointer. If the pointer is not present or the
+License file is not found successfully, then no further action is taken. If the
+License file is successfully opened, and the contents validated then the
+attached encrypted module is loaded and the seconds remaining until License
+expiration are returned or now() in the case of no expiration. Undef is
+returned for an expired license (module fails to load).
+
+WWW: http://search.cpan.org/dist/Crypt-License
diff --git a/security/p5-Crypt-License/pkg-plist b/security/p5-Crypt-License/pkg-plist
new file mode 100644
index 000000000000..c3d578e81d7d
--- /dev/null
+++ b/security/p5-Crypt-License/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Crypt/License.pm
+%%SITE_PERL%%/Crypt/License/Notice.pm
+%%SITE_PERL%%/Crypt/License/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/License/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/License/
+@dirrm %%SITE_PERL%%/Crypt/License/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true