aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xcb-proto/Makefile26
-rw-r--r--x11/xcb-proto/distinfo3
-rw-r--r--x11/xcb-proto/pkg-descr8
-rw-r--r--x11/xcb-proto/pkg-plist25
5 files changed, 63 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 3282ac43d988..366fe35d9cbf 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -245,6 +245,7 @@
SUBDIR += xbindkeys_config
SUBDIR += xcalib
SUBDIR += xcb
+ SUBDIR += xcb-proto
SUBDIR += xclip
SUBDIR += xcmd
SUBDIR += xco
diff --git a/x11/xcb-proto/Makefile b/x11/xcb-proto/Makefile
new file mode 100644
index 000000000000..6da7c692c07b
--- /dev/null
+++ b/x11/xcb-proto/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: xcb-proto
+# Date Created: 2006-08-23
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcb-proto
+PORTVERSION= 0.9.92
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= The X protocol C-language Binding (XCB) protocol
+
+BUILD_DEPENDS= xmllint:${PORTSDIR}/textproc/libxml2
+
+PREFIX?= ${X11BASE}
+USE_BZIP2= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+
+DATADIR= ${PREFIX}/share/xcb
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-proto/distinfo b/x11/xcb-proto/distinfo
new file mode 100644
index 000000000000..1d9e0d942a7b
--- /dev/null
+++ b/x11/xcb-proto/distinfo
@@ -0,0 +1,3 @@
+MD5 (xcb-proto-0.9.92.tar.bz2) = dc05c33ae1efc3e59d725887de9fc1a6
+SHA256 (xcb-proto-0.9.92.tar.bz2) = 4590e383f9bb6cc724e2033911a96d36f5966a5f82771bd3f06a63add2aa3e10
+SIZE (xcb-proto-0.9.92.tar.bz2) = 69107
diff --git a/x11/xcb-proto/pkg-descr b/x11/xcb-proto/pkg-descr
new file mode 100644
index 000000000000..7ae4144c72e4
--- /dev/null
+++ b/x11/xcb-proto/pkg-descr
@@ -0,0 +1,8 @@
+The X protocol C-language Binding (XCB) is a replacement for Xlib
+featuring a small footprint, latency hiding, direct access to the
+protocol, improved threading support, and extensibility.
+
+WWW: http://xcb.freedesktop.org/
+
+- Ashish Shukla
+wahjava@gmail.com
diff --git a/x11/xcb-proto/pkg-plist b/x11/xcb-proto/pkg-plist
new file mode 100644
index 000000000000..b4fdd20c4006
--- /dev/null
+++ b/x11/xcb-proto/pkg-plist
@@ -0,0 +1,25 @@
+libdata/pkgconfig/xcb-proto.pc
+%%DATADIR%%/bigreq.xml
+%%DATADIR%%/composite.xml
+%%DATADIR%%/damage.xml
+%%DATADIR%%/dpms.xml
+%%DATADIR%%/glx.xml
+%%DATADIR%%/randr.xml
+%%DATADIR%%/record.xml
+%%DATADIR%%/render.xml
+%%DATADIR%%/res.xml
+%%DATADIR%%/screensaver.xml
+%%DATADIR%%/shape.xml
+%%DATADIR%%/shm.xml
+%%DATADIR%%/sync.xml
+%%DATADIR%%/xc_misc.xml
+%%DATADIR%%/xcb.xsd
+%%DATADIR%%/xevie.xml
+%%DATADIR%%/xf86dri.xml
+%%DATADIR%%/xfixes.xml
+%%DATADIR%%/xprint.xml
+%%DATADIR%%/xproto.xml
+%%DATADIR%%/xtest.xml
+%%DATADIR%%/xv.xml
+%%DATADIR%%/xvmc.xml
+@dirrm %%DATADIR%%