aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-Algorithm-Dependency/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/devel/p5-Algorithm-Dependency/Makefile b/devel/p5-Algorithm-Dependency/Makefile
index 0f0525c0ab9d..1fc623df06ac 100644
--- a/devel/p5-Algorithm-Dependency/Makefile
+++ b/devel/p5-Algorithm-Dependency/Makefile
@@ -14,10 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Base class for implementing various dependency trees
-BUILD_DEPENDS= ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
- ${SITE_PERL}/Test/ClassAPI.pm:${PORTSDIR}/devel/p5-Test-ClassAPI \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Params-Util>=0.06:${PORTSDIR}/devel/p5-Params-Util
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= p5-Test-ClassAPI>=0.6:${PORTSDIR}/devel/p5-Test-ClassAPI
MAN3= Algorithm::Dependency.3 \
Algorithm::Dependency::Item.3 \
@@ -29,4 +28,10 @@ MAN3= Algorithm::Dependency.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+RUN_DEPENDS+= p5-Scalar-List-Utils>=1.11:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>