aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/python26/Makefile8
-rw-r--r--lang/python26/files/extra-patch-setup.py2
-rw-r--r--lang/python27/Makefile8
-rw-r--r--lang/python27/files/extra-patch-setup.py2
4 files changed, 16 insertions, 4 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 9aa26c7460b5..e77ea3a77044 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -62,7 +62,6 @@ OPTIONS= THREADS "Enable thread support" on \
.if defined(WITH_SEM)
.if ${OSVERSION} >= 701106
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-setup.py
SEM_MSG= ""
.else
IGNORE= POSIX semaphore support only works in FreeBSD 7-STABLE and later
@@ -182,6 +181,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITH_SEM)
+.if ${OSVERSION} >= 701106
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
+.endif
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib
diff --git a/lang/python26/files/extra-patch-setup.py b/lang/python26/files/extra-patch-setup.py
index b163a2ee5892..77dc467db500 100644
--- a/lang/python26/files/extra-patch-setup.py
+++ b/lang/python26/files/extra-patch-setup.py
@@ -4,7 +4,7 @@
)
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
+- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 9aa26c7460b5..e77ea3a77044 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -62,7 +62,6 @@ OPTIONS= THREADS "Enable thread support" on \
.if defined(WITH_SEM)
.if ${OSVERSION} >= 701106
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-setup.py
SEM_MSG= ""
.else
IGNORE= POSIX semaphore support only works in FreeBSD 7-STABLE and later
@@ -182,6 +181,13 @@ pre-patch:
${ECHO} "fpectl fpectlmodule.c" >> ${WRKSRC}/Modules/Setup.dist
.endif
+post-patch:
+.if defined(WITH_SEM)
+.if ${OSVERSION} >= 701106
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-setup.py
+.endif
+.endif
+
post-configure:
${TAR} -C ${WRKSRC} -cf - . | ${TAR} -C ${SHARED_WRKSRC} -xf -
${LN} -sf ${PYTHON_WRKSRC}/Lib ${WRKSRC}/Lib
diff --git a/lang/python27/files/extra-patch-setup.py b/lang/python27/files/extra-patch-setup.py
index b163a2ee5892..77dc467db500 100644
--- a/lang/python27/files/extra-patch-setup.py
+++ b/lang/python27/files/extra-patch-setup.py
@@ -4,7 +4,7 @@
)
libraries = []
-- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8'):
+- elif platform in ('freebsd4', 'freebsd5', 'freebsd6', 'freebsd7', 'freebsd8', 'freebsd9'):
+ elif platform in ('freebsd4', 'freebsd5', 'freebsd6'):
# FreeBSD's P1003.1b semaphore support is very experimental
# and has many known problems. (as of June 2008)