aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-pyinstaller/Makefile (renamed from devel/pyinstaller/Makefile)10
-rw-r--r--devel/py-pyinstaller/distinfo (renamed from devel/pyinstaller/distinfo)0
-rw-r--r--devel/py-pyinstaller/files/patch-PyInstaller_build.py (renamed from devel/pyinstaller/files/patch-PyInstaller_build.py)0
-rw-r--r--devel/py-pyinstaller/files/patch-PyInstaller_compat.py (renamed from devel/pyinstaller/files/patch-PyInstaller_compat.py)0
-rw-r--r--devel/py-pyinstaller/files/patch-bootloader_wscript (renamed from devel/pyinstaller/files/patch-bootloader_wscript)0
-rw-r--r--devel/py-pyinstaller/pkg-descr (renamed from devel/pyinstaller/pkg-descr)0
7 files changed, 6 insertions, 6 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 96373bdaee4b..47090fb8ce87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4210,6 +4210,7 @@
SUBDIR += py-pygit2
SUBDIR += py-pygithub
SUBDIR += py-pygpx
+ SUBDIR += py-pyinstaller
SUBDIR += py-pykde4
SUBDIR += py-pykdeuic4
SUBDIR += py-pyke
@@ -4496,7 +4497,6 @@
SUBDIR += pycount
SUBDIR += pydbus-common
SUBDIR += pygobject3-common
- SUBDIR += pyinstaller
SUBDIR += pylint
SUBDIR += pymacs
SUBDIR += pyobfuscate
diff --git a/devel/pyinstaller/Makefile b/devel/py-pyinstaller/Makefile
index 348fb1a81ed6..a62389cb0df4 100644
--- a/devel/pyinstaller/Makefile
+++ b/devel/py-pyinstaller/Makefile
@@ -1,18 +1,20 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-PORTNAME= PyInstaller
+PORTNAME= pyinstaller
PORTVERSION= 2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyInstaller-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Program to create standalone executables from Python scripts
LICENSE= GPLv2
+EXTRACT_AFTER_ARGS= --exclude doc/source --no-same-owner --no-same-permissions
USES= python
USE_PYTHON= autoplist distutils
@@ -31,10 +33,8 @@ post-patch:
pre-build:
cd ${WRKSRC}/bootloader && ${PYTHON_CMD} waf configure build install
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
-
-EXTRACT_AFTER_ARGS+= --exclude doc/source
diff --git a/devel/pyinstaller/distinfo b/devel/py-pyinstaller/distinfo
index b52a1157f2fa..b52a1157f2fa 100644
--- a/devel/pyinstaller/distinfo
+++ b/devel/py-pyinstaller/distinfo
diff --git a/devel/pyinstaller/files/patch-PyInstaller_build.py b/devel/py-pyinstaller/files/patch-PyInstaller_build.py
index afcd664062d6..afcd664062d6 100644
--- a/devel/pyinstaller/files/patch-PyInstaller_build.py
+++ b/devel/py-pyinstaller/files/patch-PyInstaller_build.py
diff --git a/devel/pyinstaller/files/patch-PyInstaller_compat.py b/devel/py-pyinstaller/files/patch-PyInstaller_compat.py
index 4b88a74a335a..4b88a74a335a 100644
--- a/devel/pyinstaller/files/patch-PyInstaller_compat.py
+++ b/devel/py-pyinstaller/files/patch-PyInstaller_compat.py
diff --git a/devel/pyinstaller/files/patch-bootloader_wscript b/devel/py-pyinstaller/files/patch-bootloader_wscript
index 08a3df3c3b7d..08a3df3c3b7d 100644
--- a/devel/pyinstaller/files/patch-bootloader_wscript
+++ b/devel/py-pyinstaller/files/patch-bootloader_wscript
diff --git a/devel/pyinstaller/pkg-descr b/devel/py-pyinstaller/pkg-descr
index 6e12eb02a2a7..6e12eb02a2a7 100644
--- a/devel/pyinstaller/pkg-descr
+++ b/devel/py-pyinstaller/pkg-descr