aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/festival+OGI/Makefile8
-rw-r--r--audio/festival/Makefile8
-rw-r--r--chinese/chinput2/Makefile8
-rw-r--r--devel/i386-rtems-gcc/Makefile8
-rw-r--r--lang/dylan/Makefile4
-rw-r--r--www/aria/Makefile8
6 files changed, 39 insertions, 5 deletions
diff --git a/audio/festival+OGI/Makefile b/audio/festival+OGI/Makefile
index eca2e92a4a6b..9ff2776346b5 100644
--- a/audio/festival+OGI/Makefile
+++ b/audio/festival+OGI/Makefile
@@ -45,6 +45,12 @@ RESTRICTED= no-commercial-use
PLIST= ${WRKDIR}/pkg-plist
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
WRKSRC= ${WRKDIR}
USE_GMAKE= yes
@@ -145,4 +151,4 @@ do-install:
${INSTALL_MAN} ${FESTIVAL}/doc/festival.1 ${PREFIX}/man/man1/festival.1
${INSTALL_MAN} ${FESTIVAL}/doc/festival_client.1 ${PREFIX}/man/man1/festival_client.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index eca2e92a4a6b..9ff2776346b5 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -45,6 +45,12 @@ RESTRICTED= no-commercial-use
PLIST= ${WRKDIR}/pkg-plist
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
WRKSRC= ${WRKDIR}
USE_GMAKE= yes
@@ -145,4 +151,4 @@ do-install:
${INSTALL_MAN} ${FESTIVAL}/doc/festival.1 ${PREFIX}/man/man1/festival.1
${INSTALL_MAN} ${FESTIVAL}/doc/festival_client.1 ${PREFIX}/man/man1/festival_client.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/chinese/chinput2/Makefile b/chinese/chinput2/Makefile
index 4f91c469605b..3c971f4e44f4 100644
--- a/chinese/chinput2/Makefile
+++ b/chinese/chinput2/Makefile
@@ -18,6 +18,12 @@ COMMENT= Another Chinese GB2312 and Big5 X11 input server
BUILD_DEPENDS= mysql:${PORTSDIR}/databases/mysql323-client
RUN_DEPENDS= mysql:${PORTSDIR}/databases/mysql323-client
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
USE_XLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -34,4 +40,4 @@ post-install:
@echo " -phj@cn.freebsd.org"
@echo
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index ffd29dae010b..e7c730d3fedd 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -23,6 +23,12 @@ PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
MAINTAINER= jeh@FreeBSD.org
COMMENT= FSF C/C++-gcc-3.2.1 base-port for RTEMS development
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
LCLTARGET?= i386-rtems
GCCNAME= gcc-3.2.1
@@ -76,4 +82,4 @@ post-install:
@install-info ${PREFIX}/info/cpp.info ${PREFIX}/info/dir
@install-info ${PREFIX}/info/gcc.info ${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/dylan/Makefile b/lang/dylan/Makefile
index a5816a9f2399..5597f9d3c1e4 100644
--- a/lang/dylan/Makefile
+++ b/lang/dylan/Makefile
@@ -54,6 +54,10 @@ MAN7= dylan.7 gwydion.7
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
USE_REINPLACE= yes
.if ${HAVE_GNOME:Mgtk12}!=""
USE_GNOME+= gtk12
diff --git a/www/aria/Makefile b/www/aria/Makefile
index 0c8fe72e528c..d25de8169349 100644
--- a/www/aria/Makefile
+++ b/www/aria/Makefile
@@ -16,6 +16,12 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.t/test/}
MAINTAINER= nakai@FreeBSD.org
COMMENT= Yet another download tool
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not build"
+.endif
+
USE_BZIP2= yes
USE_GNOME= gtk12
USE_OPENSSL= yes
@@ -39,4 +45,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.euc ${PREFIX}/share/doc/${PORTNAME}/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>