aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/tome4/Makefile7
-rw-r--r--games/tome4/distinfo4
-rw-r--r--games/tome4/files/patch-build__te4core.lua38
-rw-r--r--games/tome4/files/patch-premake4.lua22
-rw-r--r--games/tome4/files/patch-src__bspatch.c177
-rw-r--r--games/tome4/files/patch-src__core_lua.c46
-rw-r--r--games/tome4/files/patch-src__getself.c8
-rw-r--r--games/tome4/files/patch-src__lpeg__lptypes.h11
-rw-r--r--games/tome4/files/patch-src__luaprofiler__core_profiler.c12
-rw-r--r--games/tome4/files/patch-src__web.c11
-rw-r--r--games/tome4/files/pkg-message.in2
-rw-r--r--games/tome4/pkg-plist165
12 files changed, 431 insertions, 72 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index dfe692f40378..ee6c2f021523 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= tome4
-PORTVERSION= 1.1.5
-PORTREVISION= 1
+PORTVERSION= 1.2.2
CATEGORIES= games
MASTER_SITES= http://te4.org/dl/t-engine/ \
- SF/lifanov-ports-icons/${PORTNAME}/:icons
+ SF/lifanov-ports-distfiles/${PORTNAME}/:icons
DISTFILES= t-engine4-src-${PORTVERSION}${EXTRACT_SUFX} \
${PORTNAME}.png:icons
EXTRACT_ONLY= t-engine4-src-${PORTVERSION}${EXTRACT_SUFX}
@@ -27,10 +26,12 @@ MAKE_ARGS+= config=release verbose=yes ARCH=""
USES= gmake openal:al tar:bzip2
USE_SDL= image2 sdl2 ttf2
USE_GL= gl glu
+USE_CSTD= gnu89
SUB_FILES= tome4
MAKE_JOBS_UNSAFE=yes
pre-build:
+ @${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
(cd ${WRKSRC} && premake4 gmake)
@${REINPLACE_CMD} 's|-lpthread|-pthread|' ${WRKSRC}/build/TEngine.make
diff --git a/games/tome4/distinfo b/games/tome4/distinfo
index f40b026b8917..7e4ab920b4be 100644
--- a/games/tome4/distinfo
+++ b/games/tome4/distinfo
@@ -1,4 +1,4 @@
-SHA256 (t-engine4-src-1.1.5.tar.bz2) = f911b095064153b97b62fcb72124cdbcf19d712c24e5a735c7de6b98e527d4dd
-SIZE (t-engine4-src-1.1.5.tar.bz2) = 259331390
+SHA256 (t-engine4-src-1.2.2.tar.bz2) = 6d5706636efac1418828c4cc56b61b277848ccc2bdee0edf67ce9dbfd23c7995
+SIZE (t-engine4-src-1.2.2.tar.bz2) = 278797999
SHA256 (tome4.png) = b5223208ca6f0a51f8bbe3b96055f38f94336dbeca6704db6684fec00fad1a36
SIZE (tome4.png) = 37143
diff --git a/games/tome4/files/patch-build__te4core.lua b/games/tome4/files/patch-build__te4core.lua
index 75225fa254af..81a9914c4dcb 100644
--- a/games/tome4/files/patch-build__te4core.lua
+++ b/games/tome4/files/patch-build__te4core.lua
@@ -1,20 +1,28 @@
---- ./build/te4core.lua.orig 2014-01-05 19:42:37.000000000 -0500
-+++ ./build/te4core.lua 2014-01-05 19:42:37.000000000 -0500
-@@ -159,7 +159,7 @@
+--- ./build/te4core.lua.orig 2014-05-19 04:42:12.000000000 -0400
++++ ./build/te4core.lua 2014-06-04 12:45:57.973283399 -0400
+@@ -40,7 +40,6 @@
+ links { "physfs", "lua".._OPTIONS.lua, "fov", "luasocket", "luaprofiler", "lpeg", "tcodimport", "lxp", "expatstatic", "luamd5", "luazlib", "luabitop", "te4-bzip" }
+ defines { "_DEFAULT_VIDEOMODE_FLAGS_='SDL_HWSURFACE|SDL_DOUBLEBUF'" }
+ defines { [[TENGINE_HOME_PATH='".t-engine"']], "TE4CORE_VERSION="..TE4CORE_VERSION }
+- buildoptions { "-O3" }
- files { "../src/luajit2/src/host/minilua.c" }
-
-- local arch_test = os.capture("gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
-+ local arch_test = os.capture("cc -E ../src/luajit2/src/lj_arch.h -dM", true)
+ if _OPTIONS.relpath=="32" then linkoptions{"-Wl,-rpath -Wl,\\\$\$ORIGIN/lib "} end
+ if _OPTIONS.relpath=="64" then linkoptions{"-Wl,-rpath -Wl,\\\$\$ORIGIN/lib64 "} end
+@@ -194,7 +193,7 @@
+ if _OPTIONS.wincross then
+ arch_test = os.capture("i686-pc-mingw32-gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
+ else
+- arch_test = os.capture("gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
++ arch_test = os.capture("cc -E ../src/luajit2/src/lj_arch.h -dM", true)
+ end
if string.find(arch_test, "LJ_TARGET_X64") then
- target_arch = "x64"
-@@ -201,7 +201,7 @@
- links { "minilua" }
-
- local dasm_flags = ""
-- local arch_test = os.capture("gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
-+ local arch_test = os.capture("cc -E ../src/luajit2/src/lj_arch.h -dM", true)
+@@ -253,7 +252,7 @@
+ if _OPTIONS.wincross then
+ arch_test = os.capture("i686-pc-mingw32-gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
+ else
+- arch_test = os.capture("gcc -E ../src/luajit2/src/lj_arch.h -dM", true)
++ arch_test = os.capture("cc -E ../src/luajit2/src/lj_arch.h -dM", true)
+ end
if string.find(arch_test, "LJ_TARGET_X64") then
- target_arch = "x64"
diff --git a/games/tome4/files/patch-premake4.lua b/games/tome4/files/patch-premake4.lua
index ecaf698b822e..75c291cfe4c4 100644
--- a/games/tome4/files/patch-premake4.lua
+++ b/games/tome4/files/patch-premake4.lua
@@ -1,6 +1,18 @@
---- ./premake4.lua.orig 2014-01-06 20:04:42.000000000 -0500
-+++ ./premake4.lua 2014-03-23 19:34:38.037102075 -0400
-@@ -30,11 +30,14 @@
+--- ./premake4.lua.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./premake4.lua 2014-06-04 12:40:26.968305458 -0400
+@@ -28,11 +28,6 @@
+ "/usr/i686-pc-mingw32/usr/include/",
+ "/usr/i686-pc-mingw32/usr/include/GL/",
+ }
+- else
+- includedirs {
+- "/opt/SDL-2.0/include/SDL2",
+- "/usr/include/GL",
+- }
+ end
+ if _OPTIONS.lua == "default" then includedirs{"src/lua"}
+ elseif _OPTIONS.lua == "jit2" then includedirs{"src/luajit2/src", "src/luajit2/dynasm",}
+@@ -44,11 +39,14 @@
configuration "bsd"
libdirs {
@@ -14,9 +26,9 @@
+ "-pthread",
+ }
+ if _OPTIONS.wincross then
configuration "windows"
- libdirs {
-@@ -61,8 +64,6 @@
+@@ -86,8 +84,6 @@
configuration "Release"
defines { "NDEBUG=1" }
diff --git a/games/tome4/files/patch-src__bspatch.c b/games/tome4/files/patch-src__bspatch.c
new file mode 100644
index 000000000000..9fb6c683da00
--- /dev/null
+++ b/games/tome4/files/patch-src__bspatch.c
@@ -0,0 +1,177 @@
+--- ./src/bspatch.c.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/bspatch.c 2014-06-04 12:40:26.918305830 -0400
+@@ -24,13 +24,13 @@
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+-#include "bzlib.h"
++#include <bzlib.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <err.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+-#include <sys/types.h>
+
+ static off_t offtin(u_char *buf)
+ {
+@@ -50,13 +50,7 @@
+ return y;
+ }
+
+-#ifndef fseeko
+-#define fseeko fseek
+-#endif
+-
+-#define returnerr(ret, str, f1, f2) { printf(str, f1, f2); perror("\nError in bspatch\n"); return (ret); }
+-
+-int bspatch(char *infile, char *outfile, char *patchfile)
++int bspatch(int argc,char * argv[])
+ {
+ FILE * f, * cpf, * dpf, * epf;
+ BZFILE * cpfbz2, * dpfbz2, * epfbz2;
+@@ -71,9 +65,11 @@
+ off_t lenread;
+ off_t i;
+
++ if(argc!=4) errx(1,"usage: %s oldfile newfile patchfile\n",argv[0]);
++
+ /* Open patch file */
+- if ((f = fopen(patchfile, "r")) == NULL)
+- returnerr(1, "fopen(%s)", patchfile, 0);
++ if ((f = fopen(argv[3], "r")) == NULL)
++ err(1, "fopen(%s)", argv[3]);
+
+ /*
+ File format:
+@@ -91,53 +87,54 @@
+
+ /* Read header */
+ if (fread(header, 1, 32, f) < 32) {
+- if (feof(f)) returnerr(1, "Corrupt patch", 0, 0);
+- returnerr(1, "fread(%s)", patchfile, 0);
++ if (feof(f))
++ errx(1, "Corrupt patch\n");
++ err(1, "fread(%s)", argv[3]);
+ }
+
+ /* Check for appropriate magic */
+ if (memcmp(header, "BSDIFF40", 8) != 0)
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1, "Corrupt patch\n");
+
+ /* Read lengths from header */
+ bzctrllen=offtin(header+8);
+ bzdatalen=offtin(header+16);
+ newsize=offtin(header+24);
+ if((bzctrllen<0) || (bzdatalen<0) || (newsize<0))
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1,"Corrupt patch\n");
+
+ /* Close patch file and re-open it via libbzip2 at the right places */
+ if (fclose(f))
+- returnerr(1, "fclose(%s)", patchfile, 0);
+- if ((cpf = fopen(patchfile, "r")) == NULL)
+- returnerr(1, "fopen(%s)", patchfile, 0);
++ err(1, "fclose(%s)", argv[3]);
++ if ((cpf = fopen(argv[3], "r")) == NULL)
++ err(1, "fopen(%s)", argv[3]);
+ if (fseeko(cpf, 32, SEEK_SET))
+- returnerr(1, "fseeko(%s, %lld)", patchfile,
++ err(1, "fseeko(%s, %lld)", argv[3],
+ (long long)32);
+ if ((cpfbz2 = BZ2_bzReadOpen(&cbz2err, cpf, 0, 0, NULL, 0)) == NULL)
+- returnerr(1, "BZ2_bzReadOpen, bz2err = %d", cbz2err, 0);
+- if ((dpf = fopen(patchfile, "r")) == NULL)
+- returnerr(1, "fopen(%s)", patchfile, 0);
++ errx(1, "BZ2_bzReadOpen, bz2err = %d", cbz2err);
++ if ((dpf = fopen(argv[3], "r")) == NULL)
++ err(1, "fopen(%s)", argv[3]);
+ if (fseeko(dpf, 32 + bzctrllen, SEEK_SET))
+- returnerr(1, "fseeko(%s, %lld)", patchfile,
++ err(1, "fseeko(%s, %lld)", argv[3],
+ (long long)(32 + bzctrllen));
+ if ((dpfbz2 = BZ2_bzReadOpen(&dbz2err, dpf, 0, 0, NULL, 0)) == NULL)
+- returnerr(1, "BZ2_bzReadOpen, bz2err = %d", dbz2err, 0);
+- if ((epf = fopen(patchfile, "r")) == NULL)
+- returnerr(1, "fopen(%s)", patchfile, 0);
++ errx(1, "BZ2_bzReadOpen, bz2err = %d", dbz2err);
++ if ((epf = fopen(argv[3], "r")) == NULL)
++ err(1, "fopen(%s)", argv[3]);
+ if (fseeko(epf, 32 + bzctrllen + bzdatalen, SEEK_SET))
+- returnerr(1, "fseeko(%s, %lld)", patchfile,
++ err(1, "fseeko(%s, %lld)", argv[3],
+ (long long)(32 + bzctrllen + bzdatalen));
+ if ((epfbz2 = BZ2_bzReadOpen(&ebz2err, epf, 0, 0, NULL, 0)) == NULL)
+- returnerr(1, "BZ2_bzReadOpen, bz2err = %d", ebz2err, 0);
++ errx(1, "BZ2_bzReadOpen, bz2err = %d", ebz2err);
+
+- if(((fd=open(infile,O_RDONLY,0))<0) ||
++ if(((fd=open(argv[1],O_RDONLY,0))<0) ||
+ ((oldsize=lseek(fd,0,SEEK_END))==-1) ||
+ ((old=malloc(oldsize+1))==NULL) ||
+ (lseek(fd,0,SEEK_SET)!=0) ||
+ (read(fd,old,oldsize)!=oldsize) ||
+- (close(fd)==-1)) returnerr(1,"%s",infile, 0);
+- if((new=malloc(newsize+1))==NULL) returnerr(1,"not enough memory", 0, 0);
++ (close(fd)==-1)) err(1,"%s",argv[1]);
++ if((new=malloc(newsize+1))==NULL) err(1,NULL);
+
+ oldpos=0;newpos=0;
+ while(newpos<newsize) {
+@@ -146,19 +143,19 @@
+ lenread = BZ2_bzRead(&cbz2err, cpfbz2, buf, 8);
+ if ((lenread < 8) || ((cbz2err != BZ_OK) &&
+ (cbz2err != BZ_STREAM_END)))
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1, "Corrupt patch\n");
+ ctrl[i]=offtin(buf);
+ };
+
+ /* Sanity-check */
+ if(newpos+ctrl[0]>newsize)
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1,"Corrupt patch\n");
+
+ /* Read diff string */
+ lenread = BZ2_bzRead(&dbz2err, dpfbz2, new + newpos, ctrl[0]);
+ if ((lenread < ctrl[0]) ||
+ ((dbz2err != BZ_OK) && (dbz2err != BZ_STREAM_END)))
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1, "Corrupt patch\n");
+
+ /* Add old data to diff string */
+ for(i=0;i<ctrl[0];i++)
+@@ -171,13 +168,13 @@
+
+ /* Sanity-check */
+ if(newpos+ctrl[1]>newsize)
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1,"Corrupt patch\n");
+
+ /* Read extra string */
+ lenread = BZ2_bzRead(&ebz2err, epfbz2, new + newpos, ctrl[1]);
+ if ((lenread < ctrl[1]) ||
+ ((ebz2err != BZ_OK) && (ebz2err != BZ_STREAM_END)))
+- returnerr(1, "Corrupt patch", 0, 0);
++ errx(1, "Corrupt patch\n");
+
+ /* Adjust pointers */
+ newpos+=ctrl[1];
+@@ -189,12 +186,12 @@
+ BZ2_bzReadClose(&dbz2err, dpfbz2);
+ BZ2_bzReadClose(&ebz2err, epfbz2);
+ if (fclose(cpf) || fclose(dpf) || fclose(epf))
+- returnerr(1, "fclose(%s)", patchfile, 0);
++ err(1, "fclose(%s)", argv[3]);
+
+ /* Write the new file */
+- if(((fd=open(outfile,O_CREAT|O_TRUNC|O_WRONLY,0666))<0) ||
++ if(((fd=open(argv[2],O_CREAT|O_TRUNC|O_WRONLY,0666))<0) ||
+ (write(fd,new,newsize)!=newsize) || (close(fd)==-1))
+- returnerr(1,"%s",outfile, 0);
++ err(1,"%s",argv[2]);
+
+ free(new);
+ free(old);
diff --git a/games/tome4/files/patch-src__core_lua.c b/games/tome4/files/patch-src__core_lua.c
new file mode 100644
index 000000000000..f66ee65340a6
--- /dev/null
+++ b/games/tome4/files/patch-src__core_lua.c
@@ -0,0 +1,46 @@
+--- ./src/core_lua.c.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/core_lua.c 2014-06-04 12:40:26.921306625 -0400
+@@ -416,7 +416,7 @@
+
+ static int lua_key_set_clipboard(lua_State *L)
+ {
+- char *str = luaL_checkstring(L, 1);
++ const char *str = luaL_checkstring(L, 1);
+ SDL_SetClipboardText(str);
+ return 0;
+ }
+@@ -1458,7 +1458,7 @@
+ );
+ SDL_FillRect(s, NULL, SDL_MapRGBA(s->format, 255, 255, 255, 255));
+
+- glGenTextures(1, &gl_tex_white);
++ glGenTextures(1, (GLuint *)&gl_tex_white);
+ tfglBindTexture(GL_TEXTURE_2D, gl_tex_white);
+ int fw, fh;
+ make_texture_for_surface(s, &fw, &fh, false);
+@@ -2870,7 +2870,7 @@
+ static void png_write_data_fn(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+ luaL_Buffer *B = (luaL_Buffer*)png_get_io_ptr(png_ptr);
+- luaL_addlstring(B, data, length);
++ luaL_addlstring(B, (const char *)data, length);
+ }
+ static void png_output_flush_fn(png_structp png_ptr)
+ {
+@@ -3561,14 +3561,14 @@
+ uLongf len;
+ const char *data = luaL_checklstring(L, 1, (size_t*)&len);
+ uLongf reslen = len * 1.1 + 12;
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ unsigned
+ #endif
+ char *res = malloc(reslen);
+ z_stream zi;
+
+ zi.next_in = (
+-#ifdef __APPLE__
++#if defined(__APPLE__) || defined(__FreeBSD__)
+ unsigned
+ #endif
+ char *)data;
diff --git a/games/tome4/files/patch-src__getself.c b/games/tome4/files/patch-src__getself.c
index b4629fe5c2ea..ac7b8d29d181 100644
--- a/games/tome4/files/patch-src__getself.c
+++ b/games/tome4/files/patch-src__getself.c
@@ -1,5 +1,5 @@
---- ./src/getself.c.orig 2014-01-05 19:42:37.000000000 -0500
-+++ ./src/getself.c 2014-02-06 13:23:22.555164880 -0500
+--- ./src/getself.c.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/getself.c 2014-06-04 12:40:26.923307598 -0400
@@ -42,6 +42,8 @@
#elif defined(SELFEXE_BSD)
#include <limits.h>
@@ -9,12 +9,12 @@
const char *get_self_executable(int argc, char **argv)
{
static char res[PATH_MAX];
-@@ -51,14 +53,13 @@
+@@ -51,14 +53,12 @@
return res;
}
-#import <sys/sysctl.h>
-
+-
int get_number_cpus()
{
int count;
diff --git a/games/tome4/files/patch-src__lpeg__lptypes.h b/games/tome4/files/patch-src__lpeg__lptypes.h
new file mode 100644
index 000000000000..ddadebc0dfcd
--- /dev/null
+++ b/games/tome4/files/patch-src__lpeg__lptypes.h
@@ -0,0 +1,11 @@
+--- ./src/lpeg/lptypes.h.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/lpeg/lptypes.h 2014-06-04 12:40:26.924305800 -0400
+@@ -9,7 +9,7 @@
+ #define lptypes_h
+
+
+-#if !defined(LPEG_DEBUG)
++#if !defined(LPEG_DEBUG) && !defined(NDEBUG)
+ #define NDEBUG
+ #endif
+
diff --git a/games/tome4/files/patch-src__luaprofiler__core_profiler.c b/games/tome4/files/patch-src__luaprofiler__core_profiler.c
new file mode 100644
index 000000000000..f2ac69975d56
--- /dev/null
+++ b/games/tome4/files/patch-src__luaprofiler__core_profiler.c
@@ -0,0 +1,12 @@
+--- ./src/luaprofiler/core_profiler.c.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/luaprofiler/core_profiler.c 2014-06-04 12:40:26.925305573 -0400
+@@ -130,8 +130,7 @@
+ out_filename = (_out_filename) ? (_out_filename):(OUT_FILENAME);
+
+ /* the random string to build the logname is extracted */
+- /* from 'tmpnam()' (the '/tmp/' part is deleted) */
+- randstr = tmpnam(NULL);
++ randstr = (char *)tmpfile();
+ for (s = strtok(randstr, "/\\"); s; s = strtok(NULL, "/\\")) {
+ randstr = s;
+ }
diff --git a/games/tome4/files/patch-src__web.c b/games/tome4/files/patch-src__web.c
new file mode 100644
index 000000000000..b5e22b5b426a
--- /dev/null
+++ b/games/tome4/files/patch-src__web.c
@@ -0,0 +1,11 @@
+--- ./src/web.c.orig 2014-05-19 04:42:14.000000000 -0400
++++ ./src/web.c 2014-06-04 12:40:26.927305671 -0400
+@@ -517,7 +517,7 @@
+ char *spawnname = NULL;
+ char *libname = NULL;
+ const char *self = get_self_executable(g_argc, g_argv);
+-#if defined(SELFEXE_LINUX) || defined(SELFEXE_BSD)
++#if defined(SELFEXE_LINUX)
+ #if defined(TE4_RELPATH64)
+ const char *spawnbname = "cef3spawn64";
+ spawnname = malloc(strlen(self) + strlen(spawnbname) + 1);
diff --git a/games/tome4/files/pkg-message.in b/games/tome4/files/pkg-message.in
new file mode 100644
index 000000000000..22a942465e8e
--- /dev/null
+++ b/games/tome4/files/pkg-message.in
@@ -0,0 +1,2 @@
+The game files for ToME can be found in %%DATADIR%%.
+Launch the game with a wrapper in %%PREFIX%%/tome4
diff --git a/games/tome4/pkg-plist b/games/tome4/pkg-plist
index 1e3a4172ac0d..1619abcfcefe 100644
--- a/games/tome4/pkg-plist
+++ b/games/tome4/pkg-plist
@@ -4,10 +4,10 @@ share/pixmaps/tome4.png
%%DATADIR%%/game/addons/tome-addon-dev.teaa
%%DATADIR%%/game/addons/tome-items-vault.teaa
%%DATADIR%%/game/addons/tome-stone-wardens.teaa
-%%DATADIR%%/game/engines/te4-1.1.5.teae
+%%DATADIR%%/game/engines/te4-1.2.2.teae
%%DATADIR%%/game/loader/init.lua
%%DATADIR%%/game/loader/pre-init.lua
-%%DATADIR%%/game/modules/boot-te4-1.1.5.team
+%%DATADIR%%/game/modules/boot-te4-1.2.2.team
%%DATADIR%%/game/modules/example/class/Actor.lua
%%DATADIR%%/game/modules/example/class/Game.lua
%%DATADIR%%/game/modules/example/class/Grid.lua
@@ -56,13 +56,67 @@ share/pixmaps/tome4.png
%%DATADIR%%/game/modules/example_realtime/dialogs/Quit.lua
%%DATADIR%%/game/modules/example_realtime/init.lua
%%DATADIR%%/game/modules/example_realtime/load.lua
-%%DATADIR%%/game/modules/tome-1.1.5-gfx.team
-%%DATADIR%%/game/modules/tome-1.1.5-music.team
-%%DATADIR%%/game/modules/tome-1.1.5.team
+%%DATADIR%%/game/modules/tome-1.2.2-gfx.team
+%%DATADIR%%/game/modules/tome-1.2.2-music.team
+%%DATADIR%%/game/modules/tome-1.2.2.team
%%DATADIR%%/game/profile-thread/Client.lua
%%DATADIR%%/game/profile-thread/UserChat.lua
%%DATADIR%%/game/profile-thread/init.lua
%%DATADIR%%/game/thirdparty/Json2.lua
+%%DATADIR%%/game/thirdparty/cef3/cef.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/am.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ar.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/bg.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/bn.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ca.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/cs.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/da.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/de.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/el.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/en-GB.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/en-US.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/es-419.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/es.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/et.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/fa.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/fi.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/fil.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/fr.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/gu.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/he.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/hi.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/hr.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/hu.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/id.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/it.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ja.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/kn.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ko.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/lt.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/lv.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ml.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/mr.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ms.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/nb.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/nl.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/pl.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/pt-BR.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/pt-PT.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ro.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ru.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/sk.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/sl.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/sr.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/sv.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/sw.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/ta.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/te.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/th.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/tr.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/uk.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/vi.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/zh-CN.pak
+%%DATADIR%%/game/thirdparty/cef3/locales/zh-TW.pak
%%DATADIR%%/game/thirdparty/config.lua
%%DATADIR%%/game/thirdparty/jit/bc.lua
%%DATADIR%%/game/thirdparty/jit/bcsave.lua
@@ -74,6 +128,27 @@ share/pixmaps/tome4.png
%%DATADIR%%/game/thirdparty/jit/dis_x86.lua
%%DATADIR%%/game/thirdparty/jit/dump.lua
%%DATADIR%%/game/thirdparty/jit/v.lua
+%%DATADIR%%/game/thirdparty/licenses/CEF3.txt
+%%DATADIR%%/game/thirdparty/licenses/LuaJIT.txt
+%%DATADIR%%/game/thirdparty/licenses/SDL.txt
+%%DATADIR%%/game/thirdparty/licenses/SDL_image.txt
+%%DATADIR%%/game/thirdparty/licenses/SDL_ttf.txt
+%%DATADIR%%/game/thirdparty/licenses/expat.txt
+%%DATADIR%%/game/thirdparty/licenses/freetype.txt
+%%DATADIR%%/game/thirdparty/licenses/libogg.txt
+%%DATADIR%%/game/thirdparty/licenses/libpng.txt
+%%DATADIR%%/game/thirdparty/licenses/libvorbis.txt
+%%DATADIR%%/game/thirdparty/licenses/lpeg.txt
+%%DATADIR%%/game/thirdparty/licenses/luabitop.txt
+%%DATADIR%%/game/thirdparty/licenses/luamd5.txt
+%%DATADIR%%/game/thirdparty/licenses/luaprofiler.txt
+%%DATADIR%%/game/thirdparty/licenses/luasocket.txt
+%%DATADIR%%/game/thirdparty/licenses/luazlib.txt
+%%DATADIR%%/game/thirdparty/licenses/lxp.txt
+%%DATADIR%%/game/thirdparty/licenses/physfs.txt
+%%DATADIR%%/game/thirdparty/licenses/tcod.txt
+%%DATADIR%%/game/thirdparty/licenses/tween.txt
+%%DATADIR%%/game/thirdparty/licenses/zlib.txt
%%DATADIR%%/game/thirdparty/lpeg/re.lua
%%DATADIR%%/game/thirdparty/ltn12.lua
%%DATADIR%%/game/thirdparty/lxp/lom.lua
@@ -93,55 +168,59 @@ share/pixmaps/tome4.png
%%DATADIR%%/game/thirdparty/moonscript/util.lua
%%DATADIR%%/game/thirdparty/moonscript/version.lua
%%DATADIR%%/game/thirdparty/remdebug/engine.lua
+%%DATADIR%%/game/thirdparty/slt2.lua
%%DATADIR%%/game/thirdparty/socket.lua
%%DATADIR%%/game/thirdparty/socket/ftp.lua
%%DATADIR%%/game/thirdparty/socket/http.lua
%%DATADIR%%/game/thirdparty/socket/smtp.lua
%%DATADIR%%/game/thirdparty/socket/tp.lua
%%DATADIR%%/game/thirdparty/socket/url.lua
+%%DATADIR%%/game/thirdparty/tween.lua
%%DATADIR%%/t-engine
-@dirrm %%DATADIR%%/game/thirdparty/socket
-@dirrm %%DATADIR%%/game/thirdparty/remdebug
-@dirrm %%DATADIR%%/game/thirdparty/moonscript/compile
-@dirrm %%DATADIR%%/game/thirdparty/moonscript
-@dirrm %%DATADIR%%/game/thirdparty/lxp
-@dirrm %%DATADIR%%/game/thirdparty/lpeg
-@dirrm %%DATADIR%%/game/thirdparty/jit
-@dirrm %%DATADIR%%/game/thirdparty
-@dirrm %%DATADIR%%/game/profile-thread
-@dirrm %%DATADIR%%/game/modules/example_realtime/dialogs
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones/dungeon
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/rooms
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx/particles
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/npcs
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/grids
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/general
-@dirrm %%DATADIR%%/game/modules/example_realtime/data/birth
-@dirrm %%DATADIR%%/game/modules/example_realtime/data
-@dirrm %%DATADIR%%/game/modules/example_realtime/class/interface
-@dirrm %%DATADIR%%/game/modules/example_realtime/class
-@dirrm %%DATADIR%%/game/modules/example_realtime
-@dirrm %%DATADIR%%/game/modules/example/dialogs
-@dirrm %%DATADIR%%/game/modules/example/data/zones/dungeon
-@dirrm %%DATADIR%%/game/modules/example/data/zones
-@dirrm %%DATADIR%%/game/modules/example/data/rooms
-@dirrm %%DATADIR%%/game/modules/example/data/gfx/particles
-@dirrm %%DATADIR%%/game/modules/example/data/gfx
-@dirrm %%DATADIR%%/game/modules/example/data/general/npcs
+@dirrm %%DATADIR%%/bootstrap
+@dirrm %%DATADIR%%/game/addons
+@dirrm %%DATADIR%%/game/engines
+@dirrm %%DATADIR%%/game/loader
+@dirrm %%DATADIR%%/game/modules/example/class/interface
+@dirrm %%DATADIR%%/game/modules/example/class
+@dirrm %%DATADIR%%/game/modules/example/data/birth
@dirrm %%DATADIR%%/game/modules/example/data/general/grids
+@dirrm %%DATADIR%%/game/modules/example/data/general/npcs
@dirrm %%DATADIR%%/game/modules/example/data/general
-@dirrm %%DATADIR%%/game/modules/example/data/birth
+@dirrm %%DATADIR%%/game/modules/example/data/gfx/particles
+@dirrm %%DATADIR%%/game/modules/example/data/gfx
+@dirrm %%DATADIR%%/game/modules/example/data/rooms
+@dirrm %%DATADIR%%/game/modules/example/data/zones/dungeon
+@dirrm %%DATADIR%%/game/modules/example/data/zones
@dirrm %%DATADIR%%/game/modules/example/data
-@dirrm %%DATADIR%%/game/modules/example/class/interface
-@dirrm %%DATADIR%%/game/modules/example/class
+@dirrm %%DATADIR%%/game/modules/example/dialogs
@dirrm %%DATADIR%%/game/modules/example
+@dirrm %%DATADIR%%/game/modules/example_realtime/class/interface
+@dirrm %%DATADIR%%/game/modules/example_realtime/class
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/birth
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/grids
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/general/npcs
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/general
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx/particles
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/gfx
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/rooms
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones/dungeon
+@dirrm %%DATADIR%%/game/modules/example_realtime/data/zones
+@dirrm %%DATADIR%%/game/modules/example_realtime/data
+@dirrm %%DATADIR%%/game/modules/example_realtime/dialogs
+@dirrm %%DATADIR%%/game/modules/example_realtime
@dirrm %%DATADIR%%/game/modules
-@dirrm %%DATADIR%%/game/loader
-@dirrm %%DATADIR%%/game/engines/cores
-@dirrm %%DATADIR%%/game/engines
-@dirrm %%DATADIR%%/game/addons
+@dirrm %%DATADIR%%/game/profile-thread
+@dirrm %%DATADIR%%/game/thirdparty/cef3/locales
+@dirrm %%DATADIR%%/game/thirdparty/cef3
+@dirrm %%DATADIR%%/game/thirdparty/jit
+@dirrm %%DATADIR%%/game/thirdparty/licenses
+@dirrm %%DATADIR%%/game/thirdparty/lpeg
+@dirrm %%DATADIR%%/game/thirdparty/lxp
+@dirrm %%DATADIR%%/game/thirdparty/moonscript/compile
+@dirrm %%DATADIR%%/game/thirdparty/moonscript
+@dirrm %%DATADIR%%/game/thirdparty/remdebug
+@dirrm %%DATADIR%%/game/thirdparty/socket
+@dirrm %%DATADIR%%/game/thirdparty
@dirrm %%DATADIR%%/game
-@dirrm %%DATADIR%%/bootstrap
@dirrm %%DATADIR%%