aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/slony1/Makefile2
-rw-r--r--databases/slony1/files/patch-cleanupthread17
-rw-r--r--databases/slony1v2/Makefile2
-rw-r--r--databases/slony1v2/files/patch-cleanupthread17
4 files changed, 36 insertions, 2 deletions
diff --git a/databases/slony1/Makefile b/databases/slony1/Makefile
index c5683f2896bd..85f210207892 100644
--- a/databases/slony1/Makefile
+++ b/databases/slony1/Makefile
@@ -7,7 +7,7 @@
PORTNAME= slony1
PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/
diff --git a/databases/slony1/files/patch-cleanupthread b/databases/slony1/files/patch-cleanupthread
new file mode 100644
index 000000000000..59569507efba
--- /dev/null
+++ b/databases/slony1/files/patch-cleanupthread
@@ -0,0 +1,17 @@
+Index: src/slon/cleanup_thread.c
+===================================================================
+RCS file: /usr/local/cvsroot/slony1/slony1-engine/src/slon/cleanup_thread.c,v
+retrieving revision 1.13.2.4
+retrieving revision 1.13.2.5
+diff -u -r1.13.2.4 -r1.13.2.5
+--- cleanup_thread.c 30 Sep 2004 17:45:06 -0000 1.13.2.4
++++ cleanup_thread.c 12 Jan 2005 03:15:36 -0000 1.13.2.5
+@@ -145,7 +145,7 @@
+ "delete from %s.sl_log_1 "
+ "where log_origin = '%s' "
+ "and log_xid < '%s'; "
+- "delete from %s.sl_log_1 "
++ "delete from %s.sl_log_2 "
+ "where log_origin = '%s' "
+ "and log_xid < '%s'; "
+ "delete from %s.sl_seqlog "
diff --git a/databases/slony1v2/Makefile b/databases/slony1v2/Makefile
index c5683f2896bd..85f210207892 100644
--- a/databases/slony1v2/Makefile
+++ b/databases/slony1v2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= slony1
PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://developer.postgresql.org/~wieck/slony1/download/
diff --git a/databases/slony1v2/files/patch-cleanupthread b/databases/slony1v2/files/patch-cleanupthread
new file mode 100644
index 000000000000..59569507efba
--- /dev/null
+++ b/databases/slony1v2/files/patch-cleanupthread
@@ -0,0 +1,17 @@
+Index: src/slon/cleanup_thread.c
+===================================================================
+RCS file: /usr/local/cvsroot/slony1/slony1-engine/src/slon/cleanup_thread.c,v
+retrieving revision 1.13.2.4
+retrieving revision 1.13.2.5
+diff -u -r1.13.2.4 -r1.13.2.5
+--- cleanup_thread.c 30 Sep 2004 17:45:06 -0000 1.13.2.4
++++ cleanup_thread.c 12 Jan 2005 03:15:36 -0000 1.13.2.5
+@@ -145,7 +145,7 @@
+ "delete from %s.sl_log_1 "
+ "where log_origin = '%s' "
+ "and log_xid < '%s'; "
+- "delete from %s.sl_log_1 "
++ "delete from %s.sl_log_2 "
+ "where log_origin = '%s' "
+ "and log_xid < '%s'; "
+ "delete from %s.sl_seqlog "