aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/conky-awesome/Makefile4
-rw-r--r--sysutils/conky/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/sysutils/conky-awesome/Makefile b/sysutils/conky-awesome/Makefile
index cb4519bdf22e..c23041544434 100644
--- a/sysutils/conky-awesome/Makefile
+++ b/sysutils/conky-awesome/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= novel@FreeBSD.org
COMMENT= An advanced, highly configurable system monitor for X
USE_BZIP2= yes
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
@@ -46,6 +47,9 @@ CONFIGURE_ARGS+= --disable-mpd
CONFIGURE_ARGS+= --disable-double-buffer
.endif
+post-extract:
+ ${REINPLACE_CMD} -e "s|== xyes|= xyes|g" ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/conky ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/conky.1 ${PREFIX}/man/man1
diff --git a/sysutils/conky/Makefile b/sysutils/conky/Makefile
index cb4519bdf22e..c23041544434 100644
--- a/sysutils/conky/Makefile
+++ b/sysutils/conky/Makefile
@@ -15,6 +15,7 @@ MAINTAINER= novel@FreeBSD.org
COMMENT= An advanced, highly configurable system monitor for X
USE_BZIP2= yes
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
USE_X_PREFIX= yes
@@ -46,6 +47,9 @@ CONFIGURE_ARGS+= --disable-mpd
CONFIGURE_ARGS+= --disable-double-buffer
.endif
+post-extract:
+ ${REINPLACE_CMD} -e "s|== xyes|= xyes|g" ${WRKSRC}/configure
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/conky ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/conky.1 ${PREFIX}/man/man1