aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/clutter-box2d/Makefile28
-rw-r--r--graphics/clutter-box2d/distinfo3
-rw-r--r--graphics/clutter-box2d/pkg-descr18
-rw-r--r--graphics/clutter-box2d/pkg-plist25
5 files changed, 75 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index bfbc11354350..4e96b05c6207 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -66,6 +66,7 @@
SUBDIR += cinepaint
SUBDIR += claraocr
SUBDIR += clutter
+ SUBDIR += clutter-box2d
SUBDIR += clutter-gtk
SUBDIR += comical
SUBDIR += comix
diff --git a/graphics/clutter-box2d/Makefile b/graphics/clutter-box2d/Makefile
new file mode 100644
index 000000000000..7332ed8cf291
--- /dev/null
+++ b/graphics/clutter-box2d/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: clutter-box2d
+# Date created: 2008-12-25
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clutter-box2d
+PORTVERSION= 0.8.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.clutter-project.org/sources/${PORTNAME}/0.8/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Clutter Box2D integration library
+
+LIB_DEPENDS= clutter-glx-0.8:${PORTSDIR}/graphics/clutter
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack ltverhack gnomeprefix
+USE_XORG= xp x11
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.mk>
diff --git a/graphics/clutter-box2d/distinfo b/graphics/clutter-box2d/distinfo
new file mode 100644
index 000000000000..ebb663d2902f
--- /dev/null
+++ b/graphics/clutter-box2d/distinfo
@@ -0,0 +1,3 @@
+MD5 (clutter-box2d-0.8.0.tar.gz) = 1d56bbea9e91e434037fecc3398c06eb
+SHA256 (clutter-box2d-0.8.0.tar.gz) = fd59f24468b89d829a5f13b40d8a95ef572df383bb558b4639bb1178d61fc8ee
+SIZE (clutter-box2d-0.8.0.tar.gz) = 479436
diff --git a/graphics/clutter-box2d/pkg-descr b/graphics/clutter-box2d/pkg-descr
new file mode 100644
index 000000000000..4d113c3a5b2b
--- /dev/null
+++ b/graphics/clutter-box2d/pkg-descr
@@ -0,0 +1,18 @@
+A glue layer between clutter and box2d that provides a special group where the
+actors can be set to be static or dynamic in regard to a physics simulation. The
+source tree currently contains an embedded version of box2d trunk.
+
+Features:
+- Children of the ClutterBox2d group can be simulated as static or dynamic
+ rigid bodies. Collision detection.
+- Specifying the gravity of the world.
+- play/pause control over the box2d physics engine
+- Setting linear and angular velocities of simulated children.
+- automatic position synchronization between clutter and box2d.
+- joints
+- prismatic.
+- revolute.
+- distance (spring)
+- mouse (for dragging objects around and manipulating them).
+
+WWW: http://clutter-project.org/
diff --git a/graphics/clutter-box2d/pkg-plist b/graphics/clutter-box2d/pkg-plist
new file mode 100644
index 000000000000..d0e51c5ef927
--- /dev/null
+++ b/graphics/clutter-box2d/pkg-plist
@@ -0,0 +1,25 @@
+include/clutter-0.8/clutter-box2d/clutter-box2d-joint.h
+include/clutter-0.8/clutter-box2d/clutter-box2d-util.h
+include/clutter-0.8/clutter-box2d/clutter-box2d.h
+lib/libclutter-box2d-0.8.a
+lib/libclutter-box2d-0.8.la
+lib/libclutter-box2d-0.8.so
+lib/libclutter-box2d-0.8.so.0
+libdata/pkgconfig/clutter-box2d-0.8.pc
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/clutter-box2d-ClutterBox2D-Actor.html
+%%DOCSDIR%%/clutter-box2d-ClutterBox2D-Joint.html
+%%DOCSDIR%%/clutter-box2d.devhelp
+%%DOCSDIR%%/clutter-box2d.devhelp2
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/license.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrmtry %%DOCSDIR%%
+@dirrm include/clutter-0.8/clutter-box2d
+@dirrmtry include/clutter-0.8