aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/asterisk10/Makefile18
-rw-r--r--net/asterisk10/distinfo4
-rw-r--r--net/asterisk10/files/patch-configure24
-rw-r--r--net/asterisk10/pkg-plist2
4 files changed, 29 insertions, 19 deletions
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index 409113329b86..1ae1c63faab4 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 10.2.1
+PORTVERSION= 10.3.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -59,9 +59,10 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
CURL "Enable CURL support" on \
SPANDSP "Enable Spandsp faxing support" off \
EXCHANGE "Enable Exchange calendar support" off \
- NEWG711 "Enable new G711 Codec" off \
- SRTP "Enable SecureRTP support" off \
- LUA "Enable LUA extensions support" off
+ NEWG711 "Enable new G711 Codec" off \
+ SRTP "Enable SecureRTP support" off \
+ LUA "Enable LUA extensions support" off \
+ LDAP "Enable Ldap support" off
ASTERISK_USER?= asterisk
ASTERISK_GROUP?= asterisk
@@ -265,6 +266,15 @@ CONFIGURE_ARGS+= --without-lua
PLIST_SUB+= WITH_LUA="@comment "
.endif
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-ldap
+USE_OPENLDAP= yes
+PLIST_SUB+= WITH_LDAP=""
+.else
+CONFIGURE_ARGS+= --without-ldap
+PLIST_SUB+= WITH_LDAP="@comment "
+.endif
+
post-extract:
${FIND} ${WRKSRC} -name '*.d' -delete
diff --git a/net/asterisk10/distinfo b/net/asterisk10/distinfo
index 2ce942b5dcc2..a8897440815b 100644
--- a/net/asterisk10/distinfo
+++ b/net/asterisk10/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-10.2.1.tar.gz) = e1511569e9db2d17eb60f5ebf65dfecf679acfb1463dbd2d7d4e9a8db0ed7c1f
-SIZE (asterisk-10.2.1.tar.gz) = 25121295
+SHA256 (asterisk-10.3.0.tar.gz) = f95227bdf845aada4640ccde1e226814653a5af61026179a68d6d9ca2cd3d4c0
+SIZE (asterisk-10.3.0.tar.gz) = 25168737
diff --git a/net/asterisk10/files/patch-configure b/net/asterisk10/files/patch-configure
index f85b00291d53..7307a93f216d 100644
--- a/net/asterisk10/files/patch-configure
+++ b/net/asterisk10/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-01-14 17:41:55.000000000 +0100
-+++ configure 2012-03-05 22:00:28.728486424 +0100
-@@ -4517,9 +4517,9 @@
+--- configure.orig 2012-02-16 20:44:44.000000000 +0100
++++ configure 2012-04-01 14:39:50.244001586 +0200
+@@ -4248,9 +4248,9 @@
astheaderdir='${includedir}/asterisk'
astlibdir='${libdir}/asterisk'
astmandir='${mandir}'
@@ -12,7 +12,7 @@
astkeydir='${astvarlibdir}'
astspooldir='${localstatedir}/spool/asterisk'
astlogdir='${localstatedir}/log/asterisk'
-@@ -4542,8 +4542,6 @@
+@@ -4273,8 +4273,6 @@
case "${host_os}" in
freebsd*)
ac_default_prefix=/usr/local
@@ -21,16 +21,16 @@
;;
openbsd*)
ac_default_prefix=/usr/local
-@@ -17486,6 +17484,8 @@
-
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+@@ -28831,6 +28829,8 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
-+ #include <sys/types.h>
-+ #include <sys/socket.h>
- #include <ifaddrs.h>
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <ifaddrs.h>
int
main ()
-@@ -25476,7 +25476,7 @@
+@@ -47742,7 +47742,7 @@
fi
@@ -38,4 +38,4 @@
+ PLATFORM_OPENH323="h323_${OPENH323_SUFFIX}"
if test "${HAS_OPENH323:-unset}" != "unset"; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking OpenH323 installation validity" >&5
+ { $as_echo "$as_me:$LINENO: checking OpenH323 installation validity" >&5
diff --git a/net/asterisk10/pkg-plist b/net/asterisk10/pkg-plist
index c1df5ecaee5e..71308c0e52d7 100644
--- a/net/asterisk10/pkg-plist
+++ b/net/asterisk10/pkg-plist
@@ -473,7 +473,7 @@ lib/asterisk/modules/res_ael_share.so
lib/asterisk/modules/res_clialiases.so
%%WITH_CURL%%lib/asterisk/modules/res_curl.so
%%WITH_CURL%%lib/asterisk/modules/res_config_curl.so
-%%WITH_H323%%lib/asterisk/modules/res_config_ldap.so
+%%WITH_LDAP%%lib/asterisk/modules/res_config_ldap.so
%%WITH_SQLITE%%lib/asterisk/modules/res_config_sqlite.so
lib/asterisk/modules/res_format_attr_celt.so
lib/asterisk/modules/res_format_attr_silk.so