aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-Descriptive/Makefile23
-rw-r--r--math/p5-Statistics-Descriptive/distinfo1
-rw-r--r--math/p5-Statistics-Descriptive/pkg-comment1
-rw-r--r--math/p5-Statistics-Descriptive/pkg-descr9
-rw-r--r--math/p5-Statistics-Descriptive/pkg-plist5
6 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8b0cf70d5547..f97b292ab202 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -59,6 +59,7 @@
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
SUBDIR += p5-Statistics-ChiSquare
+ SUBDIR += p5-Statistics-Descriptive
SUBDIR += pari
SUBDIR += parmetis
SUBDIR += physcalc
diff --git a/math/p5-Statistics-Descriptive/Makefile b/math/p5-Statistics-Descriptive/Makefile
new file mode 100644
index 000000000000..05a09d43eb82
--- /dev/null
+++ b/math/p5-Statistics-Descriptive/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: math/p5- Statistics-Descriptive
+# Date created: 01 January 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Descriptive
+PORTVERSION= 2.4
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::Descriptive.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Descriptive/distinfo b/math/p5-Statistics-Descriptive/distinfo
new file mode 100644
index 000000000000..17665c993781
--- /dev/null
+++ b/math/p5-Statistics-Descriptive/distinfo
@@ -0,0 +1 @@
+MD5 (Statistics-Descriptive-2.4.tar.gz) = fe6a7d4e1aefdc7bb544db301de357de
diff --git a/math/p5-Statistics-Descriptive/pkg-comment b/math/p5-Statistics-Descriptive/pkg-comment
new file mode 100644
index 000000000000..9f52aa316a18
--- /dev/null
+++ b/math/p5-Statistics-Descriptive/pkg-comment
@@ -0,0 +1 @@
+Perl module that supplies statistical methods for perl5
diff --git a/math/p5-Statistics-Descriptive/pkg-descr b/math/p5-Statistics-Descriptive/pkg-descr
new file mode 100644
index 000000000000..71f40d3961a6
--- /dev/null
+++ b/math/p5-Statistics-Descriptive/pkg-descr
@@ -0,0 +1,9 @@
+This module provides basic functions used in descriptive statistics. It
+has an object oriented design and supports two different types of data
+storage and calculation objects: sparse and full. With the sparse
+method, none of the data is stored and only a few statistical measures
+are available. Using the full method, the entire data set is retained
+and additional functions are available.
+
+-Anton
+<tobez@tobez.org>
diff --git a/math/p5-Statistics-Descriptive/pkg-plist b/math/p5-Statistics-Descriptive/pkg-plist
new file mode 100644
index 000000000000..c3d59c30a674
--- /dev/null
+++ b/math/p5-Statistics-Descriptive/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics/Descriptive/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Statistics/Descriptive.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics/Descriptive
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Statistics 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Statistics 2>/dev/null || true