aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/p5-Bio-Das-Lite/Makefile1
-rw-r--r--databases/p5-Data-Pageset/Makefile1
-rw-r--r--devel/p5-Class-C3-Componentised/Makefile6
-rw-r--r--devel/p5-Log-Dispatch-Perl/Makefile1
-rw-r--r--devel/p5-POE-Session-MultiDispatch/Makefile1
-rw-r--r--devel/p5-Time-Duration-Parse/Makefile3
-rw-r--r--security/p5-POE-Filter-SSL/Makefile1
-rw-r--r--textproc/p5-Text-Trim/Makefile2
-rw-r--r--textproc/p5-XML-DoubleEncodedEntities/Makefile2
-rw-r--r--www/p5-HTTP-Response-Encoding/Makefile1
-rw-r--r--www/p5-WWW-Dilbert/Makefile1
11 files changed, 3 insertions, 17 deletions
diff --git a/biology/p5-Bio-Das-Lite/Makefile b/biology/p5-Bio-Das-Lite/Makefile
index 73b80589b8f6..445e15b6a66d 100644
--- a/biology/p5-Bio-Das-Lite/Makefile
+++ b/biology/p5-Bio-Das-Lite/Makefile
@@ -18,7 +18,6 @@ BUILD_DEPENDS= p5-Readonly>=1.03:${PORTSDIR}/devel/p5-Readonly \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-WWW-Curl>=4.07:${PORTSDIR}/www/p5-WWW-Curl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>0.8:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= modbuild
diff --git a/databases/p5-Data-Pageset/Makefile b/databases/p5-Data-Pageset/Makefile
index c5f9c6115584..481ae4830941 100644
--- a/databases/p5-Data-Pageset/Makefile
+++ b/databases/p5-Data-Pageset/Makefile
@@ -13,7 +13,6 @@ COMMENT= Page numbering and page sets
BUILD_DEPENDS= p5-Data-Page>=2:${PORTSDIR}/databases/p5-Data-Page
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0.1:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Class-C3-Componentised/Makefile b/devel/p5-Class-C3-Componentised/Makefile
index 0b70dc0164da..74b64eb71f39 100644
--- a/devel/p5-Class-C3-Componentised/Makefile
+++ b/devel/p5-Class-C3-Componentised/Makefile
@@ -17,11 +17,9 @@ RUN_DEPENDS= p5-Class-C3>=0.20:${PORTSDIR}/devel/p5-Class-C3 \
p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
BUILD_DEPENDS:= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
- p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
- p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
+ p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Log-Dispatch-Perl/Makefile b/devel/p5-Log-Dispatch-Perl/Makefile
index 639387419e06..b8174da0a1cf 100644
--- a/devel/p5-Log-Dispatch-Perl/Makefile
+++ b/devel/p5-Log-Dispatch-Perl/Makefile
@@ -13,7 +13,6 @@ COMMENT= Log::Dispatch plug-in using core Perl functions for logging
BUILD_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-POE-Session-MultiDispatch/Makefile b/devel/p5-POE-Session-MultiDispatch/Makefile
index 78cf229a13a0..4855749a1cc4 100644
--- a/devel/p5-POE-Session-MultiDispatch/Makefile
+++ b/devel/p5-POE-Session-MultiDispatch/Makefile
@@ -13,7 +13,6 @@ COMMENT= Callback dispatch for session events
RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS:= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Time-Duration-Parse/Makefile b/devel/p5-Time-Duration-Parse/Makefile
index c6588919d48f..45d9808fa235 100644
--- a/devel/p5-Time-Duration-Parse/Makefile
+++ b/devel/p5-Time-Duration-Parse/Makefile
@@ -16,8 +16,7 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Exporter-Lite>=0.02:${PORTSDIR}/devel/p5-Exporter-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0.99:${PORTSDIR}/devel/p5-Test-Simple \
- p5-Time-Duration>=1.0.6:${PORTSDIR}/devel/p5-Time-Duration
+TEST_DEPENDS= p5-Time-Duration>=1.0.6:${PORTSDIR}/devel/p5-Time-Duration
USES= perl5
USE_PERL5= configure
diff --git a/security/p5-POE-Filter-SSL/Makefile b/security/p5-POE-Filter-SSL/Makefile
index b6e915928018..584beabfdabc 100644
--- a/security/p5-POE-Filter-SSL/Makefile
+++ b/security/p5-POE-Filter-SSL/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-POE>=0:${PORTSDIR}/devel/p5-POE
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= configure
diff --git a/textproc/p5-Text-Trim/Makefile b/textproc/p5-Text-Trim/Makefile
index 9459afb182ea..9e319613bdc2 100644
--- a/textproc/p5-Text-Trim/Makefile
+++ b/textproc/p5-Text-Trim/Makefile
@@ -15,8 +15,6 @@ COMMENT= Extract the structure of a quoted mail message
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
-
USES= perl5
USE_PERL5= modbuild
diff --git a/textproc/p5-XML-DoubleEncodedEntities/Makefile b/textproc/p5-XML-DoubleEncodedEntities/Makefile
index c51f9b498465..b4685981e606 100644
--- a/textproc/p5-XML-DoubleEncodedEntities/Makefile
+++ b/textproc/p5-XML-DoubleEncodedEntities/Makefile
@@ -11,8 +11,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Unbreak XML with Doubly-Encoded Entities
-TEST_DEPENDS= p5-Test-Simple>=0.64:${PORTSDIR}/devel/p5-Test-Simple
-
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-HTTP-Response-Encoding/Makefile b/www/p5-HTTP-Response-Encoding/Makefile
index 575ef9494e0f..7cc67eb2b493 100644
--- a/www/p5-HTTP-Response-Encoding/Makefile
+++ b/www/p5-HTTP-Response-Encoding/Makefile
@@ -16,7 +16,6 @@ BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
p5-Encode>=2.0:${PORTSDIR}/converters/p5-Encode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= configure
diff --git a/www/p5-WWW-Dilbert/Makefile b/www/p5-WWW-Dilbert/Makefile
index 3b761545916f..460ed84f1956 100644
--- a/www/p5-WWW-Dilbert/Makefile
+++ b/www/p5-WWW-Dilbert/Makefile
@@ -14,7 +14,6 @@ COMMENT= Dilbert of the day comic strip archive and retrieval module
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
USES= perl5
USE_PERL5= modbuild