aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/stepcode/Makefile8
-rw-r--r--cad/stepcode/files/patch-doc_CMakeLists.txt11
-rw-r--r--cad/stepcode/pkg-plist4
3 files changed, 17 insertions, 6 deletions
diff --git a/cad/stepcode/Makefile b/cad/stepcode/Makefile
index ee9d3d37369e..5f3da757719b 100644
--- a/cad/stepcode/Makefile
+++ b/cad/stepcode/Makefile
@@ -3,8 +3,8 @@
PORTNAME= stepcode
PORTVERSION= 0.8
-PORTREVISION= 1
DISTVERSIONPREFIX= v
+PORTREVISION= 2
CATEGORIES= cad
MAINTAINER= fernando.apesteguia@gmail.com
@@ -15,14 +15,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= fails to configure: Schema scan for 15926-0002-lifecycle_integration.exp exited with error code 1
+USES= cmake:outsource compiler:c++11-lang
USE_GITHUB= yes
-
USE_LDCONFIG= yes
-
-USES= cmake:outsource compiler:c++11-lang
CMAKE_ARGS+= -DSC_INSTALL_PREFIX=${PREFIX} \
-DSC_BUILD_TYPE=Release
+MANDIRS= ${PREFIX}/man
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/schema_scanner
@(cd ${STAGEDIR}${PREFIX} ; \
diff --git a/cad/stepcode/files/patch-doc_CMakeLists.txt b/cad/stepcode/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..41ad8ef5bbbb
--- /dev/null
+++ b/cad/stepcode/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- doc/CMakeLists.txt.orig 2017-08-29 15:56:46 UTC
++++ doc/CMakeLists.txt
+@@ -4,7 +4,7 @@ set(sc_MANS
+ )
+
+ if(NOT DEFINED MAN_DIR)
+- set(MAN_DIR share/man)
++ set(MAN_DIR man)
+ endif(NOT DEFINED MAN_DIR)
+
+ if(NOT WIN32)
diff --git a/cad/stepcode/pkg-plist b/cad/stepcode/pkg-plist
index 7f955f6852af..78e722bc3905 100644
--- a/cad/stepcode/pkg-plist
+++ b/cad/stepcode/pkg-plist
@@ -114,5 +114,5 @@ lib/libsteplazyfile.so.2.0.0
lib/libsteputils.so
lib/libsteputils.so.2
lib/libsteputils.so.2.0.0
-share/man/man1/exp2cxx.1
-share/man/man1/fedex.1
+man/man1/exp2cxx.1.gz
+man/man1/fedex.1.gz