aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/libzip/Makefile3
-rw-r--r--archivers/libzip/distinfo6
-rw-r--r--archivers/libzip/files/patch-CVE-2017-1410727
-rw-r--r--archivers/libzip/files/patch-lib__Makefile.in14
-rw-r--r--archivers/libzip/pkg-plist8
5 files changed, 17 insertions, 41 deletions
diff --git a/archivers/libzip/Makefile b/archivers/libzip/Makefile
index 1f5868efee57..7785f4ee75d0 100644
--- a/archivers/libzip/Makefile
+++ b/archivers/libzip/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libzip
-PORTVERSION= 1.1.3
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= archivers devel
MASTER_SITES= https://www.nih.at/libzip/
diff --git a/archivers/libzip/distinfo b/archivers/libzip/distinfo
index 160115489692..61493d3b4dca 100644
--- a/archivers/libzip/distinfo
+++ b/archivers/libzip/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477213191
-SHA256 (libzip-1.1.3.tar.xz) = 729a295a59a9fd6e5b9fe9fd291d36ae391a9d2be0b0824510a214cfaa05ceee
-SIZE (libzip-1.1.3.tar.xz) = 460128
+TIMESTAMP = 1506503583
+SHA256 (libzip-1.3.0.tar.xz) = aa936efe34911be7acac2ab07fb5c8efa53ed9bb4d44ad1fe8bff19630e0d373
+SIZE (libzip-1.3.0.tar.xz) = 955876
diff --git a/archivers/libzip/files/patch-CVE-2017-14107 b/archivers/libzip/files/patch-CVE-2017-14107
deleted file mode 100644
index 510d5ff444e8..000000000000
--- a/archivers/libzip/files/patch-CVE-2017-14107
+++ /dev/null
@@ -1,27 +0,0 @@
-From 9b46957ec98d85a572e9ef98301247f39338a3b5 Mon Sep 17 00:00:00 2001
-From: Thomas Klausner <tk@giga.or.at>
-Date: Tue, 29 Aug 2017 10:25:03 +0200
-Subject: [PATCH] Make eocd checks more consistent between zip and zip64 cases.
-
----
- lib/zip_open.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/lib/zip_open.c b/lib/zip_open.c
-index 3bd593b..9d3a4cb 100644
---- lib/zip_open.c
-+++ lib/zip_open.c
-@@ -847,7 +847,12 @@ _zip_read_eocd64(zip_source_t *src, zip_buffer_t *buffer, zip_uint64_t buf_offse
- zip_error_set(error, ZIP_ER_SEEK, EFBIG);
- return NULL;
- }
-- if ((flags & ZIP_CHECKCONS) && offset+size != eocd_offset) {
-+ if (offset+size > buf_offset + eocd_offset) {
-+ /* cdir spans past EOCD record */
-+ zip_error_set(error, ZIP_ER_INCONS, 0);
-+ return NULL;
-+ }
-+ if ((flags & ZIP_CHECKCONS) && offset+size != buf_offset + eocd_offset) {
- zip_error_set(error, ZIP_ER_INCONS, 0);
- return NULL;
- }
diff --git a/archivers/libzip/files/patch-lib__Makefile.in b/archivers/libzip/files/patch-lib__Makefile.in
index eaebfcc94cc3..b8da36054025 100644
--- a/archivers/libzip/files/patch-lib__Makefile.in
+++ b/archivers/libzip/files/patch-lib__Makefile.in
@@ -1,17 +1,17 @@
---- lib/Makefile.in.orig 2016-02-19 14:21:44 UTC
-+++ lib/Makefile.in
-@@ -367,8 +367,8 @@ AM_CFLAGS = @CFLAG_VISIBILITY@
+--- lib/Makefile.in.orig 2017-09-02 18:10:43.000000000 +0200
++++ lib/Makefile.in 2017-09-27 11:19:40.288590998 +0200
+@@ -496,8 +496,8 @@ AM_CFLAGS = @CFLAG_VISIBILITY@
libincludedir = ${libdir}/@PACKAGE@/include
lib_LTLIBRARIES = libzip.la
- noinst_HEADERS = zipint.h
+ noinst_HEADERS = zipint.h gladman-fcrypt.h
-include_HEADERS = zip.h
-nodist_libinclude_HEADERS = zipconf.h
+include_HEADERS = zip.h zipconf.h
+nodist_libinclude_HEADERS =
# also update CMakeLists.txt when changing version
- libzip_la_LDFLAGS = -no-undefined -version-info 4:0:0
-@@ -882,8 +882,7 @@ info: info-am
+ libzip_la_LDFLAGS = -no-undefined -version-info 5:0:0
+@@ -1926,8 +1926,7 @@ info: info-recursive
info-am:
@@ -19,5 +19,5 @@
- install-nodist_libincludeHEADERS
+install-data-am: install-includeHEADERS
- install-dvi: install-dvi-am
+ install-dvi: install-dvi-recursive
diff --git a/archivers/libzip/pkg-plist b/archivers/libzip/pkg-plist
index c0ed30029f55..ad4eb7819529 100644
--- a/archivers/libzip/pkg-plist
+++ b/archivers/libzip/pkg-plist
@@ -5,8 +5,8 @@ include/zip.h
include/zipconf.h
lib/libzip.a
lib/libzip.so
-lib/libzip.so.4
-lib/libzip.so.4.0.0
+lib/libzip.so.5
+lib/libzip.so.5.0.0
libdata/pkgconfig/libzip.pc
man/man1/zipcmp.1.gz
man/man1/zipmerge.1.gz
@@ -51,6 +51,7 @@ man/man3/zip_file_get_external_attributes.3.gz
man/man3/zip_file_rename.3.gz
man/man3/zip_file_replace.3.gz
man/man3/zip_file_set_comment.3.gz
+man/man3/zip_file_set_encryption.3.gz
man/man3/zip_file_set_external_attributes.3.gz
man/man3/zip_file_set_mtime.3.gz
man/man3/zip_file_strerror.3.gz
@@ -59,6 +60,8 @@ man/man3/zip_fopen_encrypted.3.gz
man/man3/zip_fopen_index.3.gz
man/man3/zip_fopen_index_encrypted.3.gz
man/man3/zip_fread.3.gz
+man/man3/zip_fseek.3.gz
+man/man3/zip_ftell.3.gz
man/man3/zip_get_archive_comment.3.gz
man/man3/zip_get_archive_flag.3.gz
man/man3/zip_get_error.3.gz
@@ -69,6 +72,7 @@ man/man3/zip_get_num_files.3.gz
man/man3/zip_name_locate.3.gz
man/man3/zip_open.3.gz
man/man3/zip_open_from_source.3.gz
+man/man3/zip_register_progress_callback.3.gz
man/man3/zip_rename.3.gz
man/man3/zip_replace.3.gz
man/man3/zip_set_archive_comment.3.gz