aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnomevfs2/Makefile6
-rw-r--r--devel/nspr/Makefile6
-rw-r--r--mail/thunderbird-devel/Makefile6
-rw-r--r--mail/thunderbird-esr/Makefile6
-rw-r--r--mail/thunderbird/Makefile6
-rw-r--r--mail/thunderbird3/Makefile6
-rw-r--r--www/firefox-devel/Makefile6
-rw-r--r--www/firefox-esr/Makefile6
-rw-r--r--www/firefox/Makefile6
-rw-r--r--www/firefox10/Makefile6
-rw-r--r--www/firefox15/Makefile6
-rw-r--r--www/firefox3-devel/Makefile6
-rw-r--r--www/firefox35/Makefile6
-rw-r--r--www/firefox36/Makefile6
-rw-r--r--www/flock/Makefile6
-rw-r--r--www/mozilla-devel/Makefile6
-rw-r--r--www/mozilla/Makefile6
-rw-r--r--www/seamonkey/Makefile6
-rw-r--r--www/seamonkey2/Makefile6
20 files changed, 120 insertions, 0 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index cab5c551175a..8d0347ede42d 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -59,4 +59,10 @@ post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" \
${WRKSRC}/Makefile.in
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index cab5c551175a..8d0347ede42d 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -59,4 +59,10 @@ post-patch:
@${REINPLACE_CMD} -e "/^SUBDIRS =/s/test//" \
${WRKSRC}/Makefile.in
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
.include <bsd.port.post.mk>
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index 55ef1ef864c2..76e9ea7ffbe4 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -28,6 +28,12 @@ MAKE_ENV= DIST=${WRKSRC}/dist
LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
do-install:
${MKDIR} ${PREFIX}/include/nspr
${TAR} -C ${WRKSRC}/dist/include --dereference -cf - . | \
diff --git a/mail/thunderbird-devel/Makefile b/mail/thunderbird-devel/Makefile
index cc2d2894d185..206662c14313 100644
--- a/mail/thunderbird-devel/Makefile
+++ b/mail/thunderbird-devel/Makefile
@@ -115,6 +115,12 @@ post-patch:
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
${RM} -fr ${LOCAL_PREFIX}
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index cc2d2894d185..206662c14313 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -115,6 +115,12 @@ post-patch:
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
${RM} -fr ${LOCAL_PREFIX}
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index cc2d2894d185..206662c14313 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -115,6 +115,12 @@ post-patch:
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
${RM} -fr ${LOCAL_PREFIX}
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index cc2d2894d185..206662c14313 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -115,6 +115,12 @@ post-patch:
${WRKSRC}/intl/uconv/native/nsNativeUConvService.cpp \
${WRKSRC}/xpcom/io/nsNativeCharsetUtils.cpp
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
${RM} -fr ${LOCAL_PREFIX}
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/flock/Makefile b/www/flock/Makefile
index db5580874bf2..d78db4f2adf0 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -126,6 +126,12 @@ post-patch:
< ${WRKSRC}/${ii}/all.js.bak > ${WRKSRC}/${ii}/all.js
.endfor
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
pre-install:
# Overview: the program installs itself in FAKEDIR, then a list is made of the
# files and directories in there. This is the PLIST (packing list) for the
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index 703e78463c4e..0a330a0387b3 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -229,6 +229,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}