aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/php4/Makefile3
-rw-r--r--lang/php4/files/patch-ext_standard_basic_functions.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 1f887a5f015c..a32ca430af68 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -7,7 +7,7 @@
PORTNAME= php4
PORTVERSION= 4.4.2
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP:S,$,:release,} \
http://downloads.php.net/ilia/:rc \
@@ -25,6 +25,7 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX) || ${PKGNAMESUFFIX} == "-cgi" || ${PKGNAMESUFFIX} == "-cli"
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+USE_GETOPT_LONG=yes
CONFIGURE_ARGS= --enable-versioning \
--enable-memory-limit \
diff --git a/lang/php4/files/patch-ext_standard_basic_functions.c b/lang/php4/files/patch-ext_standard_basic_functions.c
new file mode 100644
index 000000000000..b44a87f1ec9e
--- /dev/null
+++ b/lang/php4/files/patch-ext_standard_basic_functions.c
@@ -0,0 +1,10 @@
+--- ext/standard/basic_functions.c.orig Mon Jan 30 15:58:01 2006
++++ ext/standard/basic_functions.c Mon Jan 30 15:58:36 2006
+@@ -66,6 +66,7 @@
+ # include <sys/mman.h>
+ #endif
+
++#define HARTMUT_0
+ #ifdef HARTMUT_0
+ #include <getopt.h>
+ #endif