aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/spice/Makefile13
-rw-r--r--cad/spice/files/FreeBSD.without_x1111
-rw-r--r--cad/spice/files/Makefile11
-rw-r--r--cad/spice/scripts/configure1
4 files changed, 31 insertions, 5 deletions
diff --git a/cad/spice/Makefile b/cad/spice/Makefile
index c6057b007321..9fe2f13ee6e1 100644
--- a/cad/spice/Makefile
+++ b/cad/spice/Makefile
@@ -19,7 +19,6 @@ EXTRACT_ONLY= sp3f4.kit${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= A general-purpose circuit simulation program
-USE_XLIB= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
MAN1= sconvert.1 nutmeg.1 spice.1
@@ -28,6 +27,14 @@ MAN5= mfbcap.5
MLINKS= spice.1 spice3.1
MAKE_ENV+= STRIP_CMD=${STRIP_CMD}
+.ifdef WITHOUT_X11
+COMMENT= A general-purpose circuit simulation program (non-X11 version)
+PKGNAMESUFFIX= -without-x11
+MAKE_ARGS+= -DWITHOUT_X11
+.else
+USE_XLIB= yes
+.endif
+
.include <bsd.port.pre.mk>
post-patch:
@@ -35,8 +42,8 @@ post-patch:
post-configure:
@${REINPLACE_CMD} -e 's+@CC@+${CC}+ ; s+@CFLAGS@+${CFLAGS}+ ; \
- s+@X11BASE@+${X11BASE}+;' \
- ${WRKSRC}/conf/FreeBSD
+ s+@X11BASE@+${X11BASE}+;' \
+ ${WRKSRC}/conf/FreeBSD ${WRKSRC}/conf/FreeBSD.without_x11
post-install:
.if !defined(NOPORTDOCS)
diff --git a/cad/spice/files/FreeBSD.without_x11 b/cad/spice/files/FreeBSD.without_x11
new file mode 100644
index 000000000000..86d5651c97d8
--- /dev/null
+++ b/cad/spice/files/FreeBSD.without_x11
@@ -0,0 +1,11 @@
+# FreeBSD config exception file (non-x11 version)
+
+MAKE = /usr/bin/make
+INTERFACE_OPTS = -DWANT_MFB
+CC = @CC@
+CC_OPT += @CFLAGS@
+LDFLAGS += -lm -ltermcap
+SYS_CFLAGS = -Dbsd
+X_DIR =
+INCX =
+LIBX =
diff --git a/cad/spice/files/Makefile b/cad/spice/files/Makefile
index 1e1f6d0f0e3c..a93fdab4e7ad 100644
--- a/cad/spice/files/Makefile
+++ b/cad/spice/files/Makefile
@@ -1,11 +1,18 @@
#
# $FreeBSD$
#
+
+.ifdef WITHOUT_X11
+CONFIG= FreeBSD.without_x11
+.else
+CONFIG= FreeBSD
+.endif
+
all:
- util/build FreeBSD default
+ util/build ${CONFIG} default
install:
- util/build FreeBSD install
+ util/build ${CONFIG} install
chmod a+rx ${PREFIX}/bin/spice3 ${PREFIX}/bin/nutmeg \
${PREFIX}/bin/sconvert ${PREFIX}/bin/help \
${PREFIX}/bin/proc2mod ${PREFIX}/bin/multidec
diff --git a/cad/spice/scripts/configure b/cad/spice/scripts/configure
index 5ded3cb6e041..38b148fb916f 100644
--- a/cad/spice/scripts/configure
+++ b/cad/spice/scripts/configure
@@ -3,3 +3,4 @@
rm -f ${WRKSRC}/makefile
cp ${FILESDIR}/Makefile ${WRKSRC}/Makefile
cp ${FILESDIR}/FreeBSD ${WRKSRC}/conf/FreeBSD
+cp ${FILESDIR}/FreeBSD.without_x11 ${WRKSRC}/conf/FreeBSD.without_x11