aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/doom-data/Makefile.include13
-rw-r--r--games/duke3d-data/Makefile.include12
-rw-r--r--games/openarena/Makefile.include2
-rw-r--r--games/quake-data/Makefile.include8
-rw-r--r--games/quake2-data/Makefile.include49
-rw-r--r--games/quake3-data/Makefile.include14
6 files changed, 32 insertions, 66 deletions
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
index 7f794ede029e..6c262202ab38 100644
--- a/games/doom-data/Makefile.include
+++ b/games/doom-data/Makefile.include
@@ -1,25 +1,16 @@
-# Makefile for defining variables used by other Doom related ports
-# $FreeBSD$
+# Makefile for defining variables used by other Doom related ports.
-# Set variables
-
-DMPKGNAMEPREFIX?=doom-
+DMPKGNAMEPREFIX?= doom-
DMDIR?= ${LOCALBASE}/share/doom
-# Add them to the environment
-
MAKE_ENV+= DMDIR="${DMDIR}"
PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
SUB_LIST+= DMDIR="${DMDIR}"
-# Add the dependency
-
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${DMDIR}:${PORTSDIR}/games/doom-data
.endif
-# DOS to Unix text conversion
-
.if defined(USE_CRLF)
. if defined(USE_ZIP)
EXTRACT_BEFORE_ARGS= -aqo
diff --git a/games/duke3d-data/Makefile.include b/games/duke3d-data/Makefile.include
index 6dec3b5c608f..ec9f21e91030 100644
--- a/games/duke3d-data/Makefile.include
+++ b/games/duke3d-data/Makefile.include
@@ -5,27 +5,21 @@
# is installed (i.e. no need for pkg-message asking to copy duke3d.grp).
#
# The following variables are defined, and can be used in the port.
-# DN3DPKGNAMEPREFIX - The package name prefix for Duke Nukem 3D additions.
+# DN3DPKGNAMEPREFIX - The package name prefix for Duke Nukem 3D additions
# DN3DDIR - The Duke Nukem 3D data directory (also added to
-# MAKE_ENV, PLIST_SUB and SUB_LIST).
+# MAKE_ENV, PLIST_SUB, and SUB_LIST)
#
# For notes about this kind of ports see /usr/ports/games/quake2-data (some
# rules apply to this ports, like search paths).
#
-# Set variables.
-
-DN3DPKGNAMEPREFIX?=duke3d-
+DN3DPKGNAMEPREFIX?= duke3d-
DN3DDIR?= ${LOCALBASE}/share/duke3d
-# Add them to the ports system.
-
MAKE_ENV+= DN3DDIR="${DN3DDIR}"
PLIST_SUB+= DN3DDIR="${DN3DDIR:S/${LOCALBASE}\///}"
SUB_LIST+= DN3DDIR="${DN3DDIR}"
-# Add the dependency.
-
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${DN3DDIR}:${PORTSDIR}/games/duke3d-data
.endif
diff --git a/games/openarena/Makefile.include b/games/openarena/Makefile.include
index 46855f21953b..bfdc79f28e06 100644
--- a/games/openarena/Makefile.include
+++ b/games/openarena/Makefile.include
@@ -11,7 +11,7 @@ RUN_DEPENDS+= ${OABIN}:${PORTSDIR}/games/openarena
.include <bsd.port.pre.mk>
-# You only need server or client.
+# You only need server or client
.if exists(${LOCALBASE}/bin/oa_ded)
OABIN= oa_ded
.elif exists(${LOCALBASE}/bin/openarena)
diff --git a/games/quake-data/Makefile.include b/games/quake-data/Makefile.include
index 93cc12214fa2..ee576884bd34 100644
--- a/games/quake-data/Makefile.include
+++ b/games/quake-data/Makefile.include
@@ -1,19 +1,13 @@
# Makefile for defining variables used by other Quake related ports. See
-# `games/quake2-data/Makefile.include' for extensive description.
-
-# Set variables
+# `games/quake2-data/Makefile.include' for extensive description and usage.
Q1PKGNAMEPREFIX?= quake-
Q1DIR?= ${LOCALBASE}/share/quake
-# Add them to the environment
-
MAKE_ENV+= Q1DIR="${Q1DIR}"
PLIST_SUB+= Q1DIR="${Q1DIR:S/${LOCALBASE}\///}"
SUB_LIST+= Q1DIR="${Q1DIR}"
-# Add the dependency
-
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q1DIR}/id1/pak0.pak:${PORTSDIR}/games/quake-data
.endif
diff --git a/games/quake2-data/Makefile.include b/games/quake2-data/Makefile.include
index 8d26f7957c94..4bff0cd4075c 100644
--- a/games/quake2-data/Makefile.include
+++ b/games/quake2-data/Makefile.include
@@ -5,58 +5,53 @@
# is installed (i.e. no need for pkg-message asking to copy the .pak files),
# and the main game.so (except the engine incompatible with the original one).
#
-# The following variables are defined, and can be used in the port.
-# Q2PKGNAMEPREFIX - The package name prefix for Quake II additions.
-# Q2DIR - The Quake II data directory (also added to MAKE_ENV,
-# PLIST_SUB and SUB_LIST).
+# The following variables are defined, and can be used in the port:
+#
+# Q2PKGNAMEPREFIX - The package name prefix for Quake II additions
+# Q2DIR - The Quake II data directory (also added to
+# MAKE_ENV, PLIST_SUB, and SUB_LIST)
+#
+# Some notes for making such kind of ports:
#
-# The following are some notes for making this kind of ports.
# - The game engines should be modified to add ${Q2DIR} as the first search
# path (it's a stack so new paths override previous ones), and add
-# "~/.${PORTNAME}" as the last one (this is where it writes the
-# configuration, saved games, etc.), which may need to be created if doesn't
-# exist.
+# "~/.${PORTNAME}" as the last one (this is where it writes configuration,
+# saved games, etc.), which may need to be created if doesn't exist;
# - If the engine needs to load additional data (renderers, pak files, etc.)
# don't install it in ${Q2DIR}, use ${PREFIX}/lib/${PORTNAME} instead and
-# add that directory to the search paths immediately after ${Q2DIR}.
+# add that directory to the search paths immediately after ${Q2DIR};
# - The reason to use "~/.${PORTNAME}" for writing is in the case the program
# isn't compatible with the original engine (e.g. new console variables,
# different saved game format, etc.). If just the configuration is
# different it can write in "~/.quake2" but use a different configuration
-# file name (not config.cfg).
+# file name (not config.cfg);
# - Search path summary (ordered):
-# - cddir - Directory to be prepended (optional, configurable).
-# - ${Q2DIR} - Base shared data directory.
-# - ${LIBDIR} - Program specific data directory (optional).
-# - basedir - Base data directory (configurable).
-# - "~/.${PORTNAME}" - Writing directory.
+# - cddir - Directory to be prepended (optional, configurable)
+# - ${Q2DIR} - Base shared data directory
+# - ${LIBDIR} - Program specific data directory (optional)
+# - basedir - Base data directory (configurable)
+# - "~/.${PORTNAME}" - Writing directory
# - The "game${ARCH}.so" in game engines and modifications should be changed
# to just "game.so" (the ${ARCH} can cause incompatibilities with new
-# platforms and is unnecessary).
+# platforms and is unnecessary);
# - The modifications and data which is common to all the engines should be
-# installed in ${Q2DIR}.
+# installed in ${Q2DIR};
# - The engines should not install game.so files for the normal game, CTF,
# Rogue, Xatrix, and all other which exist as a separate port. If the
-# version the engine provides is different than the original one then add it
-# as an option (off by default). If the engine is not compatible with the
-# game.so files provided by the ports then ignore this rule.
+# version the engine provides is different than the original one then add
+# it as an option (off by default). If the engine is not compatible with
+# the game.so files provided by the ports then ignore this rule.
#
-# For examples see the existing ports.
+# For the examples please see existing ports.
#
-# Set variables
-
Q2PKGNAMEPREFIX?= quake2-
Q2DIR?= ${LOCALBASE}/share/quake2
-# Add them to the ports system
-
MAKE_ENV+= Q2DIR="${Q2DIR}"
PLIST_SUB+= Q2DIR="${Q2DIR:S/${LOCALBASE}\///}"
SUB_LIST+= Q2DIR="${Q2DIR}"
-# Add the dependency
-
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q2DIR}:${PORTSDIR}/games/quake2-data
.endif
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index 217386828243..dbd7ff998c07 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -1,25 +1,17 @@
# Makefile for defining variables used by other Quake3 related ports. See
-# `games/quake2-data/Makefile.include' for extensive description.
-
-# Set variables
+# `games/quake2-data/Makefile.include' for extensive description and usage.
Q3PKGNAMEPREFIX?= quake3-
-Q3DIR?= ${PREFIX}/share/quake3
-
-# Add them to the environment
+Q3DIR?= ${LOCALBASE}/share/quake3
MAKE_ENV+= Q3DIR="${Q3DIR}"
-PLIST_SUB+= Q3DIR="${Q3DIR:S/${PREFIX}\///}"
+PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
SUB_LIST+= Q3DIR="${Q3DIR}"
-# Add the dependency
-
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
.endif
-# DOS to Unix text conversion
-
.if defined(USE_CRLF)
. if defined(USE_ZIP)
EXTRACT_BEFORE_ARGS= -aqo