aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-vld/Makefile24
-rw-r--r--devel/pecl-vld/distinfo3
-rw-r--r--devel/pecl-vld/files/patch-srm_oparray.c20
-rw-r--r--devel/pecl-vld/pkg-descr4
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index aae28ed57411..74a6cadd9332 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1667,6 +1667,7 @@
SUBDIR += pecl-runkit
SUBDIR += pecl-statgrab
SUBDIR += pecl-svn
+ SUBDIR += pecl-vld
SUBDIR += pedisassem
SUBDIR += perforce
SUBDIR += performance
diff --git a/devel/pecl-vld/Makefile b/devel/pecl-vld/Makefile
new file mode 100644
index 000000000000..00a1818cd548
--- /dev/null
+++ b/devel/pecl-vld/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pecl-vld
+# Date created: 2007/03/02
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= vld
+PORTVERSION= 0.8.0
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Dump the internal representation of PHP scripts
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-vld
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-vld/distinfo b/devel/pecl-vld/distinfo
new file mode 100644
index 000000000000..05e79f6699c9
--- /dev/null
+++ b/devel/pecl-vld/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/vld-0.8.0.tgz) = 00351344ed03a6eea6219e1db25aa660
+SHA256 (PECL/vld-0.8.0.tgz) = 0bf913e6cfd676de47704b22574711783909cef2318776db006f991f2246593a
+SIZE (PECL/vld-0.8.0.tgz) = 8796
diff --git a/devel/pecl-vld/files/patch-srm_oparray.c b/devel/pecl-vld/files/patch-srm_oparray.c
new file mode 100644
index 000000000000..42136c2254f4
--- /dev/null
+++ b/devel/pecl-vld/files/patch-srm_oparray.c
@@ -0,0 +1,20 @@
+--- srm_oparray.c.orig Mon Mar 5 00:55:20 2007
++++ srm_oparray.c Mon Mar 5 00:55:20 2007
+@@ -350,7 +350,8 @@
+ op->op2.u.opline_num = (zend_uint)((zend_op*)base_address + op->op2.u.opline_num);
+ op->op2.op_type = VLD_IS_OPLINE;
+ break;
+-
++/* use ZEND_JMP_NO_CTOR only when it is available (php < 5.1) */
++#ifdef ZEND_JMP_NO_CTOR
+ case ZEND_JMP_NO_CTOR:
+ flags = OP2_USED;
+ if (op->op1.op_type != IS_UNUSED) {
+@@ -361,6 +362,7 @@
+ #endif
+ op->op2.op_type = VLD_IS_OPLINE;
+ break;
++#endif
+
+ #ifdef ZEND_ENGINE_2
+ case ZEND_FETCH_CLASS:
diff --git a/devel/pecl-vld/pkg-descr b/devel/pecl-vld/pkg-descr
new file mode 100644
index 000000000000..55745ae85902
--- /dev/null
+++ b/devel/pecl-vld/pkg-descr
@@ -0,0 +1,4 @@
+The Vulcan Logic Disassembler hooks into the Zend Engine and
+dumps all the opcodes (execution units) of a script.
+
+WWW: http://pecl.php.net/package/vld/