aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/cdrtools-cjk/Makefile1
-rw-r--r--sysutils/cdrtools-devel/Makefile11
-rw-r--r--sysutils/cdrtools/Makefile12
3 files changed, 23 insertions, 1 deletions
diff --git a/sysutils/cdrtools-cjk/Makefile b/sysutils/cdrtools-cjk/Makefile
index 37456f0615db..8b6afdd1d01e 100644
--- a/sysutils/cdrtools-cjk/Makefile
+++ b/sysutils/cdrtools-cjk/Makefile
@@ -6,6 +6,7 @@
#
PORTVERSION= 2.01.${PATCHDATE}
+PORTREVISION= 1
CATEGORIES= sysutils chinese japanese korean audio
PKGNAMEPREFIX= cjk-
diff --git a/sysutils/cdrtools-devel/Makefile b/sysutils/cdrtools-devel/Makefile
index c3fc7df9406a..c92816df7e12 100644
--- a/sysutils/cdrtools-devel/Makefile
+++ b/sysutils/cdrtools-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cdrtools
PORTVERSION= 2.01.01a03
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= sysutils audio
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/alpha/ \
@@ -56,6 +57,12 @@ PKGNAMESUFFIX?= -devel
IGNORE= The mlockall(2) of your FreeBSD 5.x version causes problems when used by cdrecord. Please update FreeBSD to >= 5.3 in order to use this port
.endif
+.if exists(${LOCALBASE}/lib/libcdio.a) || defined(WITH_CDDB)
+WITH_CDDB= yes
+LIB_DEPENDS+= cddb.3:${PORTSDIR}/audio/libcddb \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
+.endif
+
pre-everything::
.if !defined(WITH_RSCSI)
@${ECHO_MSG} ""
@@ -68,6 +75,10 @@ pre-everything::
@${ECHO_MSG} " this is the preferred method to set it up."
@${ECHO_MSG} ""
.endif
+.if !defined(WITH_CDDB)
+ @${ECHO_MSG} "WITH_CDDB=yes builds with cddb (http://freedb.org) support"
+ @${ECHO_MSG} ""
+.endif
post-extract:
.for i in config.guess config.sub
diff --git a/sysutils/cdrtools/Makefile b/sysutils/cdrtools/Makefile
index b264b56055fe..0d9feda2c7a8 100644
--- a/sysutils/cdrtools/Makefile
+++ b/sysutils/cdrtools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cdrtools
PORTVERSION?= 2.01
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= sysutils audio
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/ \
ftp://ftp.cs.tu-berlin.de/pub/misc/cdrecord/
@@ -54,6 +54,12 @@ PLIST_SUB= RSCSI="@comment "
IGNORE= The mlockall(2) of your FreeBSD 5.x version causes problems when used by cdrecord. Please update FreeBSD to >= 5.3 in order to use this port
.endif
+.if exists(${LOCALBASE}/lib/libcdio.a) || defined(WITH_CDDB)
+WITH_CDDB= yes
+LIB_DEPENDS+= cddb.3:${PORTSDIR}/audio/libcddb \
+ cdio.6:${PORTSDIR}/sysutils/libcdio
+.endif
+
pre-everything::
.if !defined(WITH_RSCSI)
@${ECHO_MSG} ""
@@ -66,6 +72,10 @@ pre-everything::
@${ECHO_MSG} " this is the preferred method to set it up."
@${ECHO_MSG} ""
.endif
+.if !defined(WITH_CDDB)
+ @${ECHO_MSG} "WITH_CDDB=yes builds with cddb (http://freedb.org) support"
+ @${ECHO_MSG} ""
+.endif
post-extract:
.for i in config.guess config.sub