aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/fxt/Makefile20
-rw-r--r--math/fxt/distinfo4
-rw-r--r--math/fxt/files/patch-makefile22
3 files changed, 12 insertions, 34 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index 05fd6198cf84..2fce4bf3644a 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -2,33 +2,33 @@
# $FreeBSD$
PORTNAME= fxt
-PORTVERSION= 2015.07.17
-PORTREVISION= 1
+PORTVERSION= 2016.02.27
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
MAINTAINER= ports@FreeBSD.org
COMMENT= FFT code and related stuff
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= gmake tar:tgz
+MAKE_ENV= FXT_INSTALL="${INSTALL_DATA}"
MAKEFILE= makefile
OPTIONS_DEFINE= EXAMPLES
post-patch:
- @${REINPLACE_CMD} -E \
- -e 's,^(FXT_CXXFLAGS),#\1,' \
- -e 's,^(CXXFLAGS),#\1,' \
- ${WRKSRC}/makefile
- @${REINPLACE_CMD} -e 's|sinl|Sin|g' ${WRKSRC}/src/aux0/trigrec.h
- @${REINPLACE_CMD} -e 's|sinl|sin|g' ${WRKSRC}/src/fht/hartleyshift.h
+ @${REINPLACE_CMD} -e \
+ 's|^\(FXT_CXXFLAGS\)|#\1| ; \
+ s|\([[:space:]]\)\($$(INCDIR)\)|\1$$(DESTDIR)\2|g ; \
+ s|\([[:space:]]\)\($$(LIBDIR)\)|\1$$(DESTDIR)\2|g' \
+ ${WRKSRC}/makefile
post-install-EXAMPLES-on:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- (cd ${WRKSRC}/demo && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}/)
+ (cd ${WRKSRC}/demo && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index 66cf43505dec..e676f8749d98 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fxt-2015.07.17.tgz) = 516f7b1bfd8df05ce5696ba2773662ca6cdc550024dd3d8012dc341b19f648ad
-SIZE (fxt-2015.07.17.tgz) = 1810832
+SHA256 (fxt-2016.02.27.tgz) = ebd6023876a1f15b8a1728f6a29b5acc98f977e07eb0da9df68220922233597e
+SIZE (fxt-2016.02.27.tgz) = 1826058
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
deleted file mode 100644
index 0d91ce125e15..000000000000
--- a/math/fxt/files/patch-makefile
+++ /dev/null
@@ -1,22 +0,0 @@
---- makefile.orig 2015-07-18 10:34:30 UTC
-+++ makefile
-@@ -197,13 +197,13 @@ install: lib
- : '[$@]'
- @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
- @:
-- @test -d $(INCDIR) || mkdir $(INCDIR)
-- @$(FXT_INSTALL) $(FXTIDIR)/*.h $(INCDIR)/
-- @cd src && for f in $(SHFXTSRCDIRS); do mkdir -p $(INCDIR)/$$f; done
-- @cd src && for f in $(SHFXTSRCDIRS); do $(FXT_INSTALL) $$f/*.h $(INCDIR)/$$f; done
-+ @test -d $(DESTDIR)$(INCDIR) || mkdir $(DESTDIR)$(INCDIR)
-+ @$(FXT_INSTALL) $(FXTIDIR)/*.h $(DESTDIR)$(INCDIR)/
-+ @cd src && for f in $(SHFXTSRCDIRS); do mkdir -p $(DESTDIR)$(INCDIR)/$$f; done
-+ @cd src && for f in $(SHFXTSRCDIRS); do $(FXT_INSTALL) $$f/*.h $(DESTDIR)$(INCDIR)/$$f; done
- @:
-- @test -d $(LIBDIR) || mkdir $(LIBDIR)
-- @$(FXT_INSTALL) $(FXTLIB) $(LIBDIR)/
-+ @test -d $(DESTDIR)$(LIBDIR) || mkdir $(DESTDIR)$(LIBDIR)
-+ @$(FXT_INSTALL) $(FXTLIB) $(DESTDIR)$(LIBDIR)/
- : '[$@ OK]'
-
- .PHONY: chk-install ##x print whether installed header files are up to date