aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--chinese/scim-pinyin/Makefile24
-rw-r--r--chinese/scim-pinyin/distinfo6
-rw-r--r--chinese/scim-pinyin/files/patch-skim-setupui-smartpinyinui.ui23
-rw-r--r--chinese/scim-pinyin/pkg-plist15
4 files changed, 63 insertions, 5 deletions
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index a7321d88787a..a6cfbb7e75fc 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim-pinyin
-PORTVERSION= 0.5.0
-PORTREVISION= 5
+PORTVERSION= 0.5.91
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=scim
@@ -39,6 +38,27 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
.endif
+PLIST_SUB= SKIM="@comment "
+
+pre-fetch:
+.if exists(${LOCALBASE}/bin/skim)
+ @${ECHO_MSG} "===> Skim is detected, support enabled."
+.else
+ @${ECHO_MSG} "Define WITH_SKIM to enable skim support."
+.endif
+
+.if exists(${LOCALBASE}/bin/skim)
+WITH_SKIM= yes
+.endif
+
+.if !defined(WITH_SKIM)
+CONFIGURE_ARGS+=--disable-skim-support
+.else
+BUILD_DEPENDS+= skim:${PORTSDIR}/textproc/skim
+CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+PLIST_SUB= SKIM="" PREFIX="${PREFIX}"
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
diff --git a/chinese/scim-pinyin/distinfo b/chinese/scim-pinyin/distinfo
index c68c05f35a47..0fe21026b98f 100644
--- a/chinese/scim-pinyin/distinfo
+++ b/chinese/scim-pinyin/distinfo
@@ -1,3 +1,3 @@
-MD5 (scim-pinyin-0.5.0.tar.gz) = 3cb810f4ae252c7e05fc01b7e5548da9
-SHA256 (scim-pinyin-0.5.0.tar.gz) = 8e9df91c88bf135172391705201a22bf70812914b72c0a40ce54c719b03e9f9e
-SIZE (scim-pinyin-0.5.0.tar.gz) = 4829272
+MD5 (scim-pinyin-0.5.91.tar.gz) = fb96d3545090d7681ea03edaced4eccb
+SHA256 (scim-pinyin-0.5.91.tar.gz) = 9b6b24af841cbf0353b919df7f56be931850fccf3b914172af7a39b6db726653
+SIZE (scim-pinyin-0.5.91.tar.gz) = 5492055
diff --git a/chinese/scim-pinyin/files/patch-skim-setupui-smartpinyinui.ui b/chinese/scim-pinyin/files/patch-skim-setupui-smartpinyinui.ui
new file mode 100644
index 000000000000..44d6e2b457eb
--- /dev/null
+++ b/chinese/scim-pinyin/files/patch-skim-setupui-smartpinyinui.ui
@@ -0,0 +1,23 @@
+--- skim/setupui/smartpinyinui.ui~ Wed Mar 23 11:45:03 2005
++++ skim/setupui/smartpinyinui.ui Fri Feb 10 21:05:09 2006
+@@ -863,20 +863,4 @@
+ <tabstop>kcfg__IMEngine_Pinyin_DisablePhraseKey</tabstop>
+ </tabstops>
+ <layoutdefaults spacing="6" margin="11"/>
+-<includehints>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+- <includehint>skimeditshortcutbutton.h</includehint>
+- <includehint>klineedit.h</includehint>
+-</includehints>
+ </UI>
diff --git a/chinese/scim-pinyin/pkg-plist b/chinese/scim-pinyin/pkg-plist
index fe80075a1ff0..9f11a0155656 100644
--- a/chinese/scim-pinyin/pkg-plist
+++ b/chinese/scim-pinyin/pkg-plist
@@ -3,6 +3,7 @@ lib/scim-1.0/SetupUI/pinyin-imengine-setup.so
share/locale/de/LC_MESSAGES/scim-pinyin.mo
share/locale/fr/LC_MESSAGES/scim-pinyin.mo
share/locale/ko/LC_MESSAGES/scim-pinyin.mo
+share/locale/it/LC_MESSAGES/scim-pinyin.mo
share/locale/ja/LC_MESSAGES/scim-pinyin.mo
share/locale/zh_CN/LC_MESSAGES/scim-pinyin.mo
share/locale/zh_TW/LC_MESSAGES/scim-pinyin.mo
@@ -12,6 +13,20 @@ share/scim/pinyin/pinyin_phrase_lib
share/scim/pinyin/pinyin_table
share/scim/pinyin/special_table
share/scim/icons/smart-pinyin.png
+%%SKIM%%@cwd %%LOCALBASE%%
+%%SKIM%%lib/kde3/kcm_skimplugin_scim_smartpinyin.la
+%%SKIM%%lib/kde3/kcm_skimplugin_scim_smartpinyin.so
+%%SKIM%%share/services/skimconfiguredialog/skimplugin_scim_smartpinyin_config.desktop
+%%SKIM%%share/config.kcfg/smartpinyin.kcfg
+%%SKIM%%share/locale/zh_CN/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/zh_TW/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/de/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/fr/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/ja/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/it/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/locale/ko/LC_MESSAGES/skim-scim-pinyin.mo
+%%SKIM%%share/apps/skim/pics/smart-pinyin.png
+%%SKIM%%@cwd %%PREFIX%%
@dirrmtry lib/scim-1.0/IMEngine
@dirrmtry lib/scim-1.0/SetupUI
@dirrm share/scim/pinyin