aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/cfitsio/Makefile5
-rw-r--r--biology/molden/Makefile6
2 files changed, 2 insertions, 9 deletions
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index c6faf33d87b1..5357171d2fab 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -19,10 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
LIB_DEPENDS+= f2c.2:${PORTSDIR}/lang/f2c
ALL_TARGET= shared
diff --git a/biology/molden/Makefile b/biology/molden/Makefile
index 1d8b3661b115..d3ae85919f7c 100644
--- a/biology/molden/Makefile
+++ b/biology/molden/Makefile
@@ -27,11 +27,7 @@ MAKEFILE= ${WRKSRC}/makefile
.include <bsd.port.pre.mk>
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-MAKE_ENV+= FC="${FC}" F77="${77}"
+USE_FORTRAN= yes
post-patch:
${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/xwin.c