aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/twhttpd/Makefile9
-rw-r--r--www/twhttpd/files/patch-ac9
2 files changed, 11 insertions, 7 deletions
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
index a5e73fff10e1..9ca097182a0c 100644
--- a/www/twhttpd/Makefile
+++ b/www/twhttpd/Makefile
@@ -19,12 +19,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOCONF_VER= 213
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
@${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
@${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
@@ -32,4 +26,5 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/www/twhttpd/files/patch-ac b/www/twhttpd/files/patch-ac
index a663815b5f49..c138d0cf6444 100644
--- a/www/twhttpd/files/patch-ac
+++ b/www/twhttpd/files/patch-ac
@@ -9,3 +9,12 @@
#include <netinet/in.h>
#include <sys/socket.h>
#include <sys/types.h>
+@@ -3882,7 +3882,7 @@
+ lz_flush(hd->fd, &hd->fd_lzb);
+ }
+ syslog(LOG_ERR, "Exiting Testing Server\n");
+- exit;
++ exit(0);
+ }
+
+ //////////////////////////////////////////////////////////////////////