aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/another-htmllint/Makefile38
-rw-r--r--japanese/another-htmllint/distinfo4
-rw-r--r--japanese/another-htmllint/files/htmllint14
-rw-r--r--japanese/another-htmllint/files/htmllint.in14
-rw-r--r--japanese/another-htmllint/files/patch-htmllint.cgi22
-rw-r--r--japanese/another-htmllint/files/patch-htmllintenv34
-rw-r--r--japanese/another-htmllint/files/pkg-message.in9
-rw-r--r--japanese/another-htmllint/pkg-message9
-rw-r--r--japanese/another-htmllint/pkg-plist161
9 files changed, 165 insertions, 140 deletions
diff --git a/japanese/another-htmllint/Makefile b/japanese/another-htmllint/Makefile
index 5d2733f809ab..bdaba2ae15b9 100644
--- a/japanese/another-htmllint/Makefile
+++ b/japanese/another-htmllint/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= another-htmllint
-PORTVERSION= 20060601
-PORTREVISION= 1
+PORTVERSION= 20111128
CATEGORIES= japanese www
-MASTER_SITES= http://dist.bsdlab.org/
+MASTER_SITES= http://openlab.ring.gr.jp/k16/htmllint/archives/
+DISTNAME= htmllint
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Another HTML-lint (all messages are written in Japanese)
@@ -12,35 +12,41 @@ COMMENT= Another HTML-lint (all messages are written in Japanese)
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
ja-p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode
-USES= dos2unix perl5 zip
+USES= dos2unix perl5 shebangfix zip
WRKSRC= ${WRKDIR}
DOS2UNIX_FILES= readme.txt
+SHEBANG_FILES= htmllint.cgi tagslist.cgi
+SUB_FILES= htmllint pkg-message
+SUB_LIST+= PERL=${PERL}
+
+OPTIONS_DEFINE= W3M
+W3M_DESC= Use w3m to show rendering result
+W3M_RUN_DEPENDS= w3m>0:${PORTSDIR}/www/w3m
-DIR= ${STAGEDIR}${PREFIX}/share/htmllint
PM= htmllint.pm RFC2396.pm htmllint.env
RULE= *.rul
HTML= *.cgi *.html *.gif *.css
-SEDSUB= ${SED} -e 's@%PREFIX%@${PREFIX}@ ; s@%PERL%@${PERL}@'
+SEDSUB= ${SED} -i.bak -e 's@%%PREFIX%%@${PREFIX}@ ; s@%%DATADIR%%@${DATADIR}@'
# Please set this!
HTMLLINT_ADMIN?= kuriyama@FreeBSD.org
+.include <bsd.port.options.mk>
+
do-build:
- @${SEDSUB} ${FILESDIR}/htmllint > ${WRKSRC}/htmllint
- @${SEDSUB} ${WRKSRC}/htmllintenv > ${WRKSRC}/htmllint.env
- @${SEDSUB} ${WRKSRC}/htmllint.cgi > ${WRKSRC}/htmllint.cgi.new
- @${MV} ${WRKSRC}/htmllint.cgi.new ${WRKSRC}/htmllint.cgi
+ @${SEDSUB} ${WRKSRC}/htmllintenv
+ @${MV} ${WRKSRC}/htmllintenv ${WRKSRC}/htmllint.env
+ @${SEDSUB} ${WRKSRC}/htmllint.cgi
@${SED} -i.bak -e 's|^</address>|</address><br>Maintained by <address>${HTMLLINT_ADMIN}</address>|' ${WRKSRC}/*.html
-.if exists(${LOCALBASE}/bin/w3m)
- @${ECHO_MSG} "Find w3m."
+.if ${PORT_OPTIONS:MW3M}
@${SED} -i.bak -e 's|^#$$W3M|$$W3M|' ${WRKSRC}/htmllint.env
.endif
do-install:
- ${MKDIR} ${DIR}/rule ${DIR}/html
+ ${MKDIR} ${STAGEDIR}${DATADIR}/rule ${STAGEDIR}${DATADIR}/html
cd ${WRKSRC} && ${INSTALL_SCRIPT} htmllint ${STAGEDIR}${PREFIX}/bin
- cd ${WRKSRC} && ${INSTALL_SCRIPT} ${HTML} ${DIR}/html
- cd ${WRKSRC} && ${INSTALL_DATA} ${PM} ${DIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${RULE} ${DIR}/rule
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${HTML} ${STAGEDIR}${DATADIR}/html
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PM} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${RULE} ${STAGEDIR}${DATADIR}/rule
.include <bsd.port.mk>
diff --git a/japanese/another-htmllint/distinfo b/japanese/another-htmllint/distinfo
index 0f4462b9435c..e60828d59048 100644
--- a/japanese/another-htmllint/distinfo
+++ b/japanese/another-htmllint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (another-htmllint-20060601.zip) = d0f71d3144ca22b98203308dd83263ecebe2fa50c11097ee8f5bf3804428e31d
-SIZE (another-htmllint-20060601.zip) = 706210
+SHA256 (htmllint.zip) = 1a1e161813a33bc44ce5beb11d3a2a08615851bdb0a43c4fbcc687ab19f82a9a
+SIZE (htmllint.zip) = 775997
diff --git a/japanese/another-htmllint/files/htmllint b/japanese/another-htmllint/files/htmllint
deleted file mode 100644
index b3664c0d1079..000000000000
--- a/japanese/another-htmllint/files/htmllint
+++ /dev/null
@@ -1,14 +0,0 @@
-#!%PERL%
-#
-# $Id$
-#
-
-#use strict;
-use lib '%PREFIX%/share/htmllint';
-use lib '%PREFIX%/share/htmllint/rule';
-
-$RULEDIR = '%PREFIX%/share/htmllint/rule/';
-
-require 'htmllint.pm';
-
-exit(&htmllint::HTMLlint(@ARGV));
diff --git a/japanese/another-htmllint/files/htmllint.in b/japanese/another-htmllint/files/htmllint.in
new file mode 100644
index 000000000000..43cdf2e48d2a
--- /dev/null
+++ b/japanese/another-htmllint/files/htmllint.in
@@ -0,0 +1,14 @@
+#!%%PERL%%
+#
+# $Id$
+#
+
+#use strict;
+use lib '%%DATADIR%%';
+use lib '%%DATADIR%%/rule';
+
+$RULEDIR = '%%DATADIR%%/rule/';
+
+require 'htmllint.pm';
+
+exit(&htmllint::HTMLlint(@ARGV));
diff --git a/japanese/another-htmllint/files/patch-htmllint.cgi b/japanese/another-htmllint/files/patch-htmllint.cgi
index 284f10d4c460..6171b2d6dd18 100644
--- a/japanese/another-htmllint/files/patch-htmllint.cgi
+++ b/japanese/another-htmllint/files/patch-htmllint.cgi
@@ -1,17 +1,11 @@
---- htmllint.cgi.orig Wed Aug 23 19:19:28 2000
-+++ htmllint.cgi Fri Sep 29 14:41:55 2000
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/perl
-+#!%PERL%
-
- # CGI script for Another HTML-lint gateway ###################
-
-@@ -26,6 +26,8 @@
- #$OS2 = UNSUPPORTED;
- $UNIX = !($WIN || $MAC || $OS2);
-
-+use lib '%PREFIX%/share/htmllint';
-+use lib '%PREFIX%/share/htmllint/rule';
+--- htmllint.cgi.orig 2014-12-07 10:16:56.651728605 +0900
++++ htmllint.cgi 2014-12-07 10:22:52.118705399 +0900
+@@ -28,6 +28,8 @@
+ my $OS2; #UNSUPPORTED;
+ my $UNIX = !($WIN || $MAC || $OS2);
+
++use lib '%%DATADIR%%';
++use lib '%%DATADIR%%/rule';
require 'htmllint.env';
require $LINT_NAME;
diff --git a/japanese/another-htmllint/files/patch-htmllintenv b/japanese/another-htmllint/files/patch-htmllintenv
index 671558ad4d5d..3d6f2533cd5c 100644
--- a/japanese/another-htmllint/files/patch-htmllintenv
+++ b/japanese/another-htmllint/files/patch-htmllintenv
@@ -1,16 +1,16 @@
---- htmllintenv.orig Tue May 22 17:33:22 2001
-+++ htmllintenv Wed Sep 12 19:37:32 2001
+--- htmllintenv.orig 2007-05-19 17:36:51.000000000 +0900
++++ htmllintenv 2014-12-07 10:59:19.092555161 +0900
@@ -5,15 +5,15 @@
# アクセス権をうまく工夫して、他人から見えないようにしてください。
# CGI 用ディレクトリ (絶対パスかCGI相対パスで指定、なるべく絶対パスにしてください)
-$RULEDIR = './'; # 規則ファイルの場所
-#$LOGSDIR = './logs/'; # ログファイルの場所 (不要ならコメントアウト)
-+$RULEDIR = '%PREFIX%/share/htmllint/rule/'; # 規則ファイルの場所
-+#$LOGSDIR = '%PREFIX%/share/htmllint/logs/'; # ログファイルの場所 (不要ならコメントアウト)
++$RULEDIR = '%%DATADIR%%/rule/'; # 規則ファイルの場所
++#$LOGSDIR = '/var/logs/another-htmllint/'; # ログファイルの場所 (不要ならコメントアウト)
$TMPDIR = '/tmp/'; # テンポラリファイルの場所
-$IMGDIR = './'; # イメージファイルの場所
-+$IMGDIR = '%PREFIX%/share/htmllint/html/'; # イメージファイルの場所
++$IMGDIR = '%%DATADIR%%/html/'; # イメージファイルの場所
$TAGSLIST = ''; # タグ一覧キャッシュ用の場所 (空ならキャッシュしない)
# 設定するときはアクセス権を適当に与えておくこと
@@ -20,3 +20,27 @@
$GATEWAYURL = $HTMLDIR.'htmllint.html'; # ゲイトウェイサーヴィス HTML
$EXPLAIN = $HTMLDIR.'explain.html'; # 解説用 HTML (HTML用)
$CGIROOT = $HTMLDIR; # CGIの場所
+@@ -80,12 +80,12 @@
+ #$KANJICODE = 'JIS'; # JIS/EUC/SJIS/UTF8 のいずれか
+
+ # Lynx (不要あるいは未実装ならコメントアウト)
+-#$LYNX = '/usr/local/bin/lynx -dump -nolist -force_html';
++#$LYNX = '%%PREFIX%%/bin/lynx -dump -nolist -force_html';
+
+ # w3m (不要あるいは未実装ならコメントアウト)
+ # カラー機能のない場合 -M の指定は不可
+ # -e は EUC、Shift JIS なら -s
+-#$W3M = '/usr/local/bin/w3m -dump -T text/html -M -e';
++#$W3M = '%%PREFIX%%/bin/w3m -dump -T text/html -M -e';
+
+ # 得点記録用ログファイル (不要ならコメントアウト)
+ # # の部分は年月に置き換わります
+@@ -100,7 +100,7 @@
+ #@EXCEPTSCORES = qw(uso800.ac.jp);
+
+ # Muquit's Access Counter CGI (不要あるいは未実装ならコメントアウト)
+-#$COUNTER = '/usr/local/www/cgi-bin/Count.cgi';
++#$COUNTER = '%%PREFIX%%/www/cgi-bin/Count.cgi';
+
+ # ビジーチェック関数
+ # sub BusyCheck {
diff --git a/japanese/another-htmllint/files/pkg-message.in b/japanese/another-htmllint/files/pkg-message.in
new file mode 100644
index 000000000000..5508dd0735d9
--- /dev/null
+++ b/japanese/another-htmllint/files/pkg-message.in
@@ -0,0 +1,9 @@
+To activate htmllint, use Alias directive in httd.conf or symbolic link
+from %%DATADIR%%/html/ like as:
+
+Alias /htmllint/ %%DATADIR%%/html/
+
+<Directory %%DATADIR%%/html>
+ AddHandler cgi-script .cgi
+ Options +ExecCGI
+</Directory>
diff --git a/japanese/another-htmllint/pkg-message b/japanese/another-htmllint/pkg-message
deleted file mode 100644
index a2a71083dc1e..000000000000
--- a/japanese/another-htmllint/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
-To activate htmllint, use Alias directive in httd.conf or symbolic link
-from ${PREFIX}/share/htmllint/html/ like as:
-
-Alias /htmllint/ /usr/local/share/htmllint/html/
-
-<Directory /usr/local/share/htmllint/html>
- AddHandler cgi-script .cgi
- Options +ExecCGI
-</Directory>
diff --git a/japanese/another-htmllint/pkg-plist b/japanese/another-htmllint/pkg-plist
index cd4013319fee..1aadfacd14c6 100644
--- a/japanese/another-htmllint/pkg-plist
+++ b/japanese/another-htmllint/pkg-plist
@@ -1,81 +1,82 @@
bin/htmllint
-share/htmllint/htmllint.pm
-share/htmllint/RFC2396.pm
-share/htmllint/rule/15445.rul
-share/htmllint/rule/15445-preparation.rul
-share/htmllint/rule/arena.rul
-share/htmllint/rule/charsets.rul
-share/htmllint/rule/colortable.rul
-share/htmllint/rule/common.rul
-share/htmllint/rule/compact-html.rul
-share/htmllint/rule/doti10.rul
-share/htmllint/rule/html10.rul
-share/htmllint/rule/html20.rul
-share/htmllint/rule/html40-frameset.rul
-share/htmllint/rule/html40-mobile.rul
-share/htmllint/rule/html40-strict.rul
-share/htmllint/rule/html40-transitional.rul
-share/htmllint/rule/html401-frameset.rul
-share/htmllint/rule/html401-strict.rul
-share/htmllint/rule/html401-transitional.rul
-share/htmllint/rule/htmlplus.rul
-share/htmllint/rule/i18n.rul
-share/htmllint/rule/ie30.rul
-share/htmllint/rule/ie30b.rul
-share/htmllint/rule/ie40.rul
-share/htmllint/rule/ie50.rul
-share/htmllint/rule/ie55.rul
-share/htmllint/rule/imode-xhtml.rul
-share/htmllint/rule/imode-xhtml11.rul
-share/htmllint/rule/imode.rul
-share/htmllint/rule/imode20.rul
-share/htmllint/rule/imode30.rul
-share/htmllint/rule/imode40.rul
-share/htmllint/rule/imode50.rul
-share/htmllint/rule/jpo.rul
-share/htmllint/rule/jskystation.rul
-share/htmllint/rule/jskyweb.rul
-share/htmllint/rule/mozilla20.rul
-share/htmllint/rule/mozilla30.rul
-share/htmllint/rule/mozilla40.rul
-share/htmllint/rule/webexp.rul
-share/htmllint/rule/wilbur.rul
-share/htmllint/rule/xhtml-basic.rul
-share/htmllint/rule/xhtml-mp.rul
-share/htmllint/rule/xhtml1-frameset.rul
-share/htmllint/rule/xhtml1-strict.rul
-share/htmllint/rule/xhtml1-transitional.rul
-share/htmllint/rule/xhtml11.rul
-share/htmllint/html/htmllint.cgi
-share/htmllint/html/colors.html
-share/htmllint/html/colorsbk.html
-share/htmllint/html/download.html
-share/htmllint/html/explain-omake.html
-share/htmllint/html/explain-score.html
-share/htmllint/html/explain-wai.html
-share/htmllint/html/explain.html
-share/htmllint/html/faq.html
-share/htmllint/html/htmllint.html
-share/htmllint/html/htmllinte.html
-share/htmllint/html/htmllintl.html
-share/htmllint/html/index.html
-share/htmllint/html/introduction.html
-share/htmllint/html/mailinglist.html
-share/htmllint/html/notice.html
-share/htmllint/html/reference.html
-share/htmllint/html/rulefile.html
-share/htmllint/html/sitemap.html
-share/htmllint/html/tagslist.html
-share/htmllint/html/use-htmllint.html
-share/htmllint/html/use-htmllintcgi.html
-share/htmllint/html/close.gif
-share/htmllint/html/fight.gif
-share/htmllint/html/good.gif
-share/htmllint/html/normal.gif
-share/htmllint/html/open.gif
-share/htmllint/html/top.gif
-share/htmllint/html/verygood.gif
-share/htmllint/html/htmllint.css
-share/htmllint/html/htmllint2.css
-share/htmllint/html/tagslist.cgi
-share/htmllint/htmllint.env
+%%DATADIR%%/RFC2396.pm
+%%DATADIR%%/html/close.gif
+%%DATADIR%%/html/colors.html
+%%DATADIR%%/html/colorsbk.html
+%%DATADIR%%/html/download.html
+%%DATADIR%%/html/explain-omake.html
+%%DATADIR%%/html/explain-score.html
+%%DATADIR%%/html/explain-wai.html
+%%DATADIR%%/html/explain.html
+%%DATADIR%%/html/faq.html
+%%DATADIR%%/html/fight.gif
+%%DATADIR%%/html/good.gif
+%%DATADIR%%/html/htmllint.cgi
+%%DATADIR%%/html/htmllint.css
+%%DATADIR%%/html/htmllint.html
+%%DATADIR%%/html/htmllinte.html
+%%DATADIR%%/html/htmllintl.html
+%%DATADIR%%/html/index.html
+%%DATADIR%%/html/introduction.html
+%%DATADIR%%/html/mailinglist.html
+%%DATADIR%%/html/normal.gif
+%%DATADIR%%/html/notice.html
+%%DATADIR%%/html/open.gif
+%%DATADIR%%/html/reference.html
+%%DATADIR%%/html/rulefile.html
+%%DATADIR%%/html/sitemap.html
+%%DATADIR%%/html/tagslist.cgi
+%%DATADIR%%/html/tagslist.html
+%%DATADIR%%/html/top.gif
+%%DATADIR%%/html/use-htmllint.html
+%%DATADIR%%/html/use-htmllintcgi.html
+%%DATADIR%%/html/verygood.gif
+%%DATADIR%%/htmllint.env
+%%DATADIR%%/htmllint.pm
+%%DATADIR%%/rule/15445-preparation.rul
+%%DATADIR%%/rule/15445.rul
+%%DATADIR%%/rule/arena.rul
+%%DATADIR%%/rule/charsets.rul
+%%DATADIR%%/rule/colortable.rul
+%%DATADIR%%/rule/common.rul
+%%DATADIR%%/rule/compact-html.rul
+%%DATADIR%%/rule/doti10.rul
+%%DATADIR%%/rule/html10.rul
+%%DATADIR%%/rule/html20.rul
+%%DATADIR%%/rule/html40-frameset.rul
+%%DATADIR%%/rule/html40-mobile.rul
+%%DATADIR%%/rule/html40-strict.rul
+%%DATADIR%%/rule/html40-transitional.rul
+%%DATADIR%%/rule/html401-frameset.rul
+%%DATADIR%%/rule/html401-strict.rul
+%%DATADIR%%/rule/html401-transitional.rul
+%%DATADIR%%/rule/htmlplus-old.rul
+%%DATADIR%%/rule/htmlplus.rul
+%%DATADIR%%/rule/i18n.rul
+%%DATADIR%%/rule/ie30.rul
+%%DATADIR%%/rule/ie30b.rul
+%%DATADIR%%/rule/ie40.rul
+%%DATADIR%%/rule/ie50.rul
+%%DATADIR%%/rule/ie55.rul
+%%DATADIR%%/rule/imode-xhtml.rul
+%%DATADIR%%/rule/imode-xhtml11.rul
+%%DATADIR%%/rule/imode.rul
+%%DATADIR%%/rule/imode20.rul
+%%DATADIR%%/rule/imode30.rul
+%%DATADIR%%/rule/imode40.rul
+%%DATADIR%%/rule/imode50.rul
+%%DATADIR%%/rule/jpo.rul
+%%DATADIR%%/rule/jskystation.rul
+%%DATADIR%%/rule/jskyweb.rul
+%%DATADIR%%/rule/mozilla20.rul
+%%DATADIR%%/rule/mozilla30.rul
+%%DATADIR%%/rule/mozilla40.rul
+%%DATADIR%%/rule/webexp.rul
+%%DATADIR%%/rule/wilbur.rul
+%%DATADIR%%/rule/xhtml-basic.rul
+%%DATADIR%%/rule/xhtml-mp.rul
+%%DATADIR%%/rule/xhtml-rdfa-1.rul
+%%DATADIR%%/rule/xhtml1-frameset.rul
+%%DATADIR%%/rule/xhtml1-strict.rul
+%%DATADIR%%/rule/xhtml1-transitional.rul
+%%DATADIR%%/rule/xhtml11.rul