aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/apcupsd/Makefile140
-rw-r--r--sysutils/apcupsd/distinfo7
-rw-r--r--sysutils/apcupsd/pkg-descr2
-rw-r--r--sysutils/apcupsd/pkg-plist17
4 files changed, 52 insertions, 114 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 1e4876a81691..91f399cca059 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -1,44 +1,38 @@
-# Created by: Lars Köller <Lars.Koeller@Uni-Bielefeld.DE>
+# Created by: Lars Köller <Lars.Koeller@Uni-Bielefeld.DE>
# $FreeBSD$
PORTNAME= apcupsd
-PORTVERSION= 3.14.10
-PORTREVISION= 1
+PORTVERSION= 3.14.12
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20-%20Stable/${PORTVERSION}:src_sf \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/:src_bk \
http://apcupsd.sourceforge.net/manual/:doc_sf \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/:doc_bk
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src_sf,src_bk \
- ${PORTNAME}.pdf:doc_sf,doc_bk
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:src_sf,src_bk
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Set of programs for controlling APC UPS
-BROKEN= no distinfo provided for some of the distfiles
-
USE_RC_SUBR= apcupsd
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
USES= gmake
+OPTIONS_SUB= yes
CONFIGURE_ARGS= --sbindir=${PREFIX}/sbin \
--with-nologin=/var/run \
--disable-install-distdir \
--sysconfdir=${ETCDIR} \
--with-serial-dev=/dev/usv
-CONFIGURE_ENV+= LD="${CXX}"
+CONFIGURE_ENV+= LD="${CXX}" LIBS="-lstdc++"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-MAN5= apcupsd.conf.5
-MAN8= apcaccess.8 apccontrol.8 apctest.8 apcupsd.8
-
OPTIONS_DEFINE= APCSMART_DRV APCDUMB_DRV CLIENT_ONLY CGI PCNET_DRV USB SNMP_DRV \
- SNMP_DRV_OLD TCP_WRAPPERS TEST_DRV GAPCMON DOCS
-OPTIONS_DEFAULT= APCSMART_DRV APCDUMB_DRV PCNET_DRV USB TCP_WRAPPERS
+ SNMP_DRV_OLD TCP_WRAPPERS TEST_DRV GAPCMON DOCS MODBUS
+OPTIONS_DEFAULT= APCSMART_DRV APCDUMB_DRV PCNET_DRV USB TCP_WRAPPERS MODBUS
APCSMART_DRV_DESC= Compile APC SmartUPS serial driver
APCDUMB_DRV_DESC= Compile dumb UPS driver
CLIENT_ONLY_DESC= Only NIS client (no network server or drivers)
@@ -50,82 +44,40 @@ SNMP_DRV_OLD_DESC= Compile with old SNMP driver
TCP_WRAPPERS_DESC= Compile with TCP_WRAPPERS support
TEST_DRV_DESC= Compile TEST driver
GAPCMON_DESC= Build GTK GUI front-end
+MODBUS_DESC= Compile with MODBUS driver
PORTDOCS= ${PORTNAME}.pdf
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MAPCSMART_DRV}
-CONFIGURE_ARGS+= --enable-apcsmart
-.else
-CONFIGURE_ARGS+= --disable-apcsmart
-.endif
-
-.if ${PORT_OPTIONS:MAPCDUMB_DRV}
-CONFIGURE_ARGS+= --enable-dumb
-.else
-CONFIGURE_ARGS+= --disable-dumb
-.endif
-
-.if ${PORT_OPTIONS:MCLIENT_ONLY}
-CONFIGURE_ARGS+= --enable-net \
- --disable-apcsmart --disable-dumb --disable-usb \
- --disable-snmp --disable-test --disable-pcnet
-.endif
-
-.if ${PORT_OPTIONS:MCGI}
-CONFIGURE_ARGS+= --enable-cgi --with-cgi-bin=${ETCDIR}/cgi
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-PLIST_SUB+= CGI=""
-.else
-PLIST_SUB+= CGI="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MGAPCMON}
-CONFIGURE_ARGS+= --enable-gapcmon
-USE_GNOME+= gconf2
-PLIST_SUB+= GAPCMON=""
-CONFLICTS+= gapcmon-[0-9]*
-.else
-PLIST_SUB+= GAPCMON="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPCNET_DRV}
-CONFIGURE_ARGS+= --enable-pcnet
-.else
-CONFIGURE_ARGS+= --disable-pcnet
-.endif
-
-.if ${PORT_OPTIONS:MUSB}
-CONFIGURE_ARGS+= --enable-usb
-.endif
-
-.if ${PORT_OPTIONS:MSNMP_DRV}
-CONFIGURE_ARGS+= --enable-snmp
-.else
-CONFIGURE_ARGS+= --disable-snmp
-.endif
-
-.if ${PORT_OPTIONS:MSNMP_DRV_OLD}
-LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
-CONFIGURE_ARGS+= --enable-net-snmp
-.else
-CONFIGURE_ARGS+= --disable-net-snmp
-.endif
-
-.if ${PORT_OPTIONS:MTCP_WRAPPERS}
-CONFIGURE_ARGS+= --with-libwrap=yes
-.endif
-
-.if ${PORT_OPTIONS:MTEST_DRV}
-CONFIGURE_ARGS+= --enable-test
-.endif
+APCSMART_DRV_CONFIGURE_ENABLE= apcsmart
+APCDUMB_DRV_CONFIGURE_ENABLE= dumb
+CLIENT_ONLY_CONFIGURE_ON= --enable-net \
+ --disable-apcsmart --disable-dumb --disable-usb \
+ --disable-snmp --disable-test --disable-pcnet
+CGI_CONFIGURE_ENABLE= cgi
+CGI_CONFIGURE_ON= --with-cgi-bin=${ETCDIR}/cgi
+CGI_LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+GAPCMON_CONFIGURE_ENABLE= gapcmon
+GAPCMON_USE= GNOME=gconf2
+GPCMON_CONFLICTS= gapcmon-[0-9]*
+PCNET_DRV_CONFIGURE_ENABLE= pcnet
+USB_CONFIGURE_ENABLE= usb
+SNMP_DRV_CONFIGURE_ENABLE= snmp
+MODBUS_CONFIGURE_ENABLE= modbus
+SNMP_DRV_OLD_CONFIGURE_ENABLE= net-snmp
+SNMP_DRV_OLD_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
+TCP_WRAPPERS_CONFIGURE_WITH= libwrap=yes
+TEST_DRV_CONFIGURE_ENABLE= test
#CONFIGURE_ARGS+= --with-libwrap=yes
#CONFIGURE_ENV+= LIBS="-lcurses -lmenu"
#PLIST_SUB+= POWERFL=""
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS} || make(makesum)
+DISTFILES+= ${PORTNAME}.pdf:doc_sf,doc_bk
+.endif
+
pre-configure:
.if ${PORT_OPTIONS:MCLIENT_ONLY} && ( ${PORT_OPTIONS:MAPCSMART_DRV} || \
${PORT_OPTIONS:MAPCDUMB_DRV} || ${PORT_OPTIONS:MPCNET_DRV} || \
@@ -138,32 +90,16 @@ pre-configure:
.endif
post-install:
-# If the files presaved are identical with the new one, include them in
-# the package list, so the port can be removed without problems
- for na in apccontrol commfailure mainsback mastertimeout \
- changeme commok masterconnect onbattery; do \
- if [ -f ${ETCDIR}/$$na.orig ]; then \
- if cmp -s ${ETCDIR}/$$na ${ETCDIR}/$$na.orig; then \
- ${ECHO_CMD} "%%ETCDIR%%/$$na.orig" >> ${TMPPLIST}; \
- fi \
- fi; \
- done
@${ECHO_CMD} "@unexec if [ -d %D/${ETCDIR_REL} ]; then ${ECHO_CMD} \"If you are permanently removing this port, you should do a ``rm -rf ${ETCDIR}`` to remove config files left.\" | ${FMT} ; fi" >> ${TMPPLIST}
# Install sample startup script
-# If there is already a config file it is installed as ...new
for na in apcupsd.conf apcupsd.css hosts.conf multimon.conf; do \
- if [ -f ${ETCDIR}/$$na ]; then \
- if [ -f ${ETCDIR}/$$na.new ]; then \
- ${MV} ${ETCDIR}/$$na.new ${ETCDIR}/$$na.sample; \
- else \
- ${CP} ${ETCDIR}/$$na ${ETCDIR}/$$na.sample; \
- fi; \
- fi; \
+ if [ -f ${STAGEDIR}${ETCDIR}/$$na ]; then \
+ ${MV} ${STAGEDIR}${ETCDIR}/$$na ${STAGEDIR}${ETCDIR}/$$na.sample; \
+ fi \
done
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.pdf ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.pdf ${STAGEDIR}${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/apcupsd/distinfo b/sysutils/apcupsd/distinfo
index 9a61fe999e85..cfef79768d75 100644
--- a/sysutils/apcupsd/distinfo
+++ b/sysutils/apcupsd/distinfo
@@ -1,3 +1,4 @@
-SHA256 (apcupsd-3.14.10.tar.gz) = 0707b5ec9916fbde9e44eb8d18037c8d8f75dfd6aeef51aba5487e189eef2032
-SIZE (apcupsd-3.14.10.tar.gz) = 1336852
-SHA256 (apcupsd.pdf) = IGNORE
+SHA256 (apcupsd-3.14.12.tar.gz) = 1b4f703cb19cfdf44daf173dc8394cafd30fee0b30a0c75a7d19db622454a440
+SIZE (apcupsd-3.14.12.tar.gz) = 2014699
+SHA256 (apcupsd.pdf) = 9cfc69eb6cad27b702c888c3dd4e6a585463ac326f119a0ac7b317786d86c15c
+SIZE (apcupsd.pdf) = 1170356
diff --git a/sysutils/apcupsd/pkg-descr b/sysutils/apcupsd/pkg-descr
index 422201bdcb2a..e2a5afb2aab7 100644
--- a/sysutils/apcupsd/pkg-descr
+++ b/sysutils/apcupsd/pkg-descr
@@ -4,4 +4,4 @@ It can monitor and log the current power and battery status, perform
automatic shutdown, and can run in network mode in order to power down
other hosts on a LAN
-WWW: http://www.apcupsd.com
+WWW: http://www.apcupsd.com
diff --git a/sysutils/apcupsd/pkg-plist b/sysutils/apcupsd/pkg-plist
index fdb07702d8f9..462be247bb7b 100644
--- a/sysutils/apcupsd/pkg-plist
+++ b/sysutils/apcupsd/pkg-plist
@@ -2,20 +2,16 @@ sbin/apcupsd
sbin/apcaccess
sbin/apctest
sbin/smtp
-@unexec if cmp -s %D/%%ETCDIR%%/apcupsd.conf.sample %D/%%ETCDIR%%/apcupsd.conf; then rm -f %D/%%ETCDIR%%/apcupsd.conf; fi
-%%ETCDIR%%/apcupsd.conf.sample
+@sample %%ETCDIR%%/apcupsd.conf.sample
%%ETCDIR%%/apccontrol
%%ETCDIR%%/changeme
%%ETCDIR%%/commfailure
%%ETCDIR%%/commok
%%ETCDIR%%/onbattery
%%ETCDIR%%/offbattery
-%%CGI%%@unexec if cmp -s %D/%%ETCDIR%%/apcupsd.css.sample %D/%%ETCDIR%%/apcupsd.css; then rm -f %D/%%ETCDIR%%/apcupsd.css; fi
-%%CGI%%%%ETCDIR%%/apcupsd.css.sample
-%%CGI%%@unexec if cmp -s %D/%%ETCDIR%%/hosts.conf.sample %D/%%ETCDIR%%/hosts.conf; then rm -f %D/%%ETCDIR%%/hosts.conf; fi
-%%CGI%%%%ETCDIR%%/hosts.conf.sample
-%%CGI%%@unexec if cmp -s %D/%%ETCDIR%%/multimon.conf.sample %D/%%ETCDIR%%/multimon.conf; then rm -f %D/%%ETCDIR%%/multimon.conf; fi
-%%CGI%%%%ETCDIR%%/multimon.conf.sample
+%%CGI%%@sample %%ETCDIR%%/apcupsd.css.sample
+%%CGI%%@sample %%ETCDIR%%/hosts.conf.sample
+%%CGI%%@sample %%ETCDIR%%/multimon.conf.sample
%%CGI%%%%ETCDIR%%/cgi/multimon.cgi
%%CGI%%%%ETCDIR%%/cgi/upsfstats.cgi
%%CGI%%%%ETCDIR%%/cgi/upsimage.cgi
@@ -29,4 +25,9 @@ sbin/smtp
%%GAPCMON%%share/pixmaps/onbatt.png
%%GAPCMON%%share/pixmaps/online.png
%%GAPCMON%%share/pixmaps/unplugged.png
+man/man5/apcupsd.conf.5.gz
+man/man8/apcaccess.8.gz
+man/man8/apccontrol.8.gz
+man/man8/apctest.8.gz
+man/man8/apcupsd.8.gz
@dirrmtry %%ETCDIR%%