aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/qmail-autoresponder/Makefile8
-rw-r--r--mail/qmail-autoresponder/files/patch-main.c31
2 files changed, 32 insertions, 7 deletions
diff --git a/mail/qmail-autoresponder/Makefile b/mail/qmail-autoresponder/Makefile
index e00072f0745d..6d4f652c64b5 100644
--- a/mail/qmail-autoresponder/Makefile
+++ b/mail/qmail-autoresponder/Makefile
@@ -32,12 +32,6 @@ PLIST_SUB+= MYSQL="@comment "
ALL_TARGET= ${PROGS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
pre-build:
${ECHO_CMD} "${LOCALBASE}/include/bglibs" > ${WRKSRC}/conf-bgincs
${ECHO_CMD} "${LOCALBASE}/lib" > ${WRKSRC}/conf-bglibs
@@ -53,4 +47,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/qmail-autoresponder/files/patch-main.c b/mail/qmail-autoresponder/files/patch-main.c
new file mode 100644
index 000000000000..2ac8f8de9634
--- /dev/null
+++ b/mail/qmail-autoresponder/files/patch-main.c
@@ -0,0 +1,31 @@
+--- main.c.orig Mon Oct 13 16:17:08 2003
++++ main.c Mon Oct 13 16:17:41 2003
+@@ -244,17 +244,17 @@ static void copy_input(obuf* out)
+ }
+
+ static const char* usage_str =
+-"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s
+- -c Copy message into response
+- -n NUM Set the maximum number of replies (defaults to 1)
+- -s STR Add the subject to the autoresponse, prefixed by STR
+- -t TIME Set the time interval, in seconds (defaults to 1 hour)
+- -q Don't show error messages
+- -D Don't remove old response records
+- -N Don't send, just send autoresponse to standard output
+- If more than NUM messages are received from the same sender
+- within TIME seconds of each other, no response is sent.
+- This program must be run by qmail.
++"usage: %s [-cqDNT] [-n NUM] [-s STR] [-t TIME] %s\n\
++ -c Copy message into response\n\
++ -n NUM Set the maximum number of replies (defaults to 1)\n\
++ -s STR Add the subject to the autoresponse, prefixed by STR\n\
++ -t TIME Set the time interval, in seconds (defaults to 1 hour)\n\
++ -q Don't show error messages\n\
++ -D Don't remove old response records\n\
++ -N Don't send, just send autoresponse to standard output\n\
++ If more than NUM messages are received from the same sender\n\
++ within TIME seconds of each other, no response is sent.\n\
++ This program must be run by qmail.\n\
+ %s";
+
+ void usage(const char* msg)