aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/opendbx/Makefile2
-rw-r--r--databases/qt4-sqlite-plugin/Makefile1
-rw-r--r--databases/qt5-sqldrivers-sqlite2/Makefile2
-rw-r--r--databases/ruby-dbd_sqlite/Makefile1
-rw-r--r--databases/sqlcached/Makefile1
-rw-r--r--databases/sqlite2/Makefile10
-rw-r--r--databases/sqlite2/files/patch-Makefile.in30
-rw-r--r--databases/sqlite2/pkg-plist10
-rw-r--r--databases/sqliteodbc/Makefile1
-rw-r--r--deskutils/gtkjournal/Makefile2
-rw-r--r--devel/libleaftag/Makefile2
-rw-r--r--mail/dspam-devel/Makefile2
-rw-r--r--mail/dspam/Makefile2
-rw-r--r--mail/qsf/Makefile2
-rw-r--r--net/csync2/Makefile2
-rw-r--r--security/cyrus-sasl2/Makefile2
-rw-r--r--www/MT/Makefile1
-rw-r--r--www/mnogosearch/Makefile2
18 files changed, 31 insertions, 44 deletions
diff --git a/databases/opendbx/Makefile b/databases/opendbx/Makefile
index c753cd67b79e..8cc319779ca5 100644
--- a/databases/opendbx/Makefile
+++ b/databases/opendbx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opendbx
PORTVERSION= 1.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://www.linuxnetworks.de/opendbx/download/
diff --git a/databases/qt4-sqlite-plugin/Makefile b/databases/qt4-sqlite-plugin/Makefile
index dfde4a1832ab..7d1d32eab7bb 100644
--- a/databases/qt4-sqlite-plugin/Makefile
+++ b/databases/qt4-sqlite-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qt4-${DB}-plugin
DISTVERSION= ${QT4_VERSION}
+PORTREVISION= 1
CATEGORIES= databases
MAINTAINER= kde@FreeBSD.org
diff --git a/databases/qt5-sqldrivers-sqlite2/Makefile b/databases/qt5-sqldrivers-sqlite2/Makefile
index 09812cbcbed1..a5e3f0c25bc3 100644
--- a/databases/qt5-sqldrivers-sqlite2/Makefile
+++ b/databases/qt5-sqldrivers-sqlite2/Makefile
@@ -1,5 +1,7 @@
# $FreeBSD$
+PORTREVISION= 1
+
DB= SQLite2
DB_DESC= SQLite 2
diff --git a/databases/ruby-dbd_sqlite/Makefile b/databases/ruby-dbd_sqlite/Makefile
index c4bd5894fbd9..aa28ca0b9930 100644
--- a/databases/ruby-dbd_sqlite/Makefile
+++ b/databases/ruby-dbd_sqlite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dbd_sqlite
PORTVERSION= 0.1.2
+PORTREVISION= 1
CATEGORIES= databases ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= ruby-dbi
diff --git a/databases/sqlcached/Makefile b/databases/sqlcached/Makefile
index 75a751d2c022..daa76b7a7234 100644
--- a/databases/sqlcached/Makefile
+++ b/databases/sqlcached/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sqlcached
PORTVERSION= r6
+PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
diff --git a/databases/sqlite2/Makefile b/databases/sqlite2/Makefile
index b4f20bcdd6d5..3732da434b3c 100644
--- a/databases/sqlite2/Makefile
+++ b/databases/sqlite2/Makefile
@@ -3,18 +3,18 @@
PORTNAME= sqlite
PORTVERSION= 2.8.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://www.sqlite.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= SQL database engine in a C library
-USES= gmake pkgconfig readline
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USES= gmake libtool pkgconfig readline
USE_LDCONFIG= YES
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-hints=freebsd.hints
+CONFIGURE_ARGS= --with-hints=freebsd.hints
DOCSDIR= ${PREFIX}/share/doc/sqlite2
EXAMPLESDIR= ${PREFIX}/share/examples/sqlite2
@@ -55,7 +55,7 @@ MAKE_ENV+= TCL_VER=${TCL_VER}
post-patch:
@${REINPLACE_CMD} -e "s/tclsh \$$(TOP)/\$$(TCLSH) \$$(TOP)/g" \
- -e "s|\./libtool|${LIBTOOL}|g" ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.in
.if ${PORT_OPTIONS:MTCL} || !empty(PORT_OPTIONS:MDOCS)
@${ECHO} "config_TARGET_TCL_INC=\"-I${TCL_INCLUDEDIR}\"" \
> ${WRKSRC}/freebsd.hints
diff --git a/databases/sqlite2/files/patch-Makefile.in b/databases/sqlite2/files/patch-Makefile.in
index 84aed7e33ea1..ad1b8ff07b42 100644
--- a/databases/sqlite2/files/patch-Makefile.in
+++ b/databases/sqlite2/files/patch-Makefile.in
@@ -1,31 +1,7 @@
--- Makefile.in.orig Sat Mar 27 08:16:32 2004
+++ Makefile.in Sun Nov 21 04:32:00 2004
-@@ -188,12 +188,12 @@
-
- libsqlite.la: $(LIBOBJ)
- $(LTLINK) -o libsqlite.la $(LIBOBJ) ${RELEASE} -rpath @exec_prefix@/lib \
-- -version-info "8:6:8"
-+ -version-info "2:0:0"
-
- libtclsqlite.la: tclsqlite.lo libsqlite.la
- $(LTLINK) -o libtclsqlite.la tclsqlite.lo \
- libsqlite.la $(LIBTCL) -rpath @exec_prefix@/lib/sqlite \
-- -version-info "8:6:8"
-+ -version-info "2:0:0"
-
- sqlite@TARGET_EXEEXT@: $(TOP)/src/shell.c libsqlite.la sqlite.h
- $(LTLINK) $(READLINE_FLAGS) -o sqlite $(TOP)/src/shell.c \
-@@ -466,13 +466,19 @@
-
- install: sqlite libsqlite.la sqlite.h
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
-- $(LTINSTALL) libsqlite.la $(DESTDIR)$(exec_prefix)/lib
-+ $(INSTALL) .libs/libsqlite.a $(DESTDIR)$(exec_prefix)/lib
-+ $(INSTALL) .libs/libsqlite.so $(DESTDIR)$(exec_prefix)/lib
-+ $(INSTALL) .libs/libsqlite.so.2 $(DESTDIR)$(exec_prefix)/lib
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/bin
-- $(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
-+ $(INSTALL) .libs/sqlite $(DESTDIR)$(exec_prefix)/bin
+@@ -471,8 +471,12 @@
+ $(LTINSTALL) sqlite $(DESTDIR)$(exec_prefix)/bin
$(INSTALL) -d $(DESTDIR)$(prefix)/include
$(INSTALL) -m 0644 sqlite.h $(DESTDIR)$(prefix)/include
- $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib/pkgconfig;
@@ -35,7 +11,7 @@
+
+install-tcl: libtclsqlite.la
+ $(INSTALL) -d $(DESTDIR)$(prefix)/lib/sqlite
-+ $(INSTALL) .libs/libtclsqlite.so $(DESTDIR)$(prefix)/lib/sqlite
++ $(LTINSTALL) libtclsqlite.la $(DESTDIR)$(prefix)/lib/sqlite
clean:
rm -f *.lo *.la *.o sqlite@TARGET_EXEEXT@ libsqlite.la sqlite.h opcodes.*
diff --git a/databases/sqlite2/pkg-plist b/databases/sqlite2/pkg-plist
index 5fd9ba1adcf6..46f4c36a7f1c 100644
--- a/databases/sqlite2/pkg-plist
+++ b/databases/sqlite2/pkg-plist
@@ -2,10 +2,14 @@ bin/sqlite
include/sqlite.h
lib/libsqlite.a
lib/libsqlite.so
-lib/libsqlite.so.2
-libdata/pkgconfig/sqlite.pc
+lib/libsqlite.so.0
+lib/libsqlite.so.0.8.6
+%%WITH_TCLWRAPPER%%lib/sqlite/libtclsqlite.a
%%WITH_TCLWRAPPER%%lib/sqlite/libtclsqlite.so
+%%WITH_TCLWRAPPER%%lib/sqlite/libtclsqlite.so.0
+%%WITH_TCLWRAPPER%%lib/sqlite/libtclsqlite.so.0.8.6
%%WITH_TCLWRAPPER%%lib/sqlite/pkgIndex.tcl
-%%WITH_TCLWRAPPER%%@dirrm lib/sqlite
+libdata/pkgconfig/sqlite.pc
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.tcl
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%WITH_TCLWRAPPER%%@dirrm lib/sqlite
diff --git a/databases/sqliteodbc/Makefile b/databases/sqliteodbc/Makefile
index 4961807fd02e..fce9e346dc71 100644
--- a/databases/sqliteodbc/Makefile
+++ b/databases/sqliteodbc/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sqliteodbc
PORTVERSION= 0.998
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://www.ch-werner.de/sqliteodbc/
diff --git a/deskutils/gtkjournal/Makefile b/deskutils/gtkjournal/Makefile
index c0ccdd1ece12..80661e0b91a6 100644
--- a/deskutils/gtkjournal/Makefile
+++ b/deskutils/gtkjournal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gtkjournal
PORTVERSION= 0.3.5.b
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= deskutils gnome
MASTER_SITES= http://sourcefiles.org/Productivity_Tools/Diary/ \
LOCAL/beech
diff --git a/devel/libleaftag/Makefile b/devel/libleaftag/Makefile
index 9212abce0b19..4e5fd1c566d3 100644
--- a/devel/libleaftag/Makefile
+++ b/devel/libleaftag/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libleaftag
PORTVERSION= 0.3.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel deskutils
MASTER_SITES= http://releases.chipx86.com/leaftag/libleaftag/
diff --git a/mail/dspam-devel/Makefile b/mail/dspam-devel/Makefile
index c2f9393c98ac..e6ba92c98cb9 100644
--- a/mail/dspam-devel/Makefile
+++ b/mail/dspam-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dspam
PORTVERSION= ${PORTVER_MAJ}${SNAP_DATE}
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= # set later
diff --git a/mail/dspam/Makefile b/mail/dspam/Makefile
index c8c8fbb6ff6a..12ba5d5e0c17 100644
--- a/mail/dspam/Makefile
+++ b/mail/dspam/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dspam
PORTVERSION= 3.9.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= mail
MASTER_SITES= SF \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/mail/qsf/Makefile b/mail/qsf/Makefile
index 4f4c1e82a186..6bf18d47dd56 100644
--- a/mail/qsf/Makefile
+++ b/mail/qsf/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qsf
PORTVERSION= 1.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MASTER_SITES= SF
diff --git a/net/csync2/Makefile b/net/csync2/Makefile
index f6134f2f52ba..ebbdc29cbfc5 100644
--- a/net/csync2/Makefile
+++ b/net/csync2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csync2
PORTVERSION= 1.34
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= net
MASTER_SITES= http://oss.linbit.com/csync2/ \
http://people.freebsd.org/~aaron/distfiles/
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 73733e58ad5f..ec7d9b357630 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cyrus-sasl
PORTVERSION= 2.1.26
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
http://cyrusimap.org/releases/
diff --git a/www/MT/Makefile b/www/MT/Makefile
index c6508498c951..caa279d70cca 100644
--- a/www/MT/Makefile
+++ b/www/MT/Makefile
@@ -3,6 +3,7 @@
PORTNAME= MT
PORTVERSION= 5.2.10
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES?= www
MASTER_SITES?= http://www.movabletype.org/downloads/stable/\
diff --git a/www/mnogosearch/Makefile b/www/mnogosearch/Makefile
index 82b9bc84ecd8..35d1c75b7069 100644
--- a/www/mnogosearch/Makefile
+++ b/www/mnogosearch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mnogosearch
PORTVERSION= 3.4.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www databases
MASTER_SITES= http://www.mnogosearch.org/Download/ \
http://www.bayofrum.net/dist/${PORTNAME}/