aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile24
-rw-r--r--security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/distinfo2
-rw-r--r--security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr6
-rw-r--r--security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b8cd748390e2..a31281840584 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -509,6 +509,7 @@
SUBDIR += p5-Crypt-xDBM_File
SUBDIR += p5-CryptX
SUBDIR += p5-Dancer-Plugin-Auth-Extensible
+ SUBDIR += p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup
SUBDIR += p5-Dancer-Plugin-Passphrase
SUBDIR += p5-Data-Entropy
SUBDIR += p5-Data-Password
diff --git a/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
new file mode 100644
index 000000000000..01c12b3a7161
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/Makefile
@@ -0,0 +1,24 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Dancer-Plugin-Auth-Extensible-Provider-Usergroup
+PORTVERSION= 0.21
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hvo.pm@xs4all.nl
+COMMENT= Extensible authentication framework for Dancer apps
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Dancer>=1.3118:${PORTSDIR}/www/p5-Dancer \
+ p5-Dancer-Plugin-Auth-Extensible>=0:${PORTSDIR}/security/p5-Dancer-Plugin-Auth-Extensible \
+ p5-Dancer-Plugin-Passphrase>=0:${PORTSDIR}/security/p5-Dancer-Plugin-Passphrase
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/distinfo b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/distinfo
new file mode 100644
index 000000000000..6923eb3bd9d4
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Dancer-Plugin-Auth-Extensible-Provider-Usergroup-0.21.tar.gz) = 3917f4e0568d892e57a5941230ac261e66ae024bbc57f8e04bf1ceb1c46612a6
+SIZE (Dancer-Plugin-Auth-Extensible-Provider-Usergroup-0.21.tar.gz) = 10033
diff --git a/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr
new file mode 100644
index 000000000000..93553c706c44
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-descr
@@ -0,0 +1,6 @@
+authenticate as a member of a group
+
+Define that a user must be logged in and have the proper permissions to
+access a route
+
+WWW: https://metacpan.org/pod/Dancer::Plugin::Auth::Extensible::Provider::Usergroup
diff --git a/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist
new file mode 100644
index 000000000000..81bbbc67f27a
--- /dev/null
+++ b/security/p5-Dancer-Plugin-Auth-Extensible-Provider-Usergroup/pkg-plist
@@ -0,0 +1,5 @@
+%%PERL5_MAN3%%/Dancer::Plugin::Auth::Extensible::Provider::Usergroup.3.gz
+%%SITE_PERL%%/Dancer/Plugin/Auth/Extensible/Provider/Usergroup.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Auth/Extensible/Provider/Usergroup/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Auth/Extensible/Provider/Usergroup
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Dancer/Plugin/Auth/Extensible/Provider