aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/mysql-proxy/Makefile33
-rw-r--r--databases/mysql-proxy/distinfo3
-rw-r--r--databases/mysql-proxy/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 8f7237107053..b8634f4e5be7 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -134,6 +134,7 @@
SUBDIR += mysql-connector-odbc
SUBDIR += mysql-editor
SUBDIR += mysql-navigator
+ SUBDIR += mysql-proxy
SUBDIR += mysql-query-browser
SUBDIR += mysql2odbc
SUBDIR += mysql2pgsql
diff --git a/databases/mysql-proxy/Makefile b/databases/mysql-proxy/Makefile
new file mode 100644
index 000000000000..cfe1ae30eeb0
--- /dev/null
+++ b/databases/mysql-proxy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mysql-proxy
+# Date created: 2007-06-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql-proxy
+PORTVERSION= 0.5.0
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_MYSQL}
+MASTER_SITE_SUBDIR= MySQL-Proxy
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Monitor, analyze or transform the communication of MySQL
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent \
+ glib:${PORTSDIR}/devel/glib20
+
+CONFIGURE_ARGS+= --with-lua --with-mysql
+CONFIGURE_ENV+= CFLAGS="-I${LOCALBASE}/include -I${LUA_INCDIR}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${LUA_LIBDIR}" \
+ PKG_CONFIG_PATH="${LUA_PREFIX}/share/doc/${LUA_SUBDIR}/etc"
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget pkgconfig
+USE_ICONV= yes
+USE_LUA= 5.1+
+USE_MYSQL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}r8
+
+PLIST_FILES= sbin/mysql-proxy
+
+.include <bsd.port.mk>
diff --git a/databases/mysql-proxy/distinfo b/databases/mysql-proxy/distinfo
new file mode 100644
index 000000000000..41d78340908a
--- /dev/null
+++ b/databases/mysql-proxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (mysql-proxy-0.5.0.tar.gz) = f97aefed2fddd2353343a716d9c646c6
+SHA256 (mysql-proxy-0.5.0.tar.gz) = e1e1951d8bddfc0813aad1a3a93e63229dd9baa82833569cb44237cb769a2669
+SIZE (mysql-proxy-0.5.0.tar.gz) = 245007
diff --git a/databases/mysql-proxy/pkg-descr b/databases/mysql-proxy/pkg-descr
new file mode 100644
index 000000000000..c7189b6b8a00
--- /dev/null
+++ b/databases/mysql-proxy/pkg-descr
@@ -0,0 +1,7 @@
+MySQL Proxy is a simple program that sits between your client and
+MySQL server(s) that can monitor, analyze or transform their
+communication. Its flexibility allows for unlimited uses; common ones
+include: load balancing; failover; query analysis; query filtering and
+modification; and many more.
+
+WWW: http://forge.mysql.com/wiki/MySQL_Proxy