aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/py-slimmer/Makefile27
-rw-r--r--www/py-slimmer/distinfo3
-rw-r--r--www/py-slimmer/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ca45592c97f5..2a533cc1054a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -831,6 +831,7 @@
SUBDIR += py-prewikka
SUBDIR += py-pullparser
SUBDIR += py-scgi
+ SUBDIR += py-slimmer
SUBDIR += py-turbogears
SUBDIR += py-twistedWeb
SUBDIR += py-twistedWeb2
diff --git a/www/py-slimmer/Makefile b/www/py-slimmer/Makefile
new file mode 100644
index 000000000000..f10f8ff7c269
--- /dev/null
+++ b/www/py-slimmer/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-slimmer
+# Date created: 22 May 2006
+# Whom: Corey Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME= slimmer
+PORTVERSION= 0.1.21
+CATEGORIES= www python
+MASTER_SITES= http://www.issuetrackerproduct.com/Download/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= corsmith@gmail.com
+COMMENT= A whitespace optimizer for CSS, HTML and XHTML output
+
+WRKSRC= ${WRKDIR}/slimmer
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/slimmer.py \
+ %%PYTHON_SITELIBDIR%%/slimmer.pyc \
+ %%PYTHON_SITELIBDIR%%/slimmer.pyo
+
+.include <bsd.port.mk>
diff --git a/www/py-slimmer/distinfo b/www/py-slimmer/distinfo
new file mode 100644
index 000000000000..e93ffa368516
--- /dev/null
+++ b/www/py-slimmer/distinfo
@@ -0,0 +1,3 @@
+MD5 (slimmer-0.1.21.tgz) = 31cc521d4cb1a1f011d8973560c6f801
+SHA256 (slimmer-0.1.21.tgz) = 3be7f303b89d8b545f62c0bc4e6b5b996dbeb94406f0aa0846f1d6cff2173bc8
+SIZE (slimmer-0.1.21.tgz) = 15175
diff --git a/www/py-slimmer/pkg-descr b/www/py-slimmer/pkg-descr
new file mode 100644
index 000000000000..1e3cb197cf49
--- /dev/null
+++ b/www/py-slimmer/pkg-descr
@@ -0,0 +1,5 @@
+Python script to remove redundant info (whitespaces, comments, etc...) from
+XHTML, HTML and CSS. Useful in build systems to pre-compress static content
+in production.
+
+WWW: http://www.issuetrackerproduct.com/Documentation#slimmer