aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED2
-rw-r--r--devel/Makefile3
-rw-r--r--devel/pure-stldict/Makefile19
-rw-r--r--devel/pure-stldict/distinfo2
-rw-r--r--devel/pure-stldict/files/patch-Makefile27
-rw-r--r--devel/pure-stldict/pkg-descr6
-rw-r--r--devel/pure-stldict/pkg-plist7
-rw-r--r--devel/pure-stllib/Makefile48
-rw-r--r--devel/pure-stllib/distinfo2
-rw-r--r--devel/pure-stllib/files/patch-Makefile19
-rw-r--r--devel/pure-stllib/pkg-descr6
-rw-r--r--devel/pure-stllib/pkg-plist (renamed from devel/pure-stlvec/pkg-plist)9
-rw-r--r--devel/pure-stlvec/Makefile20
-rw-r--r--devel/pure-stlvec/distinfo2
-rw-r--r--devel/pure-stlvec/pkg-descr5
15 files changed, 86 insertions, 91 deletions
diff --git a/MOVED b/MOVED
index 5102cd39950e..bb744910b123 100644
--- a/MOVED
+++ b/MOVED
@@ -5172,3 +5172,5 @@ net-p2p/libtorrent-rasterbar-python-16|net-p2p/libtorrent-rasterbar-python|2013-
devel/ORBit||2013-11-07|Has expired: EOLed upstream for very long
x11/gnome-libs||2013-11-07|Has expired: EOLed upstream for very long
textproc/stardict2||2013-11-07|Has expired: Newer version available in ports: textproc/stardict3
+devel/pure-stldict|devel/pure-stllib|2013-11-07|Removed: Use devel/pure-stllib instead
+devel/pure-stlvec|devel/pure-stllib|2013-11-07|Removed: Use devel/pure-stllib instead
diff --git a/devel/Makefile b/devel/Makefile
index ecce7a945e5b..90de0ca8308d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3389,8 +3389,7 @@
SUBDIR += pure-ffi
SUBDIR += pure-gen
SUBDIR += pure-readline
- SUBDIR += pure-stldict
- SUBDIR += pure-stlvec
+ SUBDIR += pure-stllib
SUBDIR += pushmi
SUBDIR += pwlib
SUBDIR += py-Acquisition
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
deleted file mode 100644
index 637dba847e89..000000000000
--- a/devel/pure-stldict/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# Created by: Zhihao Yuan <lichray@gmail.com>
-# $FreeBSD$
-
-PORTNAME= pure-stldict
-PORTVERSION= 0.5
-PORTREVISION= 1
-CATEGORIES= devel
-
-MAINTAINER= lichray@gmail.com
-COMMENT= Pure interface to C++ STL map/unordered_map
-
-USE_PURE= yes
-
-USE_GCC= yes
-CXXFLAGS+= -std=c++0x -DHAVE_STD_IS_PERMUTATION
-
-NO_STAGE= yes
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
-.include <bsd.port.mk>
diff --git a/devel/pure-stldict/distinfo b/devel/pure-stldict/distinfo
deleted file mode 100644
index 32abfa4e1b58..000000000000
--- a/devel/pure-stldict/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pure/pure-stldict-0.5.tar.gz) = 3c12b4e15d79955e28d025d62525685e3bdbf4a07a3849cffad82eeb578e022b
-SIZE (pure/pure-stldict-0.5.tar.gz) = 64968
diff --git a/devel/pure-stldict/files/patch-Makefile b/devel/pure-stldict/files/patch-Makefile
deleted file mode 100644
index 2c2a86f2906e..000000000000
--- a/devel/pure-stldict/files/patch-Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
---- Makefile.orig 2011-11-15 20:34:11.000000000 -0600
-+++ Makefile 2011-12-05 23:59:07.886393453 -0600
-@@ -4,11 +4,11 @@ version = 0.1
-
- # platform-specific setup
-
--DLL = $(shell pkg-config pure --variable DLL)
--PIC = $(shell pkg-config pure --variable PIC)
--shared = $(shell pkg-config pure --variable shared)
-+DLL = .so
-+PIC = -fPIC
-+shared = -shared
-
--libdir = $(shell pkg-config pure --variable libdir)
-+libdir = $(prefix)/lib
- installdir = $(addprefix $(DESTDIR), $(libdir)/pure)
-
- MOD_CXXFLAGS = $(PIC) $(shell pkg-config pure --cflags) $(CXXFLAGS) $(CPPFLAGS)
-@@ -25,7 +25,7 @@ objects = $(patsubst %.cc, %$(DLL), $(cp
- all: $(objects)
-
- %$(DLL): %.cc
-- g++ $(shared) -o $@ $(MOD_CXXFLAGS) $< $(MOD_LDFLAGS) $(LIBS)
-+ $(CXX) $(shared) $(CPPFLAGS) $(CXXFLAGS) $(PIC) $< -o $@ $(LDFLAGS) -lpure $(LIBS)
-
- clean:
- rm -f *.o *$(DLL) examples/life *~
diff --git a/devel/pure-stldict/pkg-descr b/devel/pure-stldict/pkg-descr
deleted file mode 100644
index d481d4eee1b3..000000000000
--- a/devel/pure-stldict/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This package provides a light-weight, no frills interface to the C++
-dictionary containers map and unordered_map. The stldict module makes
-these data structures available in Pure land and equips them with a
-(more or less) idiomatic Pure container interface.
-
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-stldict.html
diff --git a/devel/pure-stldict/pkg-plist b/devel/pure-stldict/pkg-plist
deleted file mode 100644
index e20934799952..000000000000
--- a/devel/pure-stldict/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-lib/pure/hashdict.pure
-lib/pure/hashdict.so
-lib/pure/orddict.pure
-lib/pure/orddict.so
-lib/pure/stldict.pure
-lib/pure/stldictbase.pure
-@dirrm lib/pure
diff --git a/devel/pure-stllib/Makefile b/devel/pure-stllib/Makefile
new file mode 100644
index 000000000000..4daab78ba530
--- /dev/null
+++ b/devel/pure-stllib/Makefile
@@ -0,0 +1,48 @@
+# Created by: Zhihao Yuan <lichray@gmail.com>
+# $FreeBSD$
+
+PORTNAME= pure-stllib
+PORTVERSION= 0.5
+CATEGORIES= devel
+MASTER_SITES= https://cdn.bitbucket.org/purelang/pure-lang/downloads/
+DIST_SUBDIR= pure
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Pure interface to C++ STL map and vectors
+
+LICENSE= BSD
+
+USES= pure pkgconfig
+
+USE_GCC= yes
+
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= README
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= *.pdf
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS ?=|' \
+ ${WRKSRC}/Makefile ${WRKSRC}/pure-stlmap/Makefile ${WRKSRC}/pure-stlvec/Makefile
+ @${MKDIR} ${WRKSRC}/examples/
+ @${MV} ${WRKSRC}/pure-stlmap/examples/* \
+ ${WRKSRC}/pure-stlvec/examples/* ${WRKSRC}/examples/
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+
+.include <bsd.port.mk>
diff --git a/devel/pure-stllib/distinfo b/devel/pure-stllib/distinfo
new file mode 100644
index 000000000000..e863af0fdc8f
--- /dev/null
+++ b/devel/pure-stllib/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-stllib-0.5.tar.gz) = 555d68f0d38905a4804116e5a6f37e14bec5bad3264c7b2beab3ab68b07beaef
+SIZE (pure/pure-stllib-0.5.tar.gz) = 335191
diff --git a/devel/pure-stllib/files/patch-Makefile b/devel/pure-stllib/files/patch-Makefile
new file mode 100644
index 000000000000..cd59ecea62c1
--- /dev/null
+++ b/devel/pure-stllib/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- ./Makefile.orig 2013-08-28 18:17:41.000000000 +0200
++++ ./Makefile 2013-10-16 22:49:25.000000000 +0200
+@@ -17,12 +17,12 @@
+ MOD_CXXFLAGS = $(PIC) $(shell pkg-config pure --cflags) $(CFLAGS) $(CPPFLAGS)
+ MOD_LDFLAGS = $(shell pkg-config pure --libs) $(LDFLAGS)
+
+-CFLAGS = -g -O2 -Wall -Wextra
++CFLAGS ?= -g -O2 -Wall -Wextra
+
+-ifeq "$(DLL)" ".dylib"
++#ifeq "$(DLL)" ".dylib"
+ # OSX may need this (untested)
+-DLL_FLAGS = -install_name "$(libdir)/pure/$@"
+-endif
++#DLL_FLAGS = -install_name "$(libdir)/pure/$@"
++#endif
+
+ # Basic rules to build the module, clean, check, install and uninstall.
+
diff --git a/devel/pure-stllib/pkg-descr b/devel/pure-stllib/pkg-descr
new file mode 100644
index 000000000000..4ceb7e97cd1f
--- /dev/null
+++ b/devel/pure-stllib/pkg-descr
@@ -0,0 +1,6 @@
+pure-stllib is an "umbrella" package that contains a pair of Pure addons,
+pure-stlvec and pure-stlmap. These addons provide Pure interfaces to a
+selection of containers provided by the C++ Standard Library, specialized
+to hold pointers to arbitrary Pure expressions.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-stllib.html
diff --git a/devel/pure-stlvec/pkg-plist b/devel/pure-stllib/pkg-plist
index 81c3136d5516..f668b81a3352 100644
--- a/devel/pure-stlvec/pkg-plist
+++ b/devel/pure-stllib/pkg-plist
@@ -1,7 +1,14 @@
lib/pure/stlalgorithm.so
lib/pure/stlbase.pure
-lib/pure/stlcontainer.so
+lib/pure/stlbase.so
+lib/pure/stlhmap.pure
+lib/pure/stlhmap.so
+lib/pure/stlmap.pure
+lib/pure/stlmap.so
+lib/pure/stlmmap.pure
+lib/pure/stlmmap.so
lib/pure/stlvec.pure
+lib/pure/stlvec.so
lib/pure/stlvec/algorithms.pure
lib/pure/stlvec/heap.pure
lib/pure/stlvec/merge.pure
diff --git a/devel/pure-stlvec/Makefile b/devel/pure-stlvec/Makefile
deleted file mode 100644
index 4b2bbb148b74..000000000000
--- a/devel/pure-stlvec/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# Created by: Zhihao Yuan <lichray@gmail.com>
-# $FreeBSD$
-
-PORTNAME= pure-stlvec
-PORTVERSION= 0.2
-CATEGORIES= devel
-
-MAINTAINER= lichray@gmail.com
-COMMENT= Pure interface to C++ STL vector
-
-USE_PURE= yes
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|^PROD_FLAGS =.*|PROD_FLAGS = $$(CPPFLAGS) $$(CFLAGS) $$(LDFLAGS)|' \
- ${WRKSRC}/Makefile
-
-.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
-.include <bsd.port.mk>
diff --git a/devel/pure-stlvec/distinfo b/devel/pure-stlvec/distinfo
deleted file mode 100644
index 8f6520feba7c..000000000000
--- a/devel/pure-stlvec/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (pure/pure-stlvec-0.2.tar.gz) = 503bbc04f014c073d27d0bf2de3b57a889b5ceb9e01c4afbd82e8e5b5a2e4178
-SIZE (pure/pure-stlvec-0.2.tar.gz) = 149369
diff --git a/devel/pure-stlvec/pkg-descr b/devel/pure-stlvec/pkg-descr
deleted file mode 100644
index ceb59943320d..000000000000
--- a/devel/pure-stlvec/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Pure's interface to C++ vectors, specialized to hold pointers to arbitrary
-Pure expressions, and the C++ Standard Template Library algorithms that act
-on them.
-
-WWW: http://docs.pure-lang.googlecode.com/hg/pure-stlvec.html