aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/pecl-crack/Makefile27
-rw-r--r--security/pecl-crack/distinfo3
-rw-r--r--security/pecl-crack/pkg-descr20
-rw-r--r--security/pecl-crack/pkg-plist4
5 files changed, 55 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 0b82ad920824..268c086e5cff 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -482,6 +482,7 @@
SUBDIR += pear-LiveUser
SUBDIR += pear-LiveUser_Admin
SUBDIR += pear-Text_Password
+ SUBDIR += pecl-crack
SUBDIR += pecl-filter
SUBDIR += pecl-gnupg
SUBDIR += pecl-hash
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
new file mode 100644
index 000000000000..497389ff73be
--- /dev/null
+++ b/security/pecl-crack/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pecl-crack
+# Date created: 07 March 2006
+# Whom: Bill Moran <wmoran@collaborativefusion.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crack
+PORTVERSION= 0.4.1
+CATEGORIES= security www
+MASTER_SITES= http://www.osuweb.net/~ahaning/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= wmoran@collaborativefusion.com
+COMMENT= PECL extension to cracklib
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+PHP_MODNAME= crack
+
+WRKSRC= ${WRKDIR}/crack-0.4
+
+.include <bsd.port.mk>
diff --git a/security/pecl-crack/distinfo b/security/pecl-crack/distinfo
new file mode 100644
index 000000000000..891128943349
--- /dev/null
+++ b/security/pecl-crack/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/crack-0.4.1.tgz) = e64224cef6c8181f90cc669dae5dfe17
+SHA256 (PECL/crack-0.4.1.tgz) = d9ba43b3678fb46db0eee659d9e000e9bad682bc7702d33f6d7e293d7f6f08ad
+SIZE (PECL/crack-0.4.1.tgz) = 25143
diff --git a/security/pecl-crack/pkg-descr b/security/pecl-crack/pkg-descr
new file mode 100644
index 000000000000..0bafd3d442e5
--- /dev/null
+++ b/security/pecl-crack/pkg-descr
@@ -0,0 +1,20 @@
+This package provides an interface to the cracklib (libcrack) libraries that
+come standard on most unix-like distributions. This allows you to check
+passwords against dictionaries of words to ensure some minimal level of
+password security.
+
+From the cracklib README
+CrackLib makes literally hundreds of tests to determine whether you've
+chosen a bad password.
+
+* It tries to generate words from your username and gecos entry to tries
+to match them against what you've chosen.
+
+* It checks for simplistic patterns.
+
+* It then tries to reverse-engineer your password into a dictionary
+word, and searches for it in your dictionary.
+
+- after all that, it's PROBABLY a safe(-ish) password. 8-)
+
+WWW: http://pecl.php.net/package/crack
diff --git a/security/pecl-crack/pkg-plist b/security/pecl-crack/pkg-plist
new file mode 100644
index 000000000000..f90c25ba85bc
--- /dev/null
+++ b/security/pecl-crack/pkg-plist
@@ -0,0 +1,4 @@
+include/php/ext/crack
+include/php/ext/crack/config.h
+include/php/ext/crack/php_crack.h
+lib/php/20050922/crack.so