aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-3-devel/Makefile11
-rw-r--r--editors/openoffice-3-devel/files/Makefile.knobs11
-rw-r--r--editors/openoffice-3-devel/files/Makefile.others4
-rw-r--r--editors/openoffice.org-3-devel/Makefile11
-rw-r--r--editors/openoffice.org-3-devel/files/Makefile.knobs11
-rw-r--r--editors/openoffice.org-3-devel/files/Makefile.others4
6 files changed, 46 insertions, 6 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 3618be4c89f1..b048c6ec077d 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -40,6 +40,14 @@ USE_GNOME+= libidl
USE_GNOME= desktopfileutils gtk20
+.if defined(WITH_KDE4) && defined(WITH_KDE)
+.error "Cannot define WITH_KDE and WITH_KDE4 at the same time"
+.endif
+.if defined(WITH_KDE4)
+USE_KDE4= kdelibs
+USE_QT_VER= 4
+.endif
+
.if defined(WITH_KDE)
USE_KDELIBS_VER= 3
.endif
@@ -196,6 +204,9 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+.if defined(WITH_KDE4)
+ @${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
+.endif
do-build:
@cd ${WRKSRC} ; ./bootstrap
diff --git a/editors/openoffice-3-devel/files/Makefile.knobs b/editors/openoffice-3-devel/files/Makefile.knobs
index ebc227322996..a7f5653a88f1 100644
--- a/editors/openoffice-3-devel/files/Makefile.knobs
+++ b/editors/openoffice-3-devel/files/Makefile.knobs
@@ -7,6 +7,11 @@
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
+.if defined(WITH_KDE4)
+CONFIGURE_ARGS+= --enable-kde4 QT4DIR="${QT_PREFIX}" QT4LIB="${QT_LIBDIR}" QT4INC="${QT_INCDIR}" KDE4DIR="${KDE4_PREFIX}"
+QT_COMPONENTS+= moc
+.endif
+
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
.endif
@@ -29,7 +34,6 @@ CONFIGURE_ARGS+= --disable-gconf --disable-gnome-vfs
.else
USE_GNOME+= gconf2 gnomevfs2
.endif
-
.if defined(WITH_EVOLUTION2)
CONFIGURE_ARGS+= --enable-evolution2=yes
.else
@@ -89,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo to use Qt/KDE vclplug with"
@${ECHO} "make -DWITH_KDE"
.endif
+.if !defined(WITH_KDE4)
+ @${ECHO}
+ @${ECHO} "You can compile OOo to use Qt/KDE4 vclplug with"
+ @${ECHO} "make -DWITH_KDE4"
+.endif
.if !defined(WITH_EVOLUTION2)
@${ECHO}
@${ECHO} "You can compile OOo with evolution2 support by"
diff --git a/editors/openoffice-3-devel/files/Makefile.others b/editors/openoffice-3-devel/files/Makefile.others
index 8c7fd8f348e5..d0bd83eef195 100644
--- a/editors/openoffice-3-devel/files/Makefile.others
+++ b/editors/openoffice-3-devel/files/Makefile.others
@@ -11,7 +11,7 @@
package-rename:
@${ECHO_MSG} "===> Rename package for OpenOffice.org mirror upload";
- @${MV} ${PKGFILE} \
+ @${LN} ${PKGFILE} \
${WRKDIR}/../${PACKAGE_BASENAME}_install_${LOCALIZED_LANG}${PKG_SUFX}
package-canonical:
@@ -57,7 +57,7 @@ languagepack:
@${RM} -fr ${WRKDIR}/langpack_tmp
@${MKDIR} ${WRKDIR}/langpack_tmp
.if defined (LOCALIZED_LANG)
- @cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/OpenOffice_languagepack/bsd/install/${LOCALIZED_LANG}/freebsd/ ; ls openoffice*.t?z > ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK
+ @cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/OpenOffice_languagepack/bsd/install/${LOCALIZED_LANG}/freebsd/ ; ls openoffice*.t?z ooobasis*.t?z > ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK
@cd ${WRKDIR}/langpack_tmp ; \
for i in `${CAT} ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK`; do \
${ECHO_CMD} "extracting $$i" ; \
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 3618be4c89f1..b048c6ec077d 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -40,6 +40,14 @@ USE_GNOME+= libidl
USE_GNOME= desktopfileutils gtk20
+.if defined(WITH_KDE4) && defined(WITH_KDE)
+.error "Cannot define WITH_KDE and WITH_KDE4 at the same time"
+.endif
+.if defined(WITH_KDE4)
+USE_KDE4= kdelibs
+USE_QT_VER= 4
+.endif
+
.if defined(WITH_KDE)
USE_KDELIBS_VER= 3
.endif
@@ -196,6 +204,9 @@ post-extract:
pre-configure:
#Workaround for gperf. #i85469#
@${LN} -sf ${LOCALBASE}/bin/gperf ${WRKSRC}/solenv/bin/gperf
+.if defined(WITH_KDE4)
+ @${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/solenv/bin/moc
+.endif
do-build:
@cd ${WRKSRC} ; ./bootstrap
diff --git a/editors/openoffice.org-3-devel/files/Makefile.knobs b/editors/openoffice.org-3-devel/files/Makefile.knobs
index ebc227322996..a7f5653a88f1 100644
--- a/editors/openoffice.org-3-devel/files/Makefile.knobs
+++ b/editors/openoffice.org-3-devel/files/Makefile.knobs
@@ -7,6 +7,11 @@
CONFIGURE_ARGS+= --with-jdk-home="${JAVA_HOME}" --with-ant-home="${LOCALBASE}/share/java/apache-ant"
+.if defined(WITH_KDE4)
+CONFIGURE_ARGS+= --enable-kde4 QT4DIR="${QT_PREFIX}" QT4LIB="${QT_LIBDIR}" QT4INC="${QT_INCDIR}" KDE4DIR="${KDE4_PREFIX}"
+QT_COMPONENTS+= moc
+.endif
+
.if defined(WITH_KDE)
CONFIGURE_ARGS+= --enable-kde QTDIR="${QT_PREFIX}"
.endif
@@ -29,7 +34,6 @@ CONFIGURE_ARGS+= --disable-gconf --disable-gnome-vfs
.else
USE_GNOME+= gconf2 gnomevfs2
.endif
-
.if defined(WITH_EVOLUTION2)
CONFIGURE_ARGS+= --enable-evolution2=yes
.else
@@ -89,6 +93,11 @@ pre-fetch:
@${ECHO} "You can compile OOo to use Qt/KDE vclplug with"
@${ECHO} "make -DWITH_KDE"
.endif
+.if !defined(WITH_KDE4)
+ @${ECHO}
+ @${ECHO} "You can compile OOo to use Qt/KDE4 vclplug with"
+ @${ECHO} "make -DWITH_KDE4"
+.endif
.if !defined(WITH_EVOLUTION2)
@${ECHO}
@${ECHO} "You can compile OOo with evolution2 support by"
diff --git a/editors/openoffice.org-3-devel/files/Makefile.others b/editors/openoffice.org-3-devel/files/Makefile.others
index 8c7fd8f348e5..d0bd83eef195 100644
--- a/editors/openoffice.org-3-devel/files/Makefile.others
+++ b/editors/openoffice.org-3-devel/files/Makefile.others
@@ -11,7 +11,7 @@
package-rename:
@${ECHO_MSG} "===> Rename package for OpenOffice.org mirror upload";
- @${MV} ${PKGFILE} \
+ @${LN} ${PKGFILE} \
${WRKDIR}/../${PACKAGE_BASENAME}_install_${LOCALIZED_LANG}${PKG_SUFX}
package-canonical:
@@ -57,7 +57,7 @@ languagepack:
@${RM} -fr ${WRKDIR}/langpack_tmp
@${MKDIR} ${WRKDIR}/langpack_tmp
.if defined (LOCALIZED_LANG)
- @cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/OpenOffice_languagepack/bsd/install/${LOCALIZED_LANG}/freebsd/ ; ls openoffice*.t?z > ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK
+ @cd ${WRKSRC}/instsetoo_native/unxfbsd?.pro/OpenOffice_languagepack/bsd/install/${LOCALIZED_LANG}/freebsd/ ; ls openoffice*.t?z ooobasis*.t?z > ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK
@cd ${WRKDIR}/langpack_tmp ; \
for i in `${CAT} ${WRKDIR}/${LOCALIZED_LANG}_LANGPACK`; do \
${ECHO_CMD} "extracting $$i" ; \