aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c13
-rw-r--r--accessibility/gnopernicus/files/patch-srcore_srbrl.c51
-rw-r--r--accessibility/gnopernicus/files/patch-srcore_srmain.c26
-rw-r--r--accessibility/gok/files/patch-gok_gok-keyboard.c13
-rw-r--r--security/gnome-keyring-manager/Makefile32
-rw-r--r--security/gnome-keyring-manager/distinfo2
-rw-r--r--security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-keyring-manager.c30
-rw-r--r--security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-util.c20
-rw-r--r--security/gnome-keyring-manager/pkg-descr1
-rw-r--r--security/gnome-keyring-manager/pkg-plist7
-rw-r--r--security/gnomekeyringmanager/Makefile32
-rw-r--r--security/gnomekeyringmanager/distinfo2
-rw-r--r--security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-keyring-manager.c30
-rw-r--r--security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-util.c20
-rw-r--r--security/gnomekeyringmanager/pkg-descr1
-rw-r--r--security/gnomekeyringmanager/pkg-plist7
16 files changed, 287 insertions, 0 deletions
diff --git a/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c b/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c
new file mode 100644
index 000000000000..3a2d38735abb
--- /dev/null
+++ b/accessibility/gnopernicus/files/patch-braille_libbrl_brlxml.c
@@ -0,0 +1,13 @@
+--- braille/libbrl/brlxml.c.orig Tue Aug 3 14:50:31 2004
++++ braille/libbrl/brlxml.c Tue Aug 3 14:50:48 2004
+@@ -730,9 +730,9 @@
+ /* fprintf (stderr, "\n attr_val; %s", *attrs); */
+ if (g_strcasecmp ((gchar*)*attrs, "mode") == 0)
+ {
+- ++attrs;
+ gint16 new_offset = 0;
+ gshort sign = 1;
++ ++attrs;
+
+ attr_val = g_strdup ((gchar*)*attrs);
+ tattr_val = g_strdup (attr_val);
diff --git a/accessibility/gnopernicus/files/patch-srcore_srbrl.c b/accessibility/gnopernicus/files/patch-srcore_srbrl.c
new file mode 100644
index 000000000000..474f3f8049a4
--- /dev/null
+++ b/accessibility/gnopernicus/files/patch-srcore_srbrl.c
@@ -0,0 +1,51 @@
+--- srcore/srbrl.c.orig Wed Jul 14 20:51:31 2004
++++ srcore/srbrl.c Wed Jul 14 20:55:57 2004
+@@ -723,6 +723,12 @@
+ static void
+ src_braille_load_values (SRCBraille *braille)
+ {
++ gint default_pos_sensor;
++ gint default_opt_sensor;
++ gchar *default_braille_transaltion_table;
++ gchar *default_braille_style;
++ gchar *default_braille_cursor_style;
++
+ sru_assert (braille);
+
+ if (!braille->device)
+@@ -749,7 +755,7 @@
+ }
+ }
+
+- gchar *default_braille_transaltion_table = DEFAULT_BRAILLE_TRANSLATION;
++ *default_braille_transaltion_table = DEFAULT_BRAILLE_TRANSLATION;
+ GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_TRANSLATION, CFGT_STRING,
+ &braille->translation_table,
+ default_braille_transaltion_table);
+@@ -761,22 +767,22 @@
+ }
+
+
+- gchar *default_braille_style = DEFAULT_BRAILLE_STYLE;
++ *default_braille_style = DEFAULT_BRAILLE_STYLE;
+ GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_STYLE, CFGT_STRING,
+ &braille->style,
+ default_braille_style);
+
+- gchar *default_braille_cursor_style = DEFAULT_BRAILLE_CURSOR_STYLE;
++ *default_braille_cursor_style = DEFAULT_BRAILLE_CURSOR_STYLE;
+ GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_CURSOR_STYLE, CFGT_STRING,
+ &braille->cursor_style,
+ default_braille_cursor_style);
+
+- gint default_pos_sensor = DEFAULT_BRAILLE_POSITION_SENSOR;
++ default_pos_sensor = DEFAULT_BRAILLE_POSITION_SENSOR;
+ GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_POSITION_SENSOR, CFGT_INT,
+ &braille->position_sensor,
+ &default_pos_sensor);
+
+- gint default_opt_sensor = DEFAULT_BRAILLE_OPTICAL_SENSOR;
++ default_opt_sensor = DEFAULT_BRAILLE_OPTICAL_SENSOR;
+ GET_BRAILLE_CONFIG_DATA_WITH_DEFAULT (BRAILLE_OPTICAL_SENSOR, CFGT_INT,
+ &braille->optical_sensor,
+ &default_opt_sensor);
diff --git a/accessibility/gnopernicus/files/patch-srcore_srmain.c b/accessibility/gnopernicus/files/patch-srcore_srmain.c
new file mode 100644
index 000000000000..7b113f5bad80
--- /dev/null
+++ b/accessibility/gnopernicus/files/patch-srcore_srmain.c
@@ -0,0 +1,26 @@
+--- srcore/srmain.c.orig Sun May 30 03:08:45 2004
++++ srcore/srmain.c Sun May 30 03:09:28 2004
+@@ -602,9 +602,10 @@
+ sru_assert (config->key);
+ if (strcmp (config->key, BRAILLE_DEVICE) == 0)
+ {
++ gboolean rv;
+ sru_assert (config->newvalue && config->type == CFGT_STRING);
+
+- gboolean rv = src_braille_set_device ((gchar*)config->newvalue);
++ rv = src_braille_set_device ((gchar*)config->newvalue);
+ if (!rv)
+ {
+ sru_message ("SR: process config changed for braille: brl_device did not change!!!");
+@@ -636,9 +637,10 @@
+ }
+ else if (strcmp (config->key, BRAILLE_TRANSLATION) == 0)
+ {
++ gboolean rv;
+ sru_assert (config->type == CFGT_STRING && config->newvalue);
+
+- gboolean rv = src_braille_set_translation_table ((gchar*)config->newvalue);
++ rv = src_braille_set_translation_table ((gchar*)config->newvalue);
+
+ if (!rv)
+ {
diff --git a/accessibility/gok/files/patch-gok_gok-keyboard.c b/accessibility/gok/files/patch-gok_gok-keyboard.c
new file mode 100644
index 000000000000..c85f8da0fcb0
--- /dev/null
+++ b/accessibility/gok/files/patch-gok_gok-keyboard.c
@@ -0,0 +1,13 @@
+--- gok/gok-keyboard.c.orig Fri Nov 5 16:18:02 2004
++++ gok/gok-keyboard.c Fri Nov 5 16:18:49 2004
+@@ -2519,8 +2519,9 @@
+ else if ((pKeyboard->search_type == GOK_SPY_SEARCH_ACTIONABLE) && !did_actionkeys)
+ {
+ gint action_count, i;
++ AccessibleAction *action;
+ did_actionkeys = TRUE;
+- AccessibleAction *action =
++ action =
+ Accessible_getAction (pNodeAccessible->paccessible);
+ if (!action)
+ break;
diff --git a/security/gnome-keyring-manager/Makefile b/security/gnome-keyring-manager/Makefile
new file mode 100644
index 000000000000..3dfdfa06ed17
--- /dev/null
+++ b/security/gnome-keyring-manager/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomekeyringmanager
+# Date created: 2004 12 July
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomekeyringmanager
+PORTVERSION= 0.0.3
+PORTREVISION= 1
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-keyring-manager/0.0
+DISTNAME= gnome-keyring-manager-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME keyring manager
+
+LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnomekeyring
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gnome-keyring-manager.schemas
+
+.include <bsd.port.mk>
diff --git a/security/gnome-keyring-manager/distinfo b/security/gnome-keyring-manager/distinfo
new file mode 100644
index 000000000000..375275d3a8d6
--- /dev/null
+++ b/security/gnome-keyring-manager/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gnome-keyring-manager-0.0.3.tar.bz2) = 3f6e2f3ebe973317eeface0b8ffff090
+SIZE (gnome2/gnome-keyring-manager-0.0.3.tar.bz2) = 304545
diff --git a/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-keyring-manager.c b/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-keyring-manager.c
new file mode 100644
index 000000000000..763ead9f9ebe
--- /dev/null
+++ b/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-keyring-manager.c
@@ -0,0 +1,30 @@
+--- src/gnome-keyring-manager-keyring-manager.c.orig Mon Jul 12 23:14:24 2004
++++ src/gnome-keyring-manager-keyring-manager.c Mon Jul 12 23:15:32 2004
+@@ -240,6 +240,13 @@
+ GtkWidget *menubar;
+ GtkWidget *menu_item;
+ GError *error;
++ SetColumnPrefsData toggle[] =
++ {
++ { COLUMN_LOCK_ON_IDLE, "ToggleLockOnIdle", "lock-on-idle" },
++ { COLUMN_LOCK_TIMEOUT, "ToggleLockTimeout", "lock-timeout" },
++ { COLUMN_MTIME, "ToggleModificationTime", "mtime" },
++ { COLUMN_CTIME, "ToggleCreationTime", "ctime" }
++ };
+
+ manager->priv = g_new0 (GKMKeyringManagerPrivate, 1);
+
+@@ -329,13 +336,6 @@
+ g_signal_connect (manager->priv->tree_view, "button-press-event", G_CALLBACK (keyring_tree_button_press_callback), manager);
+ g_signal_connect (manager->priv->tree_view, "popup-menu", G_CALLBACK (keyring_tree_context_menu_callback), manager);
+
+- SetColumnPrefsData toggle[] =
+- {
+- { COLUMN_LOCK_ON_IDLE, "ToggleLockOnIdle", "lock-on-idle" },
+- { COLUMN_LOCK_TIMEOUT, "ToggleLockTimeout", "lock-timeout" },
+- { COLUMN_MTIME, "ToggleModificationTime", "mtime" },
+- { COLUMN_CTIME, "ToggleCreationTime", "ctime" }
+- };
+ manager->priv->gconf_cnxn_ids =
+ set_column_visibility_preferences (toggle,
+ G_N_ELEMENTS (toggle),
diff --git a/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-util.c b/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-util.c
new file mode 100644
index 000000000000..946f458084d7
--- /dev/null
+++ b/security/gnome-keyring-manager/files/patch-src::gnome-keyring-manager-util.c
@@ -0,0 +1,20 @@
+--- src/gnome-keyring-manager-util.c.orig Mon Jul 12 23:12:27 2004
++++ src/gnome-keyring-manager-util.c Mon Jul 12 23:13:00 2004
+@@ -189,8 +189,6 @@
+ GtkIconTheme *icon_theme;
+ GdkPixbuf *pixbuf;
+
+- g_return_val_if_fail (GTK_IS_WINDOW (transient_parent), NULL);
+-
+ const char *authors[] = {
+ "Fernando Herrera <fherrera@onirica.com>",
+ "Mariano Su\303\241rez-Alvarez <mariano@gnome.org>",
+@@ -201,6 +199,8 @@
+ };
+ const char *translator_credits = _("translator_credits");
+
++ g_return_val_if_fail (GTK_IS_WINDOW (transient_parent), NULL);
++
+ icon_theme = gtk_icon_theme_get_default ();
+ pixbuf = gtk_icon_theme_load_icon (icon_theme, "stock_keyring", 48, 0, NULL);
+
diff --git a/security/gnome-keyring-manager/pkg-descr b/security/gnome-keyring-manager/pkg-descr
new file mode 100644
index 000000000000..c6881629b867
--- /dev/null
+++ b/security/gnome-keyring-manager/pkg-descr
@@ -0,0 +1 @@
+This a keyring management program for the GNOME Desktop.
diff --git a/security/gnome-keyring-manager/pkg-plist b/security/gnome-keyring-manager/pkg-plist
new file mode 100644
index 000000000000..c03448de7083
--- /dev/null
+++ b/security/gnome-keyring-manager/pkg-plist
@@ -0,0 +1,7 @@
+bin/gnome-keyring-manager
+share/gnome/applications/gnome-keyring-manager.desktop
+share/locale/cs/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/en_GB/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/nl/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/sv/LC_MESSAGES/gnome-keyring-manager.mo
diff --git a/security/gnomekeyringmanager/Makefile b/security/gnomekeyringmanager/Makefile
new file mode 100644
index 000000000000..3dfdfa06ed17
--- /dev/null
+++ b/security/gnomekeyringmanager/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomekeyringmanager
+# Date created: 2004 12 July
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomekeyringmanager
+PORTVERSION= 0.0.3
+PORTREVISION= 1
+CATEGORIES= security gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-keyring-manager/0.0
+DISTNAME= gnome-keyring-manager-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME keyring manager
+
+LIB_DEPENDS= gnome-keyring:${PORTSDIR}/security/gnomekeyring
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= gnome-keyring-manager.schemas
+
+.include <bsd.port.mk>
diff --git a/security/gnomekeyringmanager/distinfo b/security/gnomekeyringmanager/distinfo
new file mode 100644
index 000000000000..375275d3a8d6
--- /dev/null
+++ b/security/gnomekeyringmanager/distinfo
@@ -0,0 +1,2 @@
+MD5 (gnome2/gnome-keyring-manager-0.0.3.tar.bz2) = 3f6e2f3ebe973317eeface0b8ffff090
+SIZE (gnome2/gnome-keyring-manager-0.0.3.tar.bz2) = 304545
diff --git a/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-keyring-manager.c b/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-keyring-manager.c
new file mode 100644
index 000000000000..763ead9f9ebe
--- /dev/null
+++ b/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-keyring-manager.c
@@ -0,0 +1,30 @@
+--- src/gnome-keyring-manager-keyring-manager.c.orig Mon Jul 12 23:14:24 2004
++++ src/gnome-keyring-manager-keyring-manager.c Mon Jul 12 23:15:32 2004
+@@ -240,6 +240,13 @@
+ GtkWidget *menubar;
+ GtkWidget *menu_item;
+ GError *error;
++ SetColumnPrefsData toggle[] =
++ {
++ { COLUMN_LOCK_ON_IDLE, "ToggleLockOnIdle", "lock-on-idle" },
++ { COLUMN_LOCK_TIMEOUT, "ToggleLockTimeout", "lock-timeout" },
++ { COLUMN_MTIME, "ToggleModificationTime", "mtime" },
++ { COLUMN_CTIME, "ToggleCreationTime", "ctime" }
++ };
+
+ manager->priv = g_new0 (GKMKeyringManagerPrivate, 1);
+
+@@ -329,13 +336,6 @@
+ g_signal_connect (manager->priv->tree_view, "button-press-event", G_CALLBACK (keyring_tree_button_press_callback), manager);
+ g_signal_connect (manager->priv->tree_view, "popup-menu", G_CALLBACK (keyring_tree_context_menu_callback), manager);
+
+- SetColumnPrefsData toggle[] =
+- {
+- { COLUMN_LOCK_ON_IDLE, "ToggleLockOnIdle", "lock-on-idle" },
+- { COLUMN_LOCK_TIMEOUT, "ToggleLockTimeout", "lock-timeout" },
+- { COLUMN_MTIME, "ToggleModificationTime", "mtime" },
+- { COLUMN_CTIME, "ToggleCreationTime", "ctime" }
+- };
+ manager->priv->gconf_cnxn_ids =
+ set_column_visibility_preferences (toggle,
+ G_N_ELEMENTS (toggle),
diff --git a/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-util.c b/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-util.c
new file mode 100644
index 000000000000..946f458084d7
--- /dev/null
+++ b/security/gnomekeyringmanager/files/patch-src::gnome-keyring-manager-util.c
@@ -0,0 +1,20 @@
+--- src/gnome-keyring-manager-util.c.orig Mon Jul 12 23:12:27 2004
++++ src/gnome-keyring-manager-util.c Mon Jul 12 23:13:00 2004
+@@ -189,8 +189,6 @@
+ GtkIconTheme *icon_theme;
+ GdkPixbuf *pixbuf;
+
+- g_return_val_if_fail (GTK_IS_WINDOW (transient_parent), NULL);
+-
+ const char *authors[] = {
+ "Fernando Herrera <fherrera@onirica.com>",
+ "Mariano Su\303\241rez-Alvarez <mariano@gnome.org>",
+@@ -201,6 +199,8 @@
+ };
+ const char *translator_credits = _("translator_credits");
+
++ g_return_val_if_fail (GTK_IS_WINDOW (transient_parent), NULL);
++
+ icon_theme = gtk_icon_theme_get_default ();
+ pixbuf = gtk_icon_theme_load_icon (icon_theme, "stock_keyring", 48, 0, NULL);
+
diff --git a/security/gnomekeyringmanager/pkg-descr b/security/gnomekeyringmanager/pkg-descr
new file mode 100644
index 000000000000..c6881629b867
--- /dev/null
+++ b/security/gnomekeyringmanager/pkg-descr
@@ -0,0 +1 @@
+This a keyring management program for the GNOME Desktop.
diff --git a/security/gnomekeyringmanager/pkg-plist b/security/gnomekeyringmanager/pkg-plist
new file mode 100644
index 000000000000..c03448de7083
--- /dev/null
+++ b/security/gnomekeyringmanager/pkg-plist
@@ -0,0 +1,7 @@
+bin/gnome-keyring-manager
+share/gnome/applications/gnome-keyring-manager.desktop
+share/locale/cs/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/en_GB/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/nl/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-keyring-manager.mo
+share/locale/sv/LC_MESSAGES/gnome-keyring-manager.mo