aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-fm/thunar-vfs/Makefile10
-rw-r--r--x11-toolkits/Xaw3d/Makefile14
2 files changed, 12 insertions, 12 deletions
diff --git a/x11-fm/thunar-vfs/Makefile b/x11-fm/thunar-vfs/Makefile
index 2120a4d30162..347daf8c2112 100644
--- a/x11-fm/thunar-vfs/Makefile
+++ b/x11-fm/thunar-vfs/Makefile
@@ -22,10 +22,10 @@ USE_AUTOTOOLS= libtool
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack glib20 gtk20 intltool intlhack
+USE_GNOME= glib20 gtk20 intltool intlhack
USE_XFCE= configenv libutil libexo
USE_XORG= x11
-USES= pkgconfig
+USES= pkgconfig pathfix
CONFIGURE_ARGS= --disable-debug
@@ -35,10 +35,10 @@ OPTIONS_DEFAULT= NLS HAL DBUS STARTUP APIDOCS
APIDOCS_DESC= Install api documentation
STARTUP_DESC= Enable startup notification support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else
@@ -86,4 +86,4 @@ PLIST_SUB+= APIDOCS="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index 0887b7de98b2..9ef8bb76f9f5 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= ftp://ftp.visi.com/users/hawkeyd/X/ \
ftp.slackware.com/pub/slackware/slackware_source/x/xaw3d/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A 3-D Athena Widget set that looks like Motif
+COMMENT= 3-D Athena Widget set that looks like Motif
LICENSE= MIT
@@ -23,10 +23,10 @@ SUB_FILES= pkg-message
XAWVER= 8
SUB_LIST= XAWVER="${XAWVER}"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
-USE_GETTEXT= yes
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -35,7 +35,7 @@ PLIST_SUB+= NLS="@comment "
post-extract:
${MKDIR} ${WRKSRC}/X11/Xaw3d
cd ${WRKSRC}/X11/Xaw3d; ${LN} -sf ../../*.h .
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e '/LINTLIBS =/s/=.*/=/' \
-e '/#ifdef XawI18nDefines/s//#if 0/' \
${WRKSRC}/Imakefile
@@ -49,10 +49,10 @@ post-configure:
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.XAW3D ${DOCSDIR}/
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>