aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--japanese/spamassassin/Makefile2
-rw-r--r--mail/spamassassin/Makefile4
-rw-r--r--mail/spamassassin/files/patch-bug740423
3 files changed, 26 insertions, 3 deletions
diff --git a/japanese/spamassassin/Makefile b/japanese/spamassassin/Makefile
index 76f781f5f359..4b585fb06631 100644
--- a/japanese/spamassassin/Makefile
+++ b/japanese/spamassassin/Makefile
@@ -1,7 +1,7 @@
# Created by: TAOKA Fumiyoshi
# $FreeBSD$
-PORTREVISION= 7
+PORTREVISION= 9
CATEGORIES= japanese mail perl5
PKGNAMEPREFIX= ja-
diff --git a/mail/spamassassin/Makefile b/mail/spamassassin/Makefile
index 0b4db73bd88a..dcb7d756a695 100644
--- a/mail/spamassassin/Makefile
+++ b/mail/spamassassin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spamassassin
PORTVERSION= 3.4.1
-PORTREVISION?= 10 # also bump japanese/spamassassin
+PORTREVISION?= 11 # also bump japanese/spamassassin
CATEGORIES?= mail perl5
MASTER_SITES= APACHE/spamassassin/source CPAN/Mail
DISTNAME= Mail-SpamAssassin-${PORTVERSION}
@@ -55,7 +55,7 @@ OPTIONS_GROUP_DATABASE= MYSQL PGSQL
OPTIONS_GROUP_PLUGINS= DCC DKIM PYZOR RAZOR RELAY_COUNTRY SPF_QUERY
OPTIONS_SINGLE= GPG
OPTIONS_SINGLE_GPG= GNUPG_NONE GNUPG GNUPG2
-OPTIONS_DEFAULT= AS_ROOT GNUPG SSL UPDATE_AND_COMPILE
+OPTIONS_DEFAULT= AS_ROOT DKIM GNUPG SSL UPDATE_AND_COMPILE SPF_QUERY
AS_ROOT_DESC= Run spamd as root (recommended)
diff --git a/mail/spamassassin/files/patch-bug7404 b/mail/spamassassin/files/patch-bug7404
new file mode 100644
index 000000000000..b370d6e0b80f
--- /dev/null
+++ b/mail/spamassassin/files/patch-bug7404
@@ -0,0 +1,23 @@
+--- lib/Mail/SpamAssassin/PerMsgStatus.pm
++++ lib/Mail/SpamAssassin/PerMsgStatus.pm
+@@ -916,16 +916,16 @@
+ $str .= shift @{$ary};
+ }
+ undef $ary;
+- chomp ($str); $str .= " [...]\n";
+
+ # in case the last line was huge, trim it back to around 200 chars
+ local $1;
+- $str =~ s/^(.{,200}).*$/$1/gs;
++ $str =~ s/^(.{200}).+$/$1 [...]/gm;
++ chomp ($str); $str .= "\n";
+
+ # now, some tidy-ups that make things look a bit prettier
+- $str =~ s/-----Original Message-----.*$//gs;
++ $str =~ s/-----Original Message-----.*$//gm;
+ $str =~ s/This is a multi-part message in MIME format\.//gs;
+- $str =~ s/[-_\*\.]{10,}//gs;
++ $str =~ s/[-_*.]{10,}//gs;
+ $str =~ s/\s+/ /gs;
+
+ # add "Content preview:" ourselves, so that the text aligns