aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/iriverter/Makefile28
-rw-r--r--multimedia/iriverter/distinfo3
-rw-r--r--multimedia/iriverter/pkg-descr5
-rw-r--r--multimedia/iriverter/pkg-plist44
5 files changed, 81 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 3e918d14ff42..6c63ded0182d 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -88,6 +88,7 @@
SUBDIR += handbrake-gtk2
SUBDIR += hayes
SUBDIR += helixplayer
+ SUBDIR += iriverter
SUBDIR += istanbul
SUBDIR += jahshaka
SUBDIR += k9copy
diff --git a/multimedia/iriverter/Makefile b/multimedia/iriverter/Makefile
new file mode 100644
index 000000000000..37bca70da0e4
--- /dev/null
+++ b/multimedia/iriverter/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: iriverter
+# Date created: 2006-09-05
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iriverter
+PORTVERSION= 0.16
+CATEGORIES= multimedia java
+MASTER_SITES= SOURCEFORGE
+
+MAINTAINER= multimedia@FreeBSD.org
+COMMENT= Cross-platform frontend to mencoder
+
+BUILD_DEPENDS= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31 \
+ ${LOCALBASE}/lib/libswt-gnome-gtk-3139.so:${PORTSDIR}/x11-toolkits/swt31
+RUN_DEPENDS= ${JAVALIBDIR}/swt.jar:${PORTSDIR}/x11-toolkits/swt31 \
+ ${LOCALBASE}/lib/libswt-gnome-gtk-3139.so:${PORTSDIR}/x11-toolkits/swt31 \
+ mencoder:${PORTSDIR}/multimedia/mplayer
+
+USE_JAVA= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-swt="${JAVALIBDIR}/swt.jar"
+
+.include <bsd.port.mk>
diff --git a/multimedia/iriverter/distinfo b/multimedia/iriverter/distinfo
new file mode 100644
index 000000000000..fcb1ad1c1512
--- /dev/null
+++ b/multimedia/iriverter/distinfo
@@ -0,0 +1,3 @@
+MD5 (iriverter-0.16.tar.bz2) = 43b3e046479f4273851e6a450b6b28bf
+SHA256 (iriverter-0.16.tar.bz2) = 2a7aaad4cd6f57704b52c80305c0fa1fffdae4476c6f171e583d54db3baf5582
+SIZE (iriverter-0.16.tar.bz2) = 305237
diff --git a/multimedia/iriverter/pkg-descr b/multimedia/iriverter/pkg-descr
new file mode 100644
index 000000000000..eb9c739dbd58
--- /dev/null
+++ b/multimedia/iriverter/pkg-descr
@@ -0,0 +1,5 @@
+A cross-platform frontend to mencoder designed to facilitate the conversion
+of almost any video format to one that is playable on various multimedia
+players.
+
+WWW: http://iriverter.sourceforge.net/
diff --git a/multimedia/iriverter/pkg-plist b/multimedia/iriverter/pkg-plist
new file mode 100644
index 000000000000..aeba0ee2030a
--- /dev/null
+++ b/multimedia/iriverter/pkg-plist
@@ -0,0 +1,44 @@
+bin/iriverter
+share/applications/iriverter.desktop
+%%DATADIR%%/doc/html/advanced.html
+%%DATADIR%%/doc/html/index.html
+%%DATADIR%%/doc/html/installing.html
+%%DATADIR%%/doc/html/introduction.html
+%%DATADIR%%/doc/html/linux.html
+%%DATADIR%%/doc/html/options.html
+%%DATADIR%%/doc/html/osx.html
+%%DATADIR%%/doc/html/other.html
+%%DATADIR%%/doc/html/playing.html
+%%DATADIR%%/doc/html/troubleshooting.html
+%%DATADIR%%/doc/html/using.html
+%%DATADIR%%/doc/images/caution.gif
+%%DATADIR%%/doc/images/convert-24.png
+%%DATADIR%%/doc/images/directory-24.png
+%%DATADIR%%/doc/images/dvd-24.png
+%%DATADIR%%/doc/images/home.gif
+%%DATADIR%%/doc/images/important.gif
+%%DATADIR%%/doc/images/next.gif
+%%DATADIR%%/doc/images/note.gif
+%%DATADIR%%/doc/images/prev.gif
+%%DATADIR%%/doc/images/singlevideo-24.png
+%%DATADIR%%/doc/images/tip.gif
+%%DATADIR%%/doc/images/toc-blank.gif
+%%DATADIR%%/doc/images/toc-minus.gif
+%%DATADIR%%/doc/images/toc-plus.gif
+%%DATADIR%%/doc/images/up.gif
+%%DATADIR%%/doc/images/warning.gif
+%%DATADIR%%/lib/iriverter.jar
+%%DATADIR%%/profiles/h300.profile
+%%DATADIR%%/profiles/pmp.profile
+%%DATADIR%%/profiles/u10.profile
+%%DATADIR%%/profiles/x5.profile
+%%DATADIR%%/profiles/zvm.profile
+share/pixmaps/iriverter.png
+@dirrmtry share/pixmaps
+@dirrm %%DATADIR%%/profiles
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/doc/images
+@dirrm %%DATADIR%%/doc/html
+@dirrm %%DATADIR%%/doc
+@dirrm %%DATADIR%%
+@dirrmtry share/applications